ipq806x: 6.6: refresh kernel patches
authorChristian Marangi <ansuelsmth@gmail.com>
Wed, 20 Mar 2024 00:48:41 +0000 (01:48 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 2 Apr 2024 21:46:01 +0000 (23:46 +0200)
Refresh kernel patches using make target/linux/refresh.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
16 files changed:
target/linux/ipq806x/patches-6.6/102-mtd-rootfs-conflicts-with-OpenWrt-auto-mounting.patch
target/linux/ipq806x/patches-6.6/107-10-ARM-dts-qcom-add-saw-for-l2-cache-and-kraitcc-for.patch
target/linux/ipq806x/patches-6.6/107-13-ARM-dts-qcom-add-opp-table-for-cpu-and-l2-for-ipq.patch
target/linux/ipq806x/patches-6.6/107-15-ARM-dts-qcom-add-multiple-missing-binding-for-cpu.patch
target/linux/ipq806x/patches-6.6/108-01-ARM-dts-qcom-fix-wrong-nad_pins-definition-for-ipq80.patch
target/linux/ipq806x/patches-6.6/108-02-ARM-dts-qcom-add-MDIO-dedicated-controller-node-for-.patch
target/linux/ipq806x/patches-6.6/114-01-devfreq-qcom-Add-L2-Krait-Cache-devfreq-scaling-driv.patch
target/linux/ipq806x/patches-6.6/114-02-ARM-dts-qcom-add-krait-cache-compatible-for-ipq806x-.patch
target/linux/ipq806x/patches-6.6/115-01-devfreq-add-ipq806x-fabric-scaling-driver.patch
target/linux/ipq806x/patches-6.6/115-02-ARM-dts-qcom-add-fab-scaling-node-for-ipq806x.patch
target/linux/ipq806x/patches-6.6/122-05-clk-qcom-clk-krait-generilize-div-functions.patch
target/linux/ipq806x/patches-6.6/130-mtd-rawnand-qcom-Fix-broken-misc_cmd_type-in-exec_op.patch
target/linux/ipq806x/patches-6.6/850-soc-add-qualcomm-syscon.patch
target/linux/ipq806x/patches-6.6/900-arm-add-cmdline-override.patch
target/linux/ipq806x/patches-6.6/901-02-ARM-decompressor-add-option-to-ignore-MEM-ATAGs.patch
target/linux/ipq806x/patches-6.6/902-ARM-decompressor-support-for-ATAGs-rootblock-parsing.patch

index e0c195f1ab94208830e7061abb49083472e64670..d70be98aca93f63073a692353d9757854023967c 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -51,7 +51,11 @@ static struct mtd_info *allocate_partiti
+@@ -57,7 +57,11 @@ static struct mtd_info *allocate_partiti
  
        /* allocate the partition structure */
        child = kzalloc(sizeof(*child), GFP_KERNEL);
index 228368b6cd733c3eea5f23fb88cb3f5c5802f802..83eb6f38cdbecf8feddc5fd448e897f7ff5fa59b 100644 (file)
@@ -16,7 +16,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
-@@ -301,6 +301,12 @@
+@@ -302,6 +302,12 @@
        };
  
        clocks {
@@ -29,7 +29,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
                cxo_board: cxo_board {
                        compatible = "fixed-clock";
                        #clock-cells = <0>;
-@@ -575,7 +581,7 @@
+@@ -587,7 +593,7 @@
                };
  
                saw0: regulator@2089000 {
@@ -38,7 +38,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
                        reg = <0x02089000 0x1000>, <0x02009000 0x1000>;
                        regulator;
                };
-@@ -591,11 +612,27 @@
+@@ -602,11 +608,27 @@
                };
  
                saw1: regulator@2099000 {
index b6359a946ebd5eca86a0cf9d23ad57dee3151d3a..1cf57d018f1416bfafbd642730f7a8c41605c904 100644 (file)
@@ -23,7 +23,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
-@@ -48,6 +48,105 @@
+@@ -49,6 +49,105 @@
                };
        };
  
index 55f02ac5aa7358b26fa040508f6dfb24b033dcd0..e4c9f73c83eb7e3402c254548866767af247408f 100644 (file)
@@ -59,7 +59,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
                L2: l2-cache {
                        compatible = "cache";
                        cache-level = <2>;
-                       cache-unified;
+                       cache-unified;
 +                      qcom,saw = <&saw_l2>;
 +
 +                      clocks = <&kraitcc 4>;
index a06dd00dfc53f4838cae66daa7ff189bfe7d9ca4..a3ac606ae9e63a28acd0e5faf22fe9028ac262c0 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
-@@ -599,12 +599,9 @@
+@@ -600,12 +600,9 @@
                        };
  
                        nand_pins: nand_pins {
index 8f6f8a287a0cb773cd1039ac710222e4e738fc96..b4aa04d7d254c8c213236d5817347175566fdbde 100644 (file)
@@ -147,7 +147,7 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
        mdio1: mdio-1 {
                status = "okay";
                compatible = "virtual,mdio-gpio";
-@@ -222,6 +155,131 @@
+@@ -337,6 +212,131 @@
        status = "okay";
  };
  
@@ -281,7 +281,7 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
  
 --- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
-@@ -476,6 +476,20 @@
+@@ -1429,6 +1429,20 @@
                        status = "disabled";
                };
  
index 9de73288799c197b0fa4a53d4197ed0bc3b23a25..9780f6a30b8792803a06922c7dc089e116486299 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
 
 --- a/drivers/devfreq/Kconfig
 +++ b/drivers/devfreq/Kconfig
-@@ -151,6 +151,17 @@ config ARM_SUN8I_A33_MBUS_DEVFREQ
+@@ -150,6 +150,17 @@ config ARM_SUN8I_A33_MBUS_DEVFREQ
          This adds the DEVFREQ driver for the MBUS controller in some
          Allwinner sun8i (A33 through H3) and sun50i (A64 and H5) SoCs.
  
index 77b6f926bdadda0b90b0118aa8f011749b2a3b6a..92ff75afe6e1112b97badcdc6a7262c534f5eea0 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
        };
  
        opp_table_l2: opp_table_l2 {
-@@ -1409,6 +1399,17 @@
+@@ -1392,6 +1381,17 @@
                        #reset-cells = <1>;
                };
  
index c9cd3ebdf7377baa6ecec884cbeeb86bc641c617..c359eda2a5102324d0476564504b3e9871c98c09 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
 
 --- a/drivers/devfreq/Kconfig
 +++ b/drivers/devfreq/Kconfig
-@@ -162,6 +162,17 @@ config ARM_KRAIT_CACHE_DEVFREQ
+@@ -161,6 +161,17 @@ config ARM_KRAIT_CACHE_DEVFREQ
          based on the max frequency across all core and the range set in the device
          dts. If provided this scale also the regulator attached to the l2 cache.
  
index 418e3248adfbc6b424772f3c10041a654a319260..bbdbedd6c23f1377566481a0f235ed991a893708 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
        thermal-zones {
                sensor0-thermal {
                        polling-delay-passive = <0>;
-@@ -1409,6 +1421,13 @@
+@@ -1392,6 +1404,13 @@
                        operating-points-v2 = <&opp_table_l2>;
                };
  
index 356659d9c083ccb06bc4079a65af1bba7cec4b80..45b94ed649d3c5ddb471762da914485b2384d08a 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
 +      req->best_parent_rate = clk_hw_round_rate(clk_hw_get_parent(hw),
 +                                                req->rate * d->divisor);
 +      req->rate = DIV_ROUND_UP(req->best_parent_rate, d->divisor);
-       return 0;
+       return 0;
  }
  
 -static int krait_div2_set_rate(struct clk_hw *hw, unsigned long rate,
index 5fc25995223061b6c49d542da2d818575edc27c8..caa5b070e4a3f45a9b2f2678da01e392ebc87ad3 100644 (file)
@@ -1,4 +1,4 @@
-From b25aac1f55c29048e5a6ab24ab0e2aea12cb4887 Mon Sep 17 00:00:00 2001
+From 9732c4f2d93a4a39ffc903c88ab7d531a8bb2e74 Mon Sep 17 00:00:00 2001
 From: Christian Marangi <ansuelsmth@gmail.com>
 Date: Wed, 20 Mar 2024 00:47:58 +0100
 Subject: [PATCH] mtd: rawnand: qcom: Fix broken misc_cmd_type in exec_op
@@ -8,10 +8,6 @@ misc_cmd_type in exec_op have multiple problems. With commit a82990c8a409
 reworked and generalized but actually dropped the handling of the
 RESET_DEVICE command.
 
-The rework itself was correct with supporting case where a single misc
-command is handled, but became problematic by the addition of exiting
-early if we didn't had an ERASE or an OP_PROGRAM_PAGE operation.
-
 Also additional logic was added without clear explaination causing the
 erase command to be broken on testing it on a ipq806x nandc.
 
@@ -25,11 +21,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
  drivers/mtd/nand/raw/qcom_nandc.c | 7 +++----
  1 file changed, 3 insertions(+), 4 deletions(-)
 
-diff --git a/drivers/mtd/nand/raw/qcom_nandc.c b/drivers/mtd/nand/raw/qcom_nandc.c
-index b079605c84d3..b8cff9240b28 100644
 --- a/drivers/mtd/nand/raw/qcom_nandc.c
 +++ b/drivers/mtd/nand/raw/qcom_nandc.c
-@@ -2815,7 +2815,7 @@ static int qcom_misc_cmd_type_exec(struct nand_chip *chip, const struct nand_sub
+@@ -2815,7 +2815,7 @@ static int qcom_misc_cmd_type_exec(struc
                              host->cfg0_raw & ~(7 << CW_PER_PAGE));
                nandc_set_reg(chip, NAND_DEV0_CFG1, host->cfg1_raw);
                instrs = 3;
@@ -38,7 +32,7 @@ index b079605c84d3..b8cff9240b28 100644
                return 0;
        }
  
-@@ -2830,9 +2830,8 @@ static int qcom_misc_cmd_type_exec(struct nand_chip *chip, const struct nand_sub
+@@ -2830,9 +2830,8 @@ static int qcom_misc_cmd_type_exec(struc
        nandc_set_reg(chip, NAND_EXEC_CMD, 1);
  
        write_reg_dma(nandc, NAND_FLASH_CMD, instrs, NAND_BAM_NEXT_SGL);
@@ -50,6 +44,3 @@ index b079605c84d3..b8cff9240b28 100644
  
        write_reg_dma(nandc, NAND_EXEC_CMD, 1, NAND_BAM_NEXT_SGL);
        read_reg_dma(nandc, NAND_FLASH_STATUS, 1, NAND_BAM_NEXT_SGL);
--- 
-2.43.0
-
index 397c4481ab1956c99cf72d2e8101d70d7ddd8f4f..3fa60a6abcf9bf0dd60fc1941da6da7217bdb6e2 100644 (file)
@@ -2,17 +2,17 @@ From: Christian Lamparter <chunkeey@googlemail.com>
 Subject: SoC: add qualcomm syscon
 --- a/drivers/soc/qcom/Makefile
 +++ b/drivers/soc/qcom/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_QCOM_SOCINFO)   += socinfo.o
+@@ -26,6 +26,7 @@ obj-$(CONFIG_QCOM_SOCINFO)   += socinfo.o
  obj-$(CONFIG_QCOM_SPM)                += spm.o
  obj-$(CONFIG_QCOM_STATS)      += qcom_stats.o
  obj-$(CONFIG_QCOM_WCNSS_CTRL) += wcnss_ctrl.o
 +obj-$(CONFIG_QCOM_TCSR)        += qcom_tcsr.o
  obj-$(CONFIG_QCOM_APR) += apr.o
  obj-$(CONFIG_QCOM_LLCC) += llcc-qcom.o
- obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
+ obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) +=       kryo-l2-accessors.o
 --- a/drivers/soc/qcom/Kconfig
 +++ b/drivers/soc/qcom/Kconfig
-@@ -213,6 +213,13 @@ config QCOM_STATS
+@@ -252,6 +252,13 @@ config QCOM_STATS
          various SoC level low power modes statistics and export to debugfs
          interface.
  
index c9583549d0c39b925043d62c0f2a445c157e9315..f8bd1674b80ab4f3e4b2b84f4bdd7c8ba81b8535 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1589,6 +1589,14 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1568,6 +1568,14 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
  
  endchoice
  
@@ -17,7 +17,7 @@
        default ""
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -1187,6 +1187,17 @@ int __init early_init_dt_scan_chosen(cha
+@@ -1189,6 +1189,17 @@ int __init early_init_dt_scan_chosen(cha
        if (p != NULL && l > 0)
                strlcat(cmdline, p, min_t(int, strlen(cmdline) + (int)l, COMMAND_LINE_SIZE));
  
index 2e4c4de545c54e81c391d9e69a11d5339ca8772d..ce46f48fa532b7ad50ecaff98dc62f3106f01544 100644 (file)
@@ -20,7 +20,7 @@ Acked-by: Linus Walleij <linus.walleij@linaro.org>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1570,6 +1570,18 @@ config ARM_ATAG_DTB_COMPAT
+@@ -1549,6 +1549,18 @@ config ARM_ATAG_DTB_COMPAT
          bootloaders, this option allows zImage to extract the information
          from the ATAG list and store it at run time into the appended DTB.
  
@@ -41,7 +41,7 @@ Acked-by: Linus Walleij <linus.walleij@linaro.org>
        default ARM_ATAG_DTB_COMPAT_CMDLINE_FROM_BOOTLOADER
 --- a/arch/arm/boot/compressed/atags_to_fdt.c
 +++ b/arch/arm/boot/compressed/atags_to_fdt.c
-@@ -169,6 +169,10 @@ int atags_to_fdt(void *atag_list, void *
+@@ -170,6 +170,10 @@ int atags_to_fdt(void *atag_list, void *
                                setprop_string(fdt, "/chosen", "bootargs",
                                               atag->u.cmdline.cmdline);
                } else if (atag->hdr.tag == ATAG_MEM) {
index 60b80fefe1757153eb98a4ef539c7f136f00dca9..1832b6bead6cf5236a565b575e965c97f46484a0 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1599,6 +1599,16 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1578,6 +1578,16 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
@@ -43,9 +43,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
  config CMDLINE_OVERRIDE
 --- a/arch/arm/boot/compressed/atags_to_fdt.c
 +++ b/arch/arm/boot/compressed/atags_to_fdt.c
-@@ -3,7 +3,8 @@
- #include <asm/setup.h>
+@@ -4,7 +4,8 @@
  #include <libfdt.h>
+ #include "misc.h"
  
 -#if defined(CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND)
 +#if defined(CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND) || \
@@ -53,7 +53,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
  #define do_extend_cmdline 1
  #else
  #define do_extend_cmdline 0
-@@ -69,6 +70,83 @@ static uint32_t get_cell_size(const void
+@@ -70,6 +71,83 @@ static uint32_t get_cell_size(const void
        return cell_size;
  }
  
@@ -137,7 +137,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
  static void merge_fdt_bootargs(void *fdt, const char *fdt_cmdline)
  {
        char cmdline[COMMAND_LINE_SIZE];
-@@ -86,13 +164,23 @@ static void merge_fdt_bootargs(void *fdt
+@@ -87,13 +165,23 @@ static void merge_fdt_bootargs(void *fdt
                        ptr += len - 1;
                }
  
@@ -177,7 +177,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
  #include <linux/bootconfig.h>
  #include <linux/console.h>
  #include <linux/nmi.h>
-@@ -995,6 +996,17 @@ asmlinkage __visible void __init __no_sa
+@@ -929,6 +930,17 @@ void start_kernel(void)
        pr_notice("Kernel command line: %s\n", saved_command_line);
        /* parameters may set static keys */
        jump_label_init();