tools: zstd: override max safe compression level
authorChristian Marangi <ansuelsmth@gmail.com>
Fri, 5 Apr 2024 12:29:50 +0000 (14:29 +0200)
committerRobert Marko <robimarko@gmail.com>
Sat, 6 Apr 2024 09:24:18 +0000 (11:24 +0200)
ZTSD limits the safe compression level to a max of 19 as 20 to 22 cause
increased RAM usage. Higher levels require --ultra arg passed.

There isn't currently a way to set --ultra using ENV options similar to
ZSTD_CLEVEL and ZSTD_CLEVEL is limited to 19.

To fix this, we can increase the max safe compression level by providing
a custom ZSTDCLI_CLEVEL_MAX value with CFLAGS.

The max safe level is increased to 20.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
tools/zstd/Makefile

index 3f69c6d497b2da352061af32156ddc2e27289f99..d194ecd005c39487cc03d2f44e80cec92b7d32af 100644 (file)
@@ -17,6 +17,9 @@ include $(INCLUDE_DIR)/host-build.mk
 
 HOSTCC:= $(HOSTCC_NOCACHE)
 
+HOST_CFLAGS += \
+       -DZSTDCLI_CLEVEL_MAX=20
+
 HOST_MAKE_FLAGS += \
        ZSTD_LEGACY_SUPPORT=7 \
        BACKTRACE=0 \