kernel: 6.6: modules: netdevices: lan743x: add missing dependency
authorMieczyslaw Nalewaj <namiltd@yahoo.com>
Tue, 2 Apr 2024 06:23:46 +0000 (08:23 +0200)
committerRobert Marko <robimarko@gmail.com>
Thu, 4 Apr 2024 06:56:10 +0000 (08:56 +0200)
Fix error: Package kmod-lan743x is missing dependencies for the following libraries:
fixed_phy.ko

Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
package/kernel/linux/modules/netdevices.mk

index 9fdbdc9ec7ae21948531a69c9ddeb6bb01610e48..906f866a6b11bad97004c4685c0f9b85498c76d4 100644 (file)
@@ -1742,7 +1742,7 @@ $(eval $(call KernelPackage,atlantic))
 define KernelPackage/lan743x
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Microchip LAN743x PCI Express Gigabit Ethernet NIC
-  DEPENDS:=@PCI_SUPPORT +kmod-ptp +kmod-mdio-devres
+  DEPENDS:=@PCI_SUPPORT +kmod-ptp +kmod-mdio-devres +!LINUX_6_1:kmod-fixed-phy
   KCONFIG:=CONFIG_LAN743X
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/microchip/lan743x.ko
   AUTOLOAD:=$(call AutoProbe,lan743x)