kernel: vfio: flag vfio_virqfd as only kernel 6.2 and earlier
authorMathew McBride <matt@traverse.com.au>
Fri, 15 Mar 2024 03:16:05 +0000 (14:16 +1100)
committerRobert Marko <robimarko@gmail.com>
Thu, 4 Apr 2024 06:56:10 +0000 (08:56 +0200)
Kernel 6.2 folded virqfd (eventd interface for VFIO interrupts)
into the base vfio module, it is no longer a tristate option.

Change suggested by vincejv on GitHub:
https://github.com/openwrt/openwrt/pull/14868#issuecomment-1998260124

Signed-off-by: Mathew McBride <matt@traverse.com.au>
package/kernel/linux/modules/virt.mk

index f45cb176147fc8e6e7cb37bf508654c82fed8cc9..a408ac9b1498b9659529cbbb59c0637ec2090660 100644 (file)
@@ -84,9 +84,9 @@ define KernelPackage/vfio
        CONFIG_VFIO_MDEV=n
   FILES:= \
        $(LINUX_DIR)/drivers/vfio/vfio.ko \
-       $(LINUX_DIR)/drivers/vfio/vfio_virqfd.ko \
+       $(LINUX_DIR)/drivers/vfio/vfio_virqfd.ko@lt6.2 \
        $(LINUX_DIR)/drivers/vfio/vfio_iommu_type1.ko
-  AUTOLOAD:=$(call AutoProbe,vfio vfio_iommu_type1 vfio_virqfd)
+  AUTOLOAD:=$(call AutoProbe,vfio vfio_iommu_type1 +LINUX_6_1:vfio_virqfd)
 endef
 
 define KernelPackage/vfio/description