kernel: bump 6.1 to 6.1.79
authorJohn Audia <therealgraysky@proton.me>
Fri, 23 Feb 2024 20:40:12 +0000 (15:40 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 24 Feb 2024 18:25:02 +0000 (19:25 +0100)
Changelog: https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.1.79

Manually rebased:
ath79/patches-6.1/900-unaligned_access_hacks.patch

All other patches automatically rebased.

Build system: x86/64
Build-tested: x86/64/AMD Cezanne, ramips/tplink_archer-a6-v3, flogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: x86/64/AMD Cezanne, ramips/tplink_archer-a6-v3, flogic/xiaomi_redmi-router-ax6000-ubootmod

Signed-off-by: John Audia <therealgraysky@proton.me>
17 files changed:
include/kernel-6.1
target/linux/ath79/patches-6.1/900-unaligned_access_hacks.patch
target/linux/bcm27xx/patches-6.1/950-0106-Add-dwc_otg-driver.patch
target/linux/bcm27xx/patches-6.1/950-0918-irqchip-irq-brcmstb-l2-Add-config-for-2711-controlle.patch
target/linux/generic/backport-6.1/771-v6.7-02-net-stmmac-move-TX-timer-arm-after-DMA-enable.patch
target/linux/generic/backport-6.1/827-v6.3-0002-of-property-make-.-cells-optional-for-simple-props.patch
target/linux/generic/backport-6.1/827-v6.3-0003-of-property-add-nvmem-cell-cells-property.patch
target/linux/generic/hack-6.1/204-module_strip.patch
target/linux/generic/hack-6.1/221-module_exports.patch
target/linux/generic/hack-6.1/253-ksmbd-config.patch
target/linux/generic/hack-6.1/930-Revert-Revert-Revert-driver-core-Set-fw_devlink-on-b.patch
target/linux/generic/pending-6.1/103-kbuild-export-SUBARCH.patch
target/linux/generic/pending-6.1/203-kallsyms_uncompressed.patch
target/linux/generic/pending-6.1/920-mangle_bootargs.patch
target/linux/imx/patches-6.1/301-ARM-dts-imx6q-apalis-ixora-make-switch3-reset-button.patch
target/linux/ipq40xx/patches-6.1/701-net-dsa-add-out-of-band-tagging-protocol.patch
target/linux/ramips/patches-6.1/825-i2c-MIPS-adds-ralink-I2C-driver.patch

index 95dede372aab0b05ee6b48e409b0cd7ba6061d66..6c05ca0236eed26efc8dcb4c54366ffd468f9eec 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-6.1 = .78
-LINUX_KERNEL_HASH-6.1.78 = 65206b969831236849c9906eba267e715734a93808e9909fd9b4f12eea10d689
+LINUX_VERSION-6.1 = .79
+LINUX_KERNEL_HASH-6.1.79 = faa49ca22fb55ed4d5ca2a55e07dd10e4e171cfc3b92568a631453cd2068b39b
index b6f6d63f6847252fc6d08025f863d2ca5a24878e..945143867ae37dd45a5506b58e007fdca3bb3cad 100644 (file)
@@ -86,7 +86,7 @@ SVN-Revision: 35130
        } while (word != stop);
  
        return csum_fold(csum);
-@@ -179,73 +183,6 @@ static inline __sum16 ip_compute_csum(co
+@@ -179,74 +183,6 @@ static inline __sum16 ip_compute_csum(co
        return csum_fold(csum_partial(buff, len, 0));
  }
  
@@ -152,7 +152,8 @@ SVN-Revision: 35130
 -      "       .set    pop"
 -      : "=&r" (sum), "=&r" (tmp)
 -      : "r" (saddr), "r" (daddr),
--        "0" (htonl(len)), "r" (htonl(proto)), "r" (sum));
+-        "0" (htonl(len)), "r" (htonl(proto)), "r" (sum)
+-      : "memory");
 -
 -      return csum_fold(sum);
 -}
index 02fc0ed49a33bca799365fc0b365a5f4984d4388..f8ab3b04a103f4796d721ed4e3a2313e82ec4f1e 100644 (file)
@@ -1185,7 +1185,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5669,7 +5669,7 @@ static void port_event(struct usb_hub *h
+@@ -5677,7 +5677,7 @@ static void port_event(struct usb_hub *h
                port_dev->over_current_count++;
                port_over_current_notify(port_dev);
  
index 5ea212d4a7b482db77c7373e4e1e8defe35ea7b8..039c5fd74f073cb8274c3d02e0897bb6deb2eb4b 100644 (file)
@@ -52,7 +52,7 @@ Signed-off-by: Dom Cobley <popcornmix@gmail.com>
  /* L2 intc private data structure */
  struct brcmstb_l2_intc_data {
        struct irq_domain *domain;
-@@ -286,11 +296,18 @@ static int __init brcmstb_l2_lvl_intc_of
+@@ -289,11 +299,18 @@ static int __init brcmstb_l2_lvl_intc_of
        return brcmstb_l2_intc_of_init(np, parent, &l2_lvl_intc_init);
  }
  
index 4e9e951598b54e840d5c0798e1186ee90919d5c8..95dd24881b665250ccbe9bc1ea2e32053d9aa989 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Paolo Abeni <pabeni@redhat.com>
  
        __netif_tx_unlock_bh(netdev_get_tx_queue(priv->dev, queue));
  
-@@ -5485,12 +5489,13 @@ static int stmmac_napi_poll_tx(struct na
+@@ -5488,12 +5492,13 @@ static int stmmac_napi_poll_tx(struct na
        struct stmmac_channel *ch =
                container_of(napi, struct stmmac_channel, tx_napi);
        struct stmmac_priv *priv = ch->priv_data;
@@ -57,7 +57,7 @@ Signed-off-by: Paolo Abeni <pabeni@redhat.com>
        work_done = min(work_done, budget);
  
        if (work_done < budget && napi_complete_done(napi, work_done)) {
-@@ -5501,6 +5506,10 @@ static int stmmac_napi_poll_tx(struct na
+@@ -5504,6 +5509,10 @@ static int stmmac_napi_poll_tx(struct na
                spin_unlock_irqrestore(&ch->lock, flags);
        }
  
@@ -68,7 +68,7 @@ Signed-off-by: Paolo Abeni <pabeni@redhat.com>
        return work_done;
  }
  
-@@ -5509,12 +5518,13 @@ static int stmmac_napi_poll_rxtx(struct
+@@ -5512,12 +5521,13 @@ static int stmmac_napi_poll_rxtx(struct
        struct stmmac_channel *ch =
                container_of(napi, struct stmmac_channel, rxtx_napi);
        struct stmmac_priv *priv = ch->priv_data;
@@ -83,7 +83,7 @@ Signed-off-by: Paolo Abeni <pabeni@redhat.com>
        tx_done = min(tx_done, budget);
  
        rx_done = stmmac_rx_zc(priv, budget, chan);
-@@ -5539,6 +5549,10 @@ static int stmmac_napi_poll_rxtx(struct
+@@ -5542,6 +5552,10 @@ static int stmmac_napi_poll_rxtx(struct
                spin_unlock_irqrestore(&ch->lock, flags);
        }
  
index 3af514c42dfd5bb2f05fceaf582406916f4634e7..66c29126b6be8eda9dc0668bd36f6c6aa213b1dc 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/drivers/of/property.c
 +++ b/drivers/of/property.c
-@@ -1144,8 +1144,8 @@ static struct device_node *parse_prop_ce
+@@ -1146,8 +1146,8 @@ static struct device_node *parse_prop_ce
        if (strcmp(prop_name, list_name))
                return NULL;
  
index 025f094987a6806ca6e70c692a77da3b9551ba3a..07354d7da7c0036c934497cef607ad4da598c6ea 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/drivers/of/property.c
 +++ b/drivers/of/property.c
-@@ -1249,7 +1249,7 @@ DEFINE_SIMPLE_PROP(dmas, "dmas", "#dma-c
+@@ -1251,7 +1251,7 @@ DEFINE_SIMPLE_PROP(dmas, "dmas", "#dma-c
  DEFINE_SIMPLE_PROP(power_domains, "power-domains", "#power-domain-cells")
  DEFINE_SIMPLE_PROP(hwlocks, "hwlocks", "#hwlock-cells")
  DEFINE_SIMPLE_PROP(extcon, "extcon", NULL)
index bd168649f2ea2048ee1a6862101c7a5e5f926de8..9fefd0bd6eff2aab0d4e95937ecea1f76c422e74 100644 (file)
@@ -141,7 +141,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/scripts/mod/modpost.c
 +++ b/scripts/mod/modpost.c
-@@ -1781,7 +1781,9 @@ static void read_symbols(const char *mod
+@@ -1785,7 +1785,9 @@ static void read_symbols(const char *mod
                symname = remove_dot(info.strtab + sym->st_name);
  
                handle_symbol(mod, &info, sym, symname);
@@ -151,7 +151,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }
  
        for (sym = info.symtab_start; sym < info.symtab_stop; sym++) {
-@@ -1944,8 +1946,10 @@ static void add_header(struct buffer *b,
+@@ -1948,8 +1950,10 @@ static void add_header(struct buffer *b,
        buf_printf(b, "BUILD_SALT;\n");
        buf_printf(b, "BUILD_LTO_INFO;\n");
        buf_printf(b, "\n");
@@ -162,7 +162,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        buf_printf(b, "\n");
        buf_printf(b, "__visible struct module __this_module\n");
        buf_printf(b, "__section(\".gnu.linkonce.this_module\") = {\n");
-@@ -1959,8 +1963,10 @@ static void add_header(struct buffer *b,
+@@ -1963,8 +1967,10 @@ static void add_header(struct buffer *b,
        buf_printf(b, "\t.arch = MODULE_ARCH_INIT,\n");
        buf_printf(b, "};\n");
  
@@ -173,7 +173,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        buf_printf(b,
                   "\n"
-@@ -1968,8 +1974,10 @@ static void add_header(struct buffer *b,
+@@ -1972,8 +1978,10 @@ static void add_header(struct buffer *b,
                   "MODULE_INFO(retpoline, \"Y\");\n"
                   "#endif\n");
  
@@ -184,7 +184,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (strstarts(mod->name, "tools/testing"))
                buf_printf(b, "\nMODULE_INFO(test, \"Y\");\n");
-@@ -2065,11 +2073,13 @@ static void add_depends(struct buffer *b
+@@ -2069,11 +2077,13 @@ static void add_depends(struct buffer *b
  
  static void add_srcversion(struct buffer *b, struct module *mod)
  {
@@ -198,7 +198,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  static void write_buf(struct buffer *b, const char *fname)
-@@ -2155,7 +2165,9 @@ static void write_mod_c_file(struct modu
+@@ -2159,7 +2169,9 @@ static void write_mod_c_file(struct modu
        add_exported_symbols(&buf, mod);
        add_versions(&buf, mod);
        add_depends(&buf, mod);
index d1ff81613a87fb85bb5cf0dbbec733392d9ce49d..967510bcb6d92f05024ad7cfaa5da52a6d6f226e 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /* Align . to a 8 byte boundary equals to maximum function alignment. */
  #define ALIGN_FUNCTION()  . = ALIGN(8)
  
-@@ -512,14 +522,14 @@
+@@ -511,14 +521,14 @@
        /* Kernel symbol table: Normal symbols */                       \
        __ksymtab         : AT(ADDR(__ksymtab) - LOAD_OFFSET) {         \
                __start___ksymtab = .;                                  \
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                __stop___ksymtab_gpl = .;                               \
        }                                                               \
                                                                        \
-@@ -539,7 +549,7 @@
+@@ -538,7 +548,7 @@
                                                                        \
        /* Kernel symbol table: strings */                              \
          __ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) {       \
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-@@ -1048,6 +1058,8 @@
+@@ -1042,6 +1052,8 @@
  #define COMMON_DISCARDS                                                       \
        SANITIZER_DISCARDS                                              \
        PATCHABLE_DISCARDS                                              \
index 4bb5eb9a6c5b74097ddd6647ea5b59775ac9de6e..a57c914180b84eb5cfcb1469b453c09c7ae83803 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH] Kconfig: add tristate for OID and ASNI string
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -2004,7 +2004,7 @@ config PADATA
+@@ -2013,7 +2013,7 @@ config PADATA
        bool
  
  config ASN1
index 98081c4b64b14cd04d5ea4d01ea86d2734f4710c..04aaab7adf162f701d651a03e7e9e0dc6625fb8a 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
 
 --- a/drivers/base/core.c
 +++ b/drivers/base/core.c
-@@ -1700,7 +1700,7 @@ static void device_links_purge(struct de
+@@ -1702,7 +1702,7 @@ static void device_links_purge(struct de
  #define FW_DEVLINK_FLAGS_RPM          (FW_DEVLINK_FLAGS_ON | \
                                         DL_FLAG_PM_RUNTIME)
  
index e6480ac03e331bb8575a43dbf964011e6bf01ed4..c8c0efaecfa1bb1de9e6ae335ca0a6137f8b2183 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -606,7 +606,7 @@ endif
+@@ -605,7 +605,7 @@ endif
  # Allows the usage of unstable features in stable compilers.
  export RUSTC_BOOTSTRAP := 1
  
index ce93b73af64e09b4eae9b2a2b57dacec7b93e2e1..78ed262b786c6a05ca633220fca47f078958a016 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1482,6 +1482,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
+@@ -1491,6 +1491,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
          the unaligned access emulation.
          see arch/parisc/kernel/unaligned.c for reference
  
@@ -105,7 +105,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/scripts/link-vmlinux.sh
 +++ b/scripts/link-vmlinux.sh
-@@ -160,6 +160,10 @@ kallsyms()
+@@ -165,6 +165,10 @@ kallsyms()
                kallsymopt="${kallsymopt} --lto-clang"
        fi
  
index db7274e7aadb94ce9b1d8bb4e1a9dbe63ee62852..4552b4cd66c124f3b76231bcb5a1522af4228553 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1827,6 +1827,15 @@ config EMBEDDED
+@@ -1836,6 +1836,15 @@ config EMBEDDED
          an embedded system so certain expert options are available
          for configuration.
  
index 6f8c7ad7278ee6c3a46ea371f97c2fb4537ff45d..95f572f35e62b1c4c4d469d9010b03df115e52d9 100644 (file)
@@ -63,7 +63,7 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
        reg_3v3_vmmc: regulator-3v3-vmmc {
                compatible = "regulator-fixed";
                enable-active-high;
-@@ -260,6 +271,12 @@
+@@ -262,6 +273,12 @@
                >;
        };
  
index ba50d64a7677e187a5b3a445144f22f410bfa526..ab01e6704a00016a694d299e2d326dc62e6796b2 100644 (file)
@@ -136,7 +136,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
  #include <net/dst.h>
  #include <net/sock.h>
  #include <net/checksum.h>
-@@ -4516,6 +4520,9 @@ static const u8 skb_ext_type_len[] = {
+@@ -4517,6 +4521,9 @@ static const u8 skb_ext_type_len[] = {
  #if IS_ENABLED(CONFIG_MCTP_FLOWS)
        [SKB_EXT_MCTP] = SKB_EXT_CHUNKSIZEOF(struct mctp_flow),
  #endif
@@ -146,7 +146,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
  };
  
  static __always_inline unsigned int skb_ext_total_length(void)
-@@ -4536,6 +4543,9 @@ static __always_inline unsigned int skb_
+@@ -4537,6 +4544,9 @@ static __always_inline unsigned int skb_
  #if IS_ENABLED(CONFIG_MCTP_FLOWS)
                skb_ext_type_len[SKB_EXT_MCTP] +
  #endif
index 09f62ad51bcfc091dc3ffdec08bfddc28977d3b7..461cf6e222423c9d00deee073a0a7a2c54bb17cd 100644 (file)
@@ -59,7 +59,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        depends on ARCH_RENESAS || COMPILE_TEST
 --- a/drivers/i2c/busses/Makefile
 +++ b/drivers/i2c/busses/Makefile
-@@ -97,6 +97,7 @@ obj-$(CONFIG_I2C_PCA_PLATFORM)       += i2c-pc
+@@ -95,6 +95,7 @@ obj-$(CONFIG_I2C_PCA_PLATFORM)       += i2c-pc
  obj-$(CONFIG_I2C_PNX)         += i2c-pnx.o
  obj-$(CONFIG_I2C_PXA)         += i2c-pxa.o
  obj-$(CONFIG_I2C_PXA_PCI)     += i2c-pxa-pci.o