ipq806x: work-around borked QCA SDK bootloader
authorDaniel Golle <daniel@makrotopia.org>
Sat, 6 Mar 2021 19:04:15 +0000 (19:04 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 6 Mar 2021 19:05:53 +0000 (19:05 +0000)
The bootloader of many ipq806x boards seems to require the config node
of the FIT image to be 'config@1' (or a secific different value).
This requirement used to be implicitely satisfied because OpenWrt used
to also call the configuration node inside a FIT image 'config@1'.
However, as recent U-Boot now prohibits the use of the '@' symbol as
part of node names, this was changed by
commit 5ec60cbe9d ("scripts: mkits.sh: replace @ with - in nodes")
Explicitely restore the default name of the configuration node to
'config@1' on ipq806x.
(ipq807x is unaffected as DEVICE_DTS_CONFIG default is set
"config@hk01" in target/linux/ipq807x/image/Makefile)

Reported-by: Chen Minqiang <ptpt52@gmail.com>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/ipq806x/image/Makefile

index cb4058f4a1f06b23679a1a57ed5afb496f405b77..6c091be33558c4ffeaf1acd7da89fa7f341cbdab 100644 (file)
@@ -28,6 +28,7 @@ define Device/Default
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_LOADADDR = 0x42208000
        DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
+       DEVICE_DTS_CONFIG := config@1
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
        IMAGE/sysupgrade.bin/squashfs :=