ipq40xx: work-around borked QCA SDK bootloader
authorDaniel Golle <daniel@makrotopia.org>
Sat, 6 Mar 2021 18:59:16 +0000 (18:59 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 6 Mar 2021 19:05:53 +0000 (19:05 +0000)
The bootloader of many ipq40xx boards seems to require the config node
of the FIT image to be 'config@1' (or a secific different value).
This requirement used to be implicitely satisfied because OpenWrt used
to also call the configuration node inside a FIT image 'config@1'.
However, as recent U-Boot now prohibits the use of the '@' symbol as
part of node names, this was changed by
commit 5ec60cbe9d ("scripts: mkits.sh: replace @ with - in nodes")
Explicitely restore the default name of the configuration node to
'config@1' on ipq40xx.

Reported-by: Chen Minqiang <ptpt52@gmail.com>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/ipq40xx/image/Makefile

index a7710cfe0556a92e1555c38d0b39d81c43867017..5851b298753680c9e0cb14b00971c0ee06539bdf 100644 (file)
@@ -6,6 +6,7 @@ define Device/Default
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_LOADADDR := 0x80208000
        DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
+       DEVICE_DTS_CONFIG := config@1
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
        IMAGE/sysupgrade.bin/squashfs :=