kernel: bump 4.19 to 4.19.80
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 28 Oct 2019 13:16:20 +0000 (14:16 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 30 Oct 2019 10:16:25 +0000 (11:16 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.19/950-0129-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch
target/linux/brcm2708/patches-4.19/950-0548-usb-xhci-hack-xhci_urb_enqueue-to-support-hid.mousep.patch
target/linux/brcm2708/patches-4.19/950-0652-Revert-usb-xhci-hack-xhci_urb_enqueue-to-support-hid.patch
target/linux/brcm2708/patches-4.19/950-0654-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch
target/linux/brcm2708/patches-4.19/950-0802-regulator-gpio-Allow-nonexclusive-GPIO-access.patch
target/linux/brcm2708/patches-4.19/950-0803-gpio-Enable-nonexclusive-gpiods-from-DT-nodes.patch
target/linux/ipq40xx/patches-4.19/700-net-add-qualcomm-mdio.patch
target/linux/ipq40xx/patches-4.19/901-arm-boot-add-dts-files.patch

index b9a2525c430ec75bc4a3b87d50ec24a87b9fd8e2..3fd619e73140cab8728a5041144e62a8af9b6540 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .197
 LINUX_VERSION-4.14 = .150
-LINUX_VERSION-4.19 = .79
+LINUX_VERSION-4.19 = .80
 
 LINUX_KERNEL_HASH-4.9.197 = 553568b6728d505da70efa8247a66ad158e849c8f5f40d715612ef4e9ed14a0c
 LINUX_KERNEL_HASH-4.14.150 = 65c5a4b86b858ba58642f46ae8c983990376d1946e59cc7e054e85b1b7eb57b0
-LINUX_KERNEL_HASH-4.19.79 = f1143564364f278ba0893a7813afc02da6ecef6d5de147bd5011aa3cc1634b34
+LINUX_KERNEL_HASH-4.19.80 = 80a9ba764e088aa7fddfef5a97c0236905e291468a37832243b6f3828d36e7ec
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index d72064166d73a76edb997ab0787cc975b5925941..2f1d32754c847e17668600dba72ca391f22ad901 100644 (file)
@@ -35,7 +35,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                gpiod_err(desc,
                          "%s: tried to set a GPIO tied to an IRQ as output\n",
                          __func__);
-@@ -3322,7 +3324,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
+@@ -3333,7 +3335,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
                }
        }
  
index 06a0a5abf2f6d29363f6b2ad091d28556ce25bc0..d5e37d87dbe8b5ba3bb8e7939e9c00b679a5c38a 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1416,6 +1416,87 @@ command_cleanup:
+@@ -1428,6 +1428,87 @@ command_cleanup:
  }
  
  /*
@@ -108,7 +108,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
   * non-error returns are a promise to giveback() the urb later
   * we drop ownership so next owner (or urb unlink) can get it
   */
-@@ -1483,6 +1564,11 @@ static int xhci_urb_enqueue(struct usb_h
+@@ -1495,6 +1576,11 @@ static int xhci_urb_enqueue(struct usb_h
                }
        }
  
index 6dd938b6d9ad7b92b6977214c2164cd95181ca65..10b0a5b9218e9398e2721ad25dd7e67244f555dc 100644 (file)
@@ -11,7 +11,7 @@ This reverts commit 1cf1071a79f320bc4497a3ade77431f04442eb17.
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1416,87 +1416,6 @@ command_cleanup:
+@@ -1428,87 +1428,6 @@ command_cleanup:
  }
  
  /*
@@ -99,7 +99,7 @@ This reverts commit 1cf1071a79f320bc4497a3ade77431f04442eb17.
   * non-error returns are a promise to giveback() the urb later
   * we drop ownership so next owner (or urb unlink) can get it
   */
-@@ -1564,11 +1483,6 @@ static int xhci_urb_enqueue(struct usb_h
+@@ -1576,11 +1495,6 @@ static int xhci_urb_enqueue(struct usb_h
                }
        }
  
index 62889445195b4ef877282bf62c115df13a18d723..48b556735ad5645ec357bc335dfbd6982776331f 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1416,6 +1416,103 @@ command_cleanup:
+@@ -1428,6 +1428,103 @@ command_cleanup:
  }
  
  /*
@@ -119,7 +119,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
   * non-error returns are a promise to giveback() the urb later
   * we drop ownership so next owner (or urb unlink) can get it
   */
-@@ -5180,6 +5277,7 @@ static const struct hc_driver xhci_hc_dr
+@@ -5220,6 +5317,7 @@ static const struct hc_driver xhci_hc_dr
        .endpoint_reset =       xhci_endpoint_reset,
        .check_bandwidth =      xhci_check_bandwidth,
        .reset_bandwidth =      xhci_reset_bandwidth,
index 4c258ad54ac38608b84f94037a8ce5fa3a9a0298..2c41dc01275c81a0733bb26ed217fc1cbedb6af1 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -3948,8 +3948,23 @@ struct gpio_desc *__must_check gpiod_get
+@@ -3959,8 +3959,23 @@ struct gpio_desc *__must_check gpiod_get
         * the device name as label
         */
        status = gpiod_request(desc, con_id ? con_id : devname);
index 4072f825b20fced5eef904625dcfc1c1e32e2ded..f7564a58c0299f521192b5dd43a3e5b255cf4a07 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -4022,6 +4022,8 @@ struct gpio_desc *gpiod_get_from_of_node
+@@ -4033,6 +4033,8 @@ struct gpio_desc *gpiod_get_from_of_node
        transitory = flags & OF_GPIO_TRANSITORY;
  
        ret = gpiod_request(desc, label);
index 20d0faa472512580e54ed6cc788f379d528609eb..c27d19fc1621fdb64bd2ee76d4d4b942f6968a44 100644 (file)
@@ -10,11 +10,9 @@ Subject: [PATCH] phy: Add ipq40xx mdio driver
  3 files changed, 255 insertions(+)
  create mode 100644 drivers/net/phy/mdio-ipq40xx.c
 
-diff --git a/drivers/net/phy/Kconfig b/drivers/net/phy/Kconfig
-index 1f5fd24cd..eb71b47a3 100644
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -436,6 +436,13 @@ config XILINX_GMII2RGMII
+@@ -519,6 +519,13 @@ config XILINX_GMII2RGMII
          the Reduced Gigabit Media Independent Interface(RGMII) between
          Ethernet physical media devices and the Gigabit Ethernet controller.
  
@@ -28,11 +26,9 @@ index 1f5fd24cd..eb71b47a3 100644
  endif # PHYLIB
  
  config MICREL_KS8995MA
-diff --git a/drivers/net/phy/Makefile b/drivers/net/phy/Makefile
-index f21cda9d8..804c52634 100644
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -33,6 +33,7 @@ obj-$(CONFIG_MDIO_CAVIUM)    += mdio-cavium.o
+@@ -48,6 +48,7 @@ obj-$(CONFIG_MDIO_CAVIUM)    += mdio-cavium
  obj-$(CONFIG_MDIO_GPIO)               += mdio-gpio.o
  obj-$(CONFIG_MDIO_HISI_FEMAC) += mdio-hisi-femac.o
  obj-$(CONFIG_MDIO_I2C)                += mdio-i2c.o
@@ -40,9 +36,6 @@ index f21cda9d8..804c52634 100644
  obj-$(CONFIG_MDIO_MOXART)     += mdio-moxart.o
  obj-$(CONFIG_MDIO_MSCC_MIIM)  += mdio-mscc-miim.o
  obj-$(CONFIG_MDIO_OCTEON)     += mdio-octeon.o
-diff --git a/drivers/net/phy/mdio-ipq40xx.c b/drivers/net/phy/mdio-ipq40xx.c
-new file mode 100644
-index 000000000..88fe5dc2b
 --- /dev/null
 +++ b/drivers/net/phy/mdio-ipq40xx.c
 @@ -0,0 +1,247 @@
@@ -293,5 +286,3 @@ index 000000000..88fe5dc2b
 +MODULE_AUTHOR("Qualcomm Atheros");
 +MODULE_VERSION(DRV_VERSION);
 +MODULE_LICENSE("Dual BSD/GPL");
---
-2.20.1
index 28ab181e7751182bb7fb55839397df803d5e02f5..2fe6e46966430851d5a5a902198c56f14c57ee0e 100644 (file)
@@ -8,8 +8,6 @@ Signed-off-by: John Crispin <john@phrozen.org>
  arch/arm/boot/dts/Makefile | 23 +++++++++++++++++++++++
  1 file changed, 23 insertions(+)
 
-diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index b5bd3de87..5a52a0b19 100644
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
 @@ -785,11 +785,35 @@ dtb-$(CONFIG_ARCH_QCOM) += \
@@ -48,5 +46,3 @@ index b5bd3de87..5a52a0b19 100644
        qcom-ipq8064-ap148.dtb \
        qcom-msm8660-surf.dtb \
        qcom-msm8960-cdp.dtb \
---
-2.20.1