kernel: bump 4.14 to 4.14.150
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 28 Oct 2019 13:15:55 +0000 (14:15 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 30 Oct 2019 10:16:25 +0000 (11:16 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch

index 70120cea93d3b6356e9e9b1162d6f32a672f81dd..b9a2525c430ec75bc4a3b87d50ec24a87b9fd8e2 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .197
-LINUX_VERSION-4.14 = .149
+LINUX_VERSION-4.14 = .150
 LINUX_VERSION-4.19 = .79
 
 LINUX_KERNEL_HASH-4.9.197 = 553568b6728d505da70efa8247a66ad158e849c8f5f40d715612ef4e9ed14a0c
-LINUX_KERNEL_HASH-4.14.149 = e69dabd2368440ce1650cda0cf043e1ba3f3343f940a43b68e761739fcb3f296
+LINUX_KERNEL_HASH-4.14.150 = 65c5a4b86b858ba58642f46ae8c983990376d1946e59cc7e054e85b1b7eb57b0
 LINUX_KERNEL_HASH-4.19.79 = f1143564364f278ba0893a7813afc02da6ecef6d5de147bd5011aa3cc1634b34
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 438ef0821db4316350b0804ab3457356c16d033d..b708fda5ca1ab16f18611ed35b600f66f7c93319 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1954,7 +1954,8 @@ static const struct usb_device_id option
+@@ -1965,7 +1965,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index 988afe10cab63366e1f6d754039ea80d743e660a..70bc3b32aa4d1713ffb98b79b9abe5cce68b3dc8 100644 (file)
@@ -1363,7 +1363,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
                while (ep_ring->dequeue != td->last_trb)
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1595,13 +1595,38 @@ static int xhci_urb_dequeue(struct usb_h
+@@ -1607,13 +1607,38 @@ static int xhci_urb_dequeue(struct usb_h
                        ret = -ENOMEM;
                        goto done;
                }