octeontx: add f2fs and ext4 support
authorTim Harvey <tharvey@gateworks.com>
Tue, 21 Feb 2023 23:08:29 +0000 (15:08 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Feb 2023 21:22:48 +0000 (22:22 +0100)
Add both ext4 and f2fs support for overlayfs. The fstools mount_root
application will choose f2fs if the overlay volume space available
exceeds 100MB, otherwise ext4 is used.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
target/linux/octeontx/Makefile
target/linux/octeontx/config-5.15

index 25096c90ba96819b8612d83fd8d89c24b10c5c3b..57250a5e01cab6ed8c7c65273f34952158714f7c 100644 (file)
@@ -20,7 +20,8 @@ include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=Image
 
-DEFAULT_PACKAGES += kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
+DEFAULT_PACKAGES += uboot-envtools mkf2fs e2fsprogs blkid \
+                   kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
                    kmod-gpio-button-hotplug kmod-input-evdev kmod-rtc-ds1672 \
                    kmod-can kmod-can-mcp251x
 
index 36402b70ebfea96567c122b390b465e6a70ba031..40cab28f60a0b882127a5d1602c41387210664a0 100644 (file)
@@ -145,6 +145,8 @@ CONFIG_EDAC_SUPPORT=y
 CONFIG_EDAC_THUNDERX=y
 # CONFIG_EDAC_XGENE is not set
 CONFIG_EEPROM_AT24=y
+CONFIG_EXT4_FS=y
+CONFIG_F2FS_FS=y
 CONFIG_FAT_FS=y
 CONFIG_FIXED_PHY=y
 CONFIG_FIX_EARLYCON_MEM=y