octeontx: add default packages for on-board devices
authorTim Harvey <tharvey@gateworks.com>
Sat, 18 Feb 2023 01:06:41 +0000 (17:06 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Feb 2023 21:22:48 +0000 (22:22 +0100)
The Gateworks Newport boards supported by the octeontx target have
the following on-board devices:
 - Gateworks System Controller
 - GPIO buttons
 - GPIO leds
 - GPS PPS
 - Accelerometer
 - MCP251X CAN controller

Add kernel drivers for these devices in DEFAULT_PACKAGES

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
target/linux/octeontx/Makefile

index 5260291d05042bf3e1169359c95de83e8e54b1a0..25096c90ba96819b8612d83fd8d89c24b10c5c3b 100644 (file)
@@ -20,4 +20,8 @@ include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=Image
 
+DEFAULT_PACKAGES += kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
+                   kmod-gpio-button-hotplug kmod-input-evdev kmod-rtc-ds1672 \
+                   kmod-can kmod-can-mcp251x
+
 $(eval $(call BuildTarget))