ramips: merge relocate compile into build recipe
authorMathias Kresin <dev@kresin.me>
Fri, 30 Nov 2018 07:57:03 +0000 (08:57 +0100)
committerMathias Kresin <dev@kresin.me>
Fri, 30 Nov 2018 08:04:29 +0000 (09:04 +0100)
Compile the loader if the relocate-kernel image recipe is used and get
rid of the legacy build code to do so.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/image/Makefile
target/linux/ramips/image/mt7621.mk

index 9cf64361a4b15c319198d88f67fd537b9d6013c6..b4ff9a74922df924c05f6d19fd9bd516076bf354 100644 (file)
@@ -74,12 +74,16 @@ define Build/loader-kernel
 endef
 
 define Build/relocate-kernel
+       rm -rf $@.relocate
+       $(CP) ../../generic/image/relocate $@.relocate
+       $(MAKE) -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
        ( \
-               dd if=$(KDIR)/loader.bin bs=32 conv=sync && \
+               dd if=$@.relocate/loader.bin bs=32 conv=sync && \
                perl -e '@s = stat("$@"); print pack("V", @s[7])' && \
                cat $@ \
        ) > $@.new
        mv $@.new $@
+       rm -rf $@.relocate
 endef
 
 define MkCombineduImage
index 6a04cd0e3804bdbd1a15f0c364ca2bac59eebbcb..92bdbcf7431acf4d976819d2efe599617e50cad4 100644 (file)
@@ -558,12 +558,3 @@ define Device/zbt-wg3526-32M
        kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
 endef
 TARGET_DEVICES += zbt-wg3526-32M
-
-# FIXME: is this still needed?
-define Image/Prepare
-#define Build/Compile
-       rm -rf $(KDIR)/relocate
-       $(CP) ../../generic/image/relocate $(KDIR)
-       $(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
-       $(CP) $(KDIR)/relocate/loader.bin $(KDIR)/loader.bin
-endef