sunxi: make use of 'rootfs-part' feature
authorDaniel Golle <daniel@makrotopia.org>
Sat, 22 Jan 2022 00:25:52 +0000 (00:25 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 23 Jan 2022 19:48:25 +0000 (19:48 +0000)
Use 'rootfs-part' feature instead of referencing the TARGET_sunxi in
Config-images.in.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
config/Config-images.in
target/linux/sunxi/Makefile

index 9f41c7feda06d36383ee561626576dc15c7635e9..7f118030f23023223ea78f27b8d60b1dea0386a6 100644 (file)
@@ -296,7 +296,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_PARTSIZE
                int "Root filesystem partition size (in MiB)"
-               depends on USES_ROOTFS_PART || TARGET_ROOTFS_EXT4FS || TARGET_sunxi || TARGET_uml
+               depends on USES_ROOTFS_PART || TARGET_ROOTFS_EXT4FS || TARGET_uml
                default 104
                help
                  Select the root filesystem partition size.
index 1c94c6eaaf75be551680d128ed20b4bce5af9f01..682603341d326cae6d94a9a16a40f6a8354b08c9 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=sunxi
 BOARDNAME:=Allwinner A1x/A20/A3x/H3/H5/R40
-FEATURES:=fpu usb ext4 display rtc squashfs
+FEATURES:=fpu usb ext4 display rootfs-part rtc squashfs
 SUBTARGETS:=cortexa8 cortexa7 cortexa53
 
 KERNEL_PATCHVER:=5.10