omap: make use of 'rootfs-part' feature
authorDaniel Golle <daniel@makrotopia.org>
Sat, 22 Jan 2022 00:24:02 +0000 (00:24 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 23 Jan 2022 19:48:20 +0000 (19:48 +0000)
Use 'rootfs-part' feature instead of referencing the TARGET_omap in
Config-images.in.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
config/Config-images.in
target/linux/omap/Makefile

index 49e5330ffe20635fc493ce7aa579a35f3a45fdd2..9f41c7feda06d36383ee561626576dc15c7635e9 100644 (file)
@@ -296,7 +296,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_PARTSIZE
                int "Root filesystem partition size (in MiB)"
-               depends on USES_ROOTFS_PART || TARGET_ROOTFS_EXT4FS || TARGET_omap || TARGET_sunxi || TARGET_uml
+               depends on USES_ROOTFS_PART || TARGET_ROOTFS_EXT4FS || TARGET_sunxi || TARGET_uml
                default 104
                help
                  Select the root filesystem partition size.
index bc20f2eddc5fbe478ce17042427d1108f800211c..c7a904bbe58984e6d38e12501efb7fc77b01e679 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb usbgadget ext4 targz fpu audio display nand squashfs
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand rootfs-part squashfs
 CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3