qca-ssdk: disable PTP and swconfig by default
authorRobert Marko <robimarko@gmail.com>
Tue, 14 Nov 2023 08:47:38 +0000 (09:47 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 14 Nov 2023 04:21:55 +0000 (05:21 +0100)
PTP and swconfig support in SSDK require kernel modifications we dont need
nor we want to support for now, so move the PTP and swconfig disablement
into general build options as they are not ipq807x specific.

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/qca-ssdk/Makefile

index ab978f3b49b3bb3216a2fc075c09c12972d2b5b8..3770d29e8c5dd0e88036807c7d9e9062953a9605 100644 (file)
@@ -44,10 +44,11 @@ MAKE_FLAGS+= \
        GCC_VERSION=$(GCC_VERSION) \
        EXTRA_CFLAGS=-fno-stack-protector -I$(STAGING_DIR)/usr/include \
        SoC=$(CONFIG_TARGET_SUBTARGET) \
+       PTP_FEATURE=disable SWCONFIG_FEATURE=disable \
        $(LNX_CONFIG_OPTS)
 
 ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq807x")
-    MAKE_FLAGS+= CHIP_TYPE=HPPE PTP_FEATURE=disable SWCONFIG_FEATURE=disable
+    MAKE_FLAGS+= CHIP_TYPE=HPPE
 endif
 
 define Build/InstallDev