qca-ssdk: pass SoC to build
authorRobert Marko <robimarko@gmail.com>
Tue, 14 Nov 2023 08:22:40 +0000 (09:22 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 14 Nov 2023 04:21:55 +0000 (05:21 +0100)
Recent SSDK versions started also parsing the "SoC" variable to identify
the SoC along with the "CHIP_TYPE".

We are not passing "SoC" currently and this leads to components we dont
need like MHT (New 2.5G quad port switch) being compiled and then unused,
so lets just pass the "SoC" as well.

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/qca-ssdk/Makefile

index 4107208c0eb93508b0524b750acbc41e5f93b65a..ab978f3b49b3bb3216a2fc075c09c12972d2b5b8 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qca-ssdk
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=https://git.codelinaro.org/clo/qsdk/oss/lklm/qca-ssdk.git
 PKG_SOURCE_PROTO:=git
@@ -43,6 +43,7 @@ MAKE_FLAGS+= \
        TARGET_SUFFIX=$(CONFIG_TARGET_SUFFIX) \
        GCC_VERSION=$(GCC_VERSION) \
        EXTRA_CFLAGS=-fno-stack-protector -I$(STAGING_DIR)/usr/include \
+       SoC=$(CONFIG_TARGET_SUBTARGET) \
        $(LNX_CONFIG_OPTS)
 
 ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq807x")