build: Remove STAGING_DIR_HOST references for InstallDev/UninstallDev
authorJeffery To <jeffery.to@gmail.com>
Sat, 8 Jun 2019 22:00:47 +0000 (06:00 +0800)
committerPetr Štetiar <ynezz@true.cz>
Sun, 1 Mar 2020 20:35:59 +0000 (21:35 +0100)
Build/InstallDev no longer places a file list in
$(STAGING_DIR_HOST)/packages; this change removes the creation of
$(STAGING_DIR_HOST)/packages and the attempted removal of a
STAGING_DIR_HOST file list during package clean.

This also changes the host directory passed to Build/UninstallDev from
$(STAGING_DIR_HOST) to $(STAGING_DIR)/host, to match the directory
passed to Build/InstallDev.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
include/package.mk

index c541f6edf7a967bb317c87b8a5c63ce98cb0673a..057569274251805b58a08314b2a5478e31ffd4f1 100644 (file)
@@ -223,7 +223,7 @@ define Build/CoreTargets
   $(STAMP_INSTALLED) : export PATH=$$(TARGET_PATH_PKG)
   $(STAMP_INSTALLED): $(STAMP_BUILT)
        rm -rf $(TMP_DIR)/stage-$(PKG_DIR_NAME)
-       mkdir -p $(TMP_DIR)/stage-$(PKG_DIR_NAME)/host $(STAGING_DIR)/packages $(STAGING_DIR_HOST)/packages
+       mkdir -p $(TMP_DIR)/stage-$(PKG_DIR_NAME)/host $(STAGING_DIR)/packages
        $(foreach hook,$(Hooks/InstallDev/Pre),\
                $(call $(hook),$(TMP_DIR)/stage-$(PKG_DIR_NAME),$(TMP_DIR)/stage-$(PKG_DIR_NAME)/host)$(sep)\
        )
@@ -342,9 +342,9 @@ clean-build: $(if $(wildcard $(PKG_BUILD_DIR)/.autoremove),force-clean-build)
 
 clean: force-clean-build
        $(CleanStaging)
-       $(call Build/UninstallDev,$(STAGING_DIR),$(STAGING_DIR_HOST))
+       $(call Build/UninstallDev,$(STAGING_DIR),$(STAGING_DIR)/host)
        $(Build/Clean)
-       rm -f $(STAGING_DIR)/packages/$(STAGING_FILES_LIST) $(STAGING_DIR_HOST)/packages/$(STAGING_FILES_LIST)
+       rm -f $(STAGING_DIR)/packages/$(STAGING_FILES_LIST)
 
 dist:
        $(Build/Dist)