uboot-sunxi: use intree dtc explicitly
authorTianling Shen <cnsztl@immortalwrt.org>
Sat, 25 Nov 2023 15:17:15 +0000 (23:17 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Nov 2023 18:44:56 +0000 (19:44 +0100)
This replaces pylibfdt hack.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
package/boot/uboot-sunxi/Makefile
package/boot/uboot-sunxi/patches/300-force-pylibfdt-build.patch [deleted file]

index 17905802c31fb92d47b08d7790828f79d6d4f1e7..7f50992e6955c6e8d3cb26e6449d324f0f72d349 100644 (file)
@@ -15,6 +15,8 @@ PKG_HASH:=e31cac91545ff41b71cec5d8c22afd695645cd6e2a442ccdacacd60534069341
 
 PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
+UBOOT_USE_INTREE_DTC:=1
+
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/package/boot/uboot-sunxi/patches/300-force-pylibfdt-build.patch b/package/boot/uboot-sunxi/patches/300-force-pylibfdt-build.patch
deleted file mode 100644 (file)
index d34ed6f..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2000,26 +2000,7 @@ endif
- # Check dtc and pylibfdt, if DTC is provided, else build them
- PHONY += scripts_dtc
- scripts_dtc: scripts_basic
--      $(Q)if test "$(DTC)" = "$(DTC_INTREE)"; then \
--              $(MAKE) $(build)=scripts/dtc; \
--      else \
--              if ! $(DTC) -v >/dev/null; then \
--                      echo '*** Failed to check dtc version: $(DTC)'; \
--                      false; \
--              else \
--                      if test "$(call dtc-version)" -lt $(DTC_MIN_VERSION); then \
--                              echo '*** Your dtc is too old, please upgrade to dtc $(DTC_MIN_VERSION) or newer'; \
--                              false; \
--                      else \
--                              if [ -n "$(CONFIG_PYLIBFDT)" ]; then \
--                                      if ! echo "import libfdt" | $(PYTHON3) 2>/dev/null; then \
--                                              echo '*** pylibfdt does not seem to be available with $(PYTHON3)'; \
--                                              false; \
--                                      fi; \
--                              fi; \
--                      fi; \
--              fi; \
--      fi
-+      $(MAKE) $(build)=scripts/dtc
- # ---------------------------------------------------------------------------
- quiet_cmd_cpp_lds = LDS     $@