uboot-sifiveu: use intree dtc explicitly
authorTianling Shen <cnsztl@immortalwrt.org>
Sat, 25 Nov 2023 15:22:59 +0000 (23:22 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Nov 2023 18:44:56 +0000 (19:44 +0100)
This replaces pylibfdt hack.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
package/boot/uboot-sifiveu/Makefile
package/boot/uboot-sifiveu/patches/300-force-pylibfdt-build.patch [deleted file]

index 5def1c1fcb801b96822f98e7e4a0191ade5fed18..4cbfe344af84bb704cdf3d21867f9ae3f6ef5ed5 100644 (file)
@@ -10,6 +10,8 @@ PKG_RELEASE:=1
 PKG_VERSION:=2022.10
 PKG_HASH:=50b4482a505bc281ba8470c399a3c26e145e29b23500bc35c50debd7fa46bdf8
 
+UBOOT_USE_INTREE_DTC:=1
+
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/package/boot/uboot-sifiveu/patches/300-force-pylibfdt-build.patch b/package/boot/uboot-sifiveu/patches/300-force-pylibfdt-build.patch
deleted file mode 100644 (file)
index 4abf13e..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2028,26 +2028,7 @@ endif
- # Check dtc and pylibfdt, if DTC is provided, else build them
- PHONY += scripts_dtc
- scripts_dtc: scripts_basic
--      $(Q)if test "$(DTC)" = "$(DTC_INTREE)"; then \
--              $(MAKE) $(build)=scripts/dtc; \
--      else \
--              if ! $(DTC) -v >/dev/null; then \
--                      echo '*** Failed to check dtc version: $(DTC)'; \
--                      false; \
--              else \
--                      if test "$(call dtc-version)" -lt $(DTC_MIN_VERSION); then \
--                              echo '*** Your dtc is too old, please upgrade to dtc $(DTC_MIN_VERSION) or newer'; \
--                              false; \
--                      else \
--                              if [ -n "$(CONFIG_PYLIBFDT)" ]; then \
--                                      if ! echo "import libfdt" | $(PYTHON3) 2>/dev/null; then \
--                                              echo '*** pylibfdt does not seem to be available with $(PYTHON3)'; \
--                                              false; \
--                                      fi; \
--                              fi; \
--                      fi; \
--              fi; \
--      fi
-+      $(MAKE) $(build)=scripts/dtc
- # ---------------------------------------------------------------------------
- quiet_cmd_cpp_lds = LDS     $@