ipq806x: setup DSA port conduit in board.d
authorChristian Marangi <ansuelsmth@gmail.com>
Thu, 9 Nov 2023 14:29:39 +0000 (15:29 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 10 Nov 2023 11:30:34 +0000 (12:30 +0100)
Now that netifd and uci-defaults.sh supports a way to setup DSA port
conduit without using iproute2 tool, set DSA port conduit directly in
board.d, that will fill board.d and will instruct netifd to setup the
port.

Drop special init.d qca8k_set_port script and ip-tiny from target dep as
they are not required anymore.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/linux/ipq806x/Makefile
target/linux/ipq806x/base-files/etc/board.d/02_network
target/linux/ipq806x/base-files/etc/init.d/qca8k_set_port [deleted file]

index 1bcea1fa80fdd6b840abd7f6ebd5f0d8eb2180ac..74a0007a4e01995bd09f5d6f1a3864a3c597f0b4 100644 (file)
@@ -21,6 +21,6 @@ DEFAULT_PACKAGES += \
        kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
        kmod-phy-qcom-ipq806x-usb kmod-usb3 kmod-usb-dwc3-qcom \
        kmod-ath10k-ct wpad-basic-mbedtls \
-       uboot-envtools ip-tiny
+       uboot-envtools
 
 $(eval $(call BuildTarget))
index a4316272e9e53265f59bb0fe24a29533ed570db7..7fdda7cfec4df39e13fdeef90921559970c7d8d3 100644 (file)
@@ -34,10 +34,17 @@ ipq806x_setup_interfaces()
        tplink,ad7200 |\
        zyxel,nbg6817)
                ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan"
+               ucidef_set_network_device_conduit "lan1" "eth1"
+               ucidef_set_network_device_conduit "lan2" "eth1"
+               ucidef_set_network_device_conduit "lan3" "eth1"
+               ucidef_set_network_device_conduit "lan4" "eth1"
+               ucidef_set_network_device_conduit "wan" "eth0"
                ;;
        asus,onhub |\
        tplink,onhub)
                ucidef_set_interfaces_lan_wan "lan1" "wan"
+               ucidef_set_network_device_conduit "lan1" "eth1"
+               ucidef_set_network_device_conduit "wan" "eth0"
                ;;
        edgecore,ecw5410 |\
        extreme,ap3935)
diff --git a/target/linux/ipq806x/base-files/etc/init.d/qca8k_set_port b/target/linux/ipq806x/base-files/etc/init.d/qca8k_set_port
deleted file mode 100755 (executable)
index bf14907..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=15
-
-set_qca8k_port() {
-       local port=$1
-       local master=$2
-
-       ip link set $port type dsa conduit $master
-}
-
-boot() {
-       # Restore original implementation where the eth1 (port 6) was used
-       # for the lan port and the eth0 (port 0) was used for the wan port
-       case $(board_name) in
-               askey,rt4230w-rev6 |\
-               asrock,g10 |\
-               buffalo,wxr-2533dhp |\
-               compex,wpq864 |\
-               nec,wg2600hp |\
-               nec,wg2600hp3 |\
-               netgear,d7800 |\
-               netgear,r7500 |\
-               netgear,r7500v2 |\
-               netgear,r7800 |\
-               netgear,xr450 |\
-               netgear,xr500 |\
-               nokia,ac400i |\
-               tplink,ad7200 |\
-               tplink,c2600 |\
-               tplink,vr2600v |\
-               zyxel,nbg6817)
-                       set_qca8k_port lan1 eth1
-                       set_qca8k_port lan2 eth1
-                       set_qca8k_port lan3 eth1
-                       set_qca8k_port lan4 eth1
-                       set_qca8k_port wan eth0
-                       ;;
-               asus,onhub |\
-               tplink,onhub)
-                       set_qca8k_port lan1 eth1
-                       set_qca8k_port wan eth0
-                       ;;
-       esac
-}