generic: net: pcs: add driver for MediaTek SGMII PCS
authorDaniel Golle <daniel@makrotopia.org>
Mon, 27 Mar 2023 17:14:21 +0000 (18:14 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 27 Mar 2023 18:07:54 +0000 (19:07 +0100)
Backport dedicated PCS driver for MediaTek LynxI SGMII/SerDes unit.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/bcm27xx/patches-5.15/950-0281-media-i2c-Add-driver-for-Sony-IMX477-sensor.patch
target/linux/bcm27xx/patches-5.15/950-0413-Documentation-devicetree-Add-documentation-for-imx37.patch
target/linux/bcm27xx/patches-5.15/950-0520-dt-bindings-media-i2c-Add-IMX519-CMOS-sensor-binding.patch
target/linux/generic/backport-5.15/707-v6.3-net-pcs-add-driver-for-MediaTek-SGMII-PCS.patch [new file with mode: 0644]
target/linux/generic/backport-5.15/804-v5.18-0009-nvmem-Add-driver-for-OCOTP-in-Sunplus-SP7021.patch
target/linux/generic/backport-5.15/806-v6.0-0001-nvmem-microchip-otpc-add-support.patch
target/linux/mediatek/patches-5.15/730-net-phy-add-driver-for-MediaTek-SoC-built-in-GE-PHYs.patch
target/linux/realtek/patches-5.15/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch
target/linux/realtek/patches-5.15/700-net-dsa-add-support-for-rtl838x-switch.patch
target/linux/realtek/patches-5.15/704-drivers-net-phy-eee-support-for-rtl838x.patch

index 7690153d3db3a016af766372d4ba27829b3a423a..e756fa2fff6605fa9c23f25dd825d96b4c497113 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Naushir Patuck <naush@raspberrypi.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17530,6 +17530,14 @@ T:    git git://linuxtv.org/media_tree.git
+@@ -17538,6 +17538,14 @@ T:    git git://linuxtv.org/media_tree.git
  F:    Documentation/devicetree/bindings/media/i2c/sony,imx412.yaml
  F:    drivers/media/i2c/imx412.c
  
index d60c0f372cc50c8737d249eddac076ed6c353eb2..27fd0e57938bada839972424fdece77f4053a086 100644 (file)
@@ -132,7 +132,7 @@ Signed-off-by: David Plowman <david.plowman@raspberrypi.com>
 +...
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17544,6 +17544,7 @@ M:     Raspberry Pi Kernel Maintenance <kern
+@@ -17552,6 +17552,7 @@ M:     Raspberry Pi Kernel Maintenance <kern
  L:    linux-media@vger.kernel.org
  S:    Maintained
  T:    git git://linuxtv.org/media_tree.git
index b1af6872fbfda1745a3dcc43278e6c458fac1c36..25e6555fdb5a402da412e024d9650d325e0ebe62 100644 (file)
@@ -132,7 +132,7 @@ Signed-off-by: Lee Jackson <info@arducam.com>
 +...
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17548,6 +17548,14 @@ F:    Documentation/devicetree/bindings/med
+@@ -17556,6 +17556,14 @@ F:    Documentation/devicetree/bindings/med
  F:    Documentation/devicetree/bindings/media/i2c/imx477.yaml
  F:    drivers/media/i2c/imx477.c
  
diff --git a/target/linux/generic/backport-5.15/707-v6.3-net-pcs-add-driver-for-MediaTek-SGMII-PCS.patch b/target/linux/generic/backport-5.15/707-v6.3-net-pcs-add-driver-for-MediaTek-SGMII-PCS.patch
new file mode 100644 (file)
index 0000000..1f2a3ee
--- /dev/null
@@ -0,0 +1,394 @@
+From 4765a9722e09765866e131ec31f7b9cf4c1f4854 Mon Sep 17 00:00:00 2001
+From: Daniel Golle <daniel@makrotopia.org>
+Date: Sun, 19 Mar 2023 12:57:50 +0000
+Subject: [PATCH] net: pcs: add driver for MediaTek SGMII PCS
+
+The SGMII core found in several MediaTek SoCs is identical to what can
+also be found in MediaTek's MT7531 Ethernet switch IC.
+As this has not always been clear, both drivers developed different
+implementations to deal with the PCS.
+Recently Alexander Couzens pointed out this fact which lead to the
+development of this shared driver.
+
+Add a dedicated driver, mostly by copying the code now found in the
+Ethernet driver. The now redundant code will be removed by a follow-up
+commit.
+
+Suggested-by: Alexander Couzens <lynxis@fe80.eu>
+Suggested-by: Russell King (Oracle) <rmk+kernel@armlinux.org.uk>
+Signed-off-by: Daniel Golle <daniel@makrotopia.org>
+Tested-by: Frank Wunderlich <frank-w@public-files.de>
+Reviewed-by: Russell King (Oracle) <rmk+kernel@armlinux.org.uk>
+Signed-off-by: Jakub Kicinski <kuba@kernel.org>
+---
+ MAINTAINERS                       |   8 +
+ drivers/net/pcs/Kconfig           |   7 +
+ drivers/net/pcs/Makefile          |   1 +
+ drivers/net/pcs/pcs-mtk-lynxi.c   | 305 ++++++++++++++++++++++++++++++
+ include/linux/pcs/pcs-mtk-lynxi.h |  13 ++
+ 5 files changed, 334 insertions(+)
+ create mode 100644 drivers/net/pcs/pcs-mtk-lynxi.c
+ create mode 100644 include/linux/pcs/pcs-mtk-lynxi.h
+
+--- a/MAINTAINERS
++++ b/MAINTAINERS
+@@ -11790,6 +11790,14 @@ L:    netdev@vger.kernel.org
+ S:    Maintained
+ F:    drivers/net/ethernet/mediatek/
++MEDIATEK ETHERNET PCS DRIVER
++M:    Alexander Couzens <lynxis@fe80.eu>
++M:    Daniel Golle <daniel@makrotopia.org>
++L:    netdev@vger.kernel.org
++S:    Maintained
++F:    drivers/net/pcs/pcs-mtk-lynxi.c
++F:    include/linux/pcs/pcs-mtk-lynxi.h
++
+ MEDIATEK I2C CONTROLLER DRIVER
+ M:    Qii Wang <qii.wang@mediatek.com>
+ L:    linux-i2c@vger.kernel.org
+--- a/drivers/net/pcs/Kconfig
++++ b/drivers/net/pcs/Kconfig
+@@ -18,4 +18,11 @@ config PCS_LYNX
+         This module provides helpers to phylink for managing the Lynx PCS
+         which is part of the Layerscape and QorIQ Ethernet SERDES.
++config PCS_MTK_LYNXI
++      tristate
++      select REGMAP
++      help
++        This module provides helpers to phylink for managing the LynxI PCS
++        which is part of MediaTek's SoC and Ethernet switch ICs.
++
+ endmenu
+--- a/drivers/net/pcs/Makefile
++++ b/drivers/net/pcs/Makefile
+@@ -5,3 +5,4 @@ pcs_xpcs-$(CONFIG_PCS_XPCS)    := pcs-xpcs.
+ obj-$(CONFIG_PCS_XPCS)                += pcs_xpcs.o
+ obj-$(CONFIG_PCS_LYNX)                += pcs-lynx.o
++obj-$(CONFIG_PCS_MTK_LYNXI)   += pcs-mtk-lynxi.o
+--- /dev/null
++++ b/drivers/net/pcs/pcs-mtk-lynxi.c
+@@ -0,0 +1,305 @@
++// SPDX-License-Identifier: GPL-2.0
++// Copyright (c) 2018-2019 MediaTek Inc.
++/* A library for MediaTek SGMII circuit
++ *
++ * Author: Sean Wang <sean.wang@mediatek.com>
++ * Author: Alexander Couzens <lynxis@fe80.eu>
++ * Author: Daniel Golle <daniel@makrotopia.org>
++ *
++ */
++
++#include <linux/mdio.h>
++#include <linux/of.h>
++#include <linux/pcs/pcs-mtk-lynxi.h>
++#include <linux/phylink.h>
++#include <linux/regmap.h>
++
++/* SGMII subsystem config registers */
++/* BMCR (low 16) BMSR (high 16) */
++#define SGMSYS_PCS_CONTROL_1          0x0
++#define SGMII_BMCR                    GENMASK(15, 0)
++#define SGMII_BMSR                    GENMASK(31, 16)
++
++#define SGMSYS_PCS_DEVICE_ID          0x4
++#define SGMII_LYNXI_DEV_ID            0x4d544950
++
++#define SGMSYS_PCS_ADVERTISE          0x8
++#define SGMII_ADVERTISE                       GENMASK(15, 0)
++#define SGMII_LPA                     GENMASK(31, 16)
++
++#define SGMSYS_PCS_SCRATCH            0x14
++#define SGMII_DEV_VERSION             GENMASK(31, 16)
++
++/* Register to programmable link timer, the unit in 2 * 8ns */
++#define SGMSYS_PCS_LINK_TIMER         0x18
++#define SGMII_LINK_TIMER_MASK         GENMASK(19, 0)
++#define SGMII_LINK_TIMER_VAL(ns)      FIELD_PREP(SGMII_LINK_TIMER_MASK, \
++                                                 ((ns) / 2 / 8))
++
++/* Register to control remote fault */
++#define SGMSYS_SGMII_MODE             0x20
++#define SGMII_IF_MODE_SGMII           BIT(0)
++#define SGMII_SPEED_DUPLEX_AN         BIT(1)
++#define SGMII_SPEED_MASK              GENMASK(3, 2)
++#define SGMII_SPEED_10                        FIELD_PREP(SGMII_SPEED_MASK, 0)
++#define SGMII_SPEED_100                       FIELD_PREP(SGMII_SPEED_MASK, 1)
++#define SGMII_SPEED_1000              FIELD_PREP(SGMII_SPEED_MASK, 2)
++#define SGMII_DUPLEX_HALF             BIT(4)
++#define SGMII_REMOTE_FAULT_DIS                BIT(8)
++
++/* Register to reset SGMII design */
++#define SGMSYS_RESERVED_0             0x34
++#define SGMII_SW_RESET                        BIT(0)
++
++/* Register to set SGMII speed, ANA RG_ Control Signals III */
++#define SGMII_PHY_SPEED_MASK          GENMASK(3, 2)
++#define SGMII_PHY_SPEED_1_25G         FIELD_PREP(SGMII_PHY_SPEED_MASK, 0)
++#define SGMII_PHY_SPEED_3_125G                FIELD_PREP(SGMII_PHY_SPEED_MASK, 1)
++
++/* Register to power up QPHY */
++#define SGMSYS_QPHY_PWR_STATE_CTRL    0xe8
++#define       SGMII_PHYA_PWD                  BIT(4)
++
++/* Register to QPHY wrapper control */
++#define SGMSYS_QPHY_WRAP_CTRL         0xec
++#define SGMII_PN_SWAP_MASK            GENMASK(1, 0)
++#define SGMII_PN_SWAP_TX_RX           (BIT(0) | BIT(1))
++
++/* struct mtk_pcs_lynxi -  This structure holds each sgmii regmap andassociated
++ *                         data
++ * @regmap:                The register map pointing at the range used to setup
++ *                         SGMII modes
++ * @dev:                   Pointer to device owning the PCS
++ * @ana_rgc3:              The offset of register ANA_RGC3 relative to regmap
++ * @interface:             Currently configured interface mode
++ * @pcs:                   Phylink PCS structure
++ * @flags:                 Flags indicating hardware properties
++ */
++struct mtk_pcs_lynxi {
++      struct regmap           *regmap;
++      u32                     ana_rgc3;
++      phy_interface_t         interface;
++      struct                  phylink_pcs pcs;
++      u32                     flags;
++};
++
++static struct mtk_pcs_lynxi *pcs_to_mtk_pcs_lynxi(struct phylink_pcs *pcs)
++{
++      return container_of(pcs, struct mtk_pcs_lynxi, pcs);
++}
++
++static void mtk_pcs_lynxi_get_state(struct phylink_pcs *pcs,
++                                  struct phylink_link_state *state)
++{
++      struct mtk_pcs_lynxi *mpcs = pcs_to_mtk_pcs_lynxi(pcs);
++      unsigned int bm, adv;
++
++      /* Read the BMSR and LPA */
++      regmap_read(mpcs->regmap, SGMSYS_PCS_CONTROL_1, &bm);
++      regmap_read(mpcs->regmap, SGMSYS_PCS_ADVERTISE, &adv);
++
++      phylink_mii_c22_pcs_decode_state(state, FIELD_GET(SGMII_BMSR, bm),
++                                       FIELD_GET(SGMII_LPA, adv));
++}
++
++static int mtk_pcs_lynxi_config(struct phylink_pcs *pcs, unsigned int mode,
++                              phy_interface_t interface,
++                              const unsigned long *advertising,
++                              bool permit_pause_to_mac)
++{
++      struct mtk_pcs_lynxi *mpcs = pcs_to_mtk_pcs_lynxi(pcs);
++      bool mode_changed = false, changed, use_an;
++      unsigned int rgc3, sgm_mode, bmcr;
++      int advertise, link_timer;
++
++      advertise = phylink_mii_c22_pcs_encode_advertisement(interface,
++                                                           advertising);
++      if (advertise < 0)
++              return advertise;
++
++      /* Clearing IF_MODE_BIT0 switches the PCS to BASE-X mode, and
++       * we assume that fixes it's speed at bitrate = line rate (in
++       * other words, 1000Mbps or 2500Mbps).
++       */
++      if (interface == PHY_INTERFACE_MODE_SGMII) {
++              sgm_mode = SGMII_IF_MODE_SGMII;
++              if (phylink_autoneg_inband(mode)) {
++                      sgm_mode |= SGMII_REMOTE_FAULT_DIS |
++                                  SGMII_SPEED_DUPLEX_AN;
++                      use_an = true;
++              } else {
++                      use_an = false;
++              }
++      } else if (phylink_autoneg_inband(mode)) {
++              /* 1000base-X or 2500base-X autoneg */
++              sgm_mode = SGMII_REMOTE_FAULT_DIS;
++              use_an = linkmode_test_bit(ETHTOOL_LINK_MODE_Autoneg_BIT,
++                                         advertising);
++      } else {
++              /* 1000base-X or 2500base-X without autoneg */
++              sgm_mode = 0;
++              use_an = false;
++      }
++
++      if (use_an)
++              bmcr = BMCR_ANENABLE;
++      else
++              bmcr = 0;
++
++      if (mpcs->interface != interface) {
++              link_timer = phylink_get_link_timer_ns(interface);
++              if (link_timer < 0)
++                      return link_timer;
++
++              /* PHYA power down */
++              regmap_set_bits(mpcs->regmap, SGMSYS_QPHY_PWR_STATE_CTRL,
++                              SGMII_PHYA_PWD);
++
++              /* Reset SGMII PCS state */
++              regmap_set_bits(mpcs->regmap, SGMSYS_RESERVED_0,
++                              SGMII_SW_RESET);
++
++              if (mpcs->flags & MTK_SGMII_FLAG_PN_SWAP)
++                      regmap_update_bits(mpcs->regmap, SGMSYS_QPHY_WRAP_CTRL,
++                                         SGMII_PN_SWAP_MASK,
++                                         SGMII_PN_SWAP_TX_RX);
++
++              if (interface == PHY_INTERFACE_MODE_2500BASEX)
++                      rgc3 = SGMII_PHY_SPEED_3_125G;
++              else
++                      rgc3 = SGMII_PHY_SPEED_1_25G;
++
++              /* Configure the underlying interface speed */
++              regmap_update_bits(mpcs->regmap, mpcs->ana_rgc3,
++                                 SGMII_PHY_SPEED_MASK, rgc3);
++
++              /* Setup the link timer */
++              regmap_write(mpcs->regmap, SGMSYS_PCS_LINK_TIMER,
++                           SGMII_LINK_TIMER_VAL(link_timer));
++
++              mpcs->interface = interface;
++              mode_changed = true;
++      }
++
++      /* Update the advertisement, noting whether it has changed */
++      regmap_update_bits_check(mpcs->regmap, SGMSYS_PCS_ADVERTISE,
++                               SGMII_ADVERTISE, advertise, &changed);
++
++      /* Update the sgmsys mode register */
++      regmap_update_bits(mpcs->regmap, SGMSYS_SGMII_MODE,
++                         SGMII_REMOTE_FAULT_DIS | SGMII_SPEED_DUPLEX_AN |
++                         SGMII_IF_MODE_SGMII, sgm_mode);
++
++      /* Update the BMCR */
++      regmap_update_bits(mpcs->regmap, SGMSYS_PCS_CONTROL_1,
++                         BMCR_ANENABLE, bmcr);
++
++      /* Release PHYA power down state
++       * Only removing bit SGMII_PHYA_PWD isn't enough.
++       * There are cases when the SGMII_PHYA_PWD register contains 0x9 which
++       * prevents SGMII from working. The SGMII still shows link but no traffic
++       * can flow. Writing 0x0 to the PHYA_PWD register fix the issue. 0x0 was
++       * taken from a good working state of the SGMII interface.
++       * Unknown how much the QPHY needs but it is racy without a sleep.
++       * Tested on mt7622 & mt7986.
++       */
++      usleep_range(50, 100);
++      regmap_write(mpcs->regmap, SGMSYS_QPHY_PWR_STATE_CTRL, 0);
++
++      return changed || mode_changed;
++}
++
++static void mtk_pcs_lynxi_restart_an(struct phylink_pcs *pcs)
++{
++      struct mtk_pcs_lynxi *mpcs = pcs_to_mtk_pcs_lynxi(pcs);
++
++      regmap_set_bits(mpcs->regmap, SGMSYS_PCS_CONTROL_1, BMCR_ANRESTART);
++}
++
++static void mtk_pcs_lynxi_link_up(struct phylink_pcs *pcs, unsigned int mode,
++                                phy_interface_t interface, int speed,
++                                int duplex)
++{
++      struct mtk_pcs_lynxi *mpcs = pcs_to_mtk_pcs_lynxi(pcs);
++      unsigned int sgm_mode;
++
++      if (!phylink_autoneg_inband(mode)) {
++              /* Force the speed and duplex setting */
++              if (speed == SPEED_10)
++                      sgm_mode = SGMII_SPEED_10;
++              else if (speed == SPEED_100)
++                      sgm_mode = SGMII_SPEED_100;
++              else
++                      sgm_mode = SGMII_SPEED_1000;
++
++              if (duplex != DUPLEX_FULL)
++                      sgm_mode |= SGMII_DUPLEX_HALF;
++
++              regmap_update_bits(mpcs->regmap, SGMSYS_SGMII_MODE,
++                                 SGMII_DUPLEX_HALF | SGMII_SPEED_MASK,
++                                 sgm_mode);
++      }
++}
++
++static const struct phylink_pcs_ops mtk_pcs_lynxi_ops = {
++      .pcs_get_state = mtk_pcs_lynxi_get_state,
++      .pcs_config = mtk_pcs_lynxi_config,
++      .pcs_an_restart = mtk_pcs_lynxi_restart_an,
++      .pcs_link_up = mtk_pcs_lynxi_link_up,
++};
++
++struct phylink_pcs *mtk_pcs_lynxi_create(struct device *dev,
++                                       struct regmap *regmap, u32 ana_rgc3,
++                                       u32 flags)
++{
++      struct mtk_pcs_lynxi *mpcs;
++      u32 id, ver;
++      int ret;
++
++      ret = regmap_read(regmap, SGMSYS_PCS_DEVICE_ID, &id);
++      if (ret < 0)
++              return NULL;
++
++      if (id != SGMII_LYNXI_DEV_ID) {
++              dev_err(dev, "unknown PCS device id %08x\n", id);
++              return NULL;
++      }
++
++      ret = regmap_read(regmap, SGMSYS_PCS_SCRATCH, &ver);
++      if (ret < 0)
++              return NULL;
++
++      ver = FIELD_GET(SGMII_DEV_VERSION, ver);
++      if (ver != 0x1) {
++              dev_err(dev, "unknown PCS device version %04x\n", ver);
++              return NULL;
++      }
++
++      dev_dbg(dev, "MediaTek LynxI SGMII PCS (id 0x%08x, ver 0x%04x)\n", id,
++              ver);
++
++      mpcs = kzalloc(sizeof(*mpcs), GFP_KERNEL);
++      if (!mpcs)
++              return NULL;
++
++      mpcs->ana_rgc3 = ana_rgc3;
++      mpcs->regmap = regmap;
++      mpcs->flags = flags;
++      mpcs->pcs.ops = &mtk_pcs_lynxi_ops;
++      mpcs->pcs.poll = true;
++      mpcs->interface = PHY_INTERFACE_MODE_NA;
++
++      return &mpcs->pcs;
++}
++EXPORT_SYMBOL(mtk_pcs_lynxi_create);
++
++void mtk_pcs_lynxi_destroy(struct phylink_pcs *pcs)
++{
++      if (!pcs)
++              return;
++
++      kfree(pcs_to_mtk_pcs_lynxi(pcs));
++}
++EXPORT_SYMBOL(mtk_pcs_lynxi_destroy);
++
++MODULE_LICENSE("GPL");
+--- /dev/null
++++ b/include/linux/pcs/pcs-mtk-lynxi.h
+@@ -0,0 +1,13 @@
++/* SPDX-License-Identifier: GPL-2.0 */
++#ifndef __LINUX_PCS_MTK_LYNXI_H
++#define __LINUX_PCS_MTK_LYNXI_H
++
++#include <linux/phylink.h>
++#include <linux/regmap.h>
++
++#define MTK_SGMII_FLAG_PN_SWAP BIT(0)
++struct phylink_pcs *mtk_pcs_lynxi_create(struct device *dev,
++                                       struct regmap *regmap,
++                                       u32 ana_rgc3, u32 flags);
++void mtk_pcs_lynxi_destroy(struct phylink_pcs *pcs);
++#endif
index a4c1b66c9e3ec9e8be3d1c2f36a9b0bd7da20b9a..2a9dc749478772c49384fc9422f805ebb46f433b 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17954,6 +17954,11 @@ L:    netdev@vger.kernel.org
+@@ -17962,6 +17962,11 @@ L:    netdev@vger.kernel.org
  S:    Maintained
  F:    drivers/net/ethernet/dlink/sundance.c
  
index 6503c7aa3b1430a91ce70bdd5b028504e67d8029..cec66ec383e432b0b3f1fa62e1e75560ea5aeeb7 100644 (file)
@@ -57,7 +57,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -12354,6 +12354,14 @@ S:    Supported
+@@ -12362,6 +12362,14 @@ S:    Supported
  F:    Documentation/devicetree/bindings/mtd/atmel-nand.txt
  F:    drivers/mtd/nand/raw/atmel/*
  
index 4909d9e9229d97041e73e4983d3b851d38d3bc62..f2145dbc16f3b4606d97cc0bb60135f3ee01b91a 100644 (file)
@@ -17,9 +17,9 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11790,6 +11790,14 @@ L:    netdev@vger.kernel.org
- S:    Maintained
- F:    drivers/net/ethernet/mediatek/
+@@ -11798,6 +11798,14 @@ S:    Maintained
+ F:    drivers/net/pcs/pcs-mtk-lynxi.c
+ F:    include/linux/pcs/pcs-mtk-lynxi.h
  
 +MEDIATEK ETHERNET PHY DRIVERS
 +M:    Daniel Golle <daniel@makrotopia.org>
index 93f0fe5cf475dc9ec2f2f679d22548c94a558416..e562dd8396c3df1cdb3b90fe90872e7afe699122 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -15891,6 +15891,13 @@ S:    Maintained
+@@ -15899,6 +15899,13 @@ S:    Maintained
  F:    include/sound/rt*.h
  F:    sound/soc/codecs/rt*
  
index 71724034d4cd1e6d151d175ddf2c7d5d4f61695b..8f400012635f9bdd4f4e68a6aeff7d2d5074dfde 100644 (file)
@@ -22,7 +22,7 @@ Submitted-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/net/dsa/Kconfig
 +++ b/drivers/net/dsa/Kconfig
-@@ -60,6 +60,8 @@ source "drivers/net/dsa/sja1105/Kconfig"
+@@ -61,6 +61,8 @@ source "drivers/net/dsa/sja1105/Kconfig"
  
  source "drivers/net/dsa/xrs700x/Kconfig"
  
index 1cea91e0d137534aeeefa75d84c602b025cfc24c..591f0cea13a3f1ff3489791929e234a4acabc7cf 100644 (file)
@@ -21,7 +21,7 @@ Submitted-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/net/phy/phylink.c
 +++ b/drivers/net/phy/phylink.c
-@@ -1943,6 +1943,11 @@ int phylink_ethtool_ksettings_set(struct
+@@ -1942,6 +1942,11 @@ int phylink_ethtool_ksettings_set(struct
                 *   the presence of a PHY, this should not be changed as that
                 *   should be determined from the media side advertisement.
                 */
@@ -33,7 +33,7 @@ Submitted-by: John Crispin <john@phrozen.org>
                return phy_ethtool_ksettings_set(pl->phydev, kset);
        }
  
-@@ -2246,8 +2251,11 @@ int phylink_ethtool_get_eee(struct phyli
+@@ -2245,8 +2250,11 @@ int phylink_ethtool_get_eee(struct phyli
  
        ASSERT_RTNL();
  
@@ -46,7 +46,7 @@ Submitted-by: John Crispin <john@phrozen.org>
  
        return ret;
  }
-@@ -2264,8 +2272,11 @@ int phylink_ethtool_set_eee(struct phyli
+@@ -2263,8 +2271,11 @@ int phylink_ethtool_set_eee(struct phyli
  
        ASSERT_RTNL();