kernel: provide kmod-fixed-phy as separate kmod
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 30 Dec 2021 19:05:15 +0000 (20:05 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 8 Jan 2022 22:20:21 +0000 (23:20 +0100)
Almost all targets have the fixed-phy feature built into the kernel.
One big exception is x86. This caused a problem with the upcoming
LAN78xx usb driver. Hence this patch breaks out the fixed-phy from
of_mdio (which didn't include the .ko) and puts into a separate
module.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/kernel/linux/modules/netdevices.mk

index 91f51f5be647b9c1faa18dc6483aa1b132cb236b..6d263bdc3425079d78fae7010e08d969fba00ace 100644 (file)
@@ -1034,13 +1034,28 @@ endef
 
 $(eval $(call KernelPackage,forcedeth))
 
+define KernelPackage/fixed-phy
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=MDIO Bus/PHY emulation with fixed speed/link PHYs
+  DEPENDS:=+kmod-libphy
+  KCONFIG:=CONFIG_FIXED_PHY
+  FILES:=$(LINUX_DIR)/drivers/net/phy/fixed_phy.ko
+  AUTOLOAD:=$(call AutoProbe,fixed_phy)
+endef
+
+define KernelPackage/fixed-phy/description
+ Kernel driver for "fixed" MDIO Bus to cover the boards
+ and devices that use PHYs that are not connected to the real MDIO bus.
+endef
+
+$(eval $(call KernelPackage,fixed-phy))
+
 define KernelPackage/of-mdio
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=OpenFirmware MDIO support
-  DEPENDS:=+kmod-libphy @!TARGET_x86
+  DEPENDS:=+kmod-libphy +kmod-fixed-phy @!TARGET_x86
   KCONFIG:=CONFIG_OF_MDIO
   FILES:= \
-       $(LINUX_DIR)/drivers/net/phy/fixed_phy.ko \
        $(LINUX_DIR)/drivers/of/of_mdio.ko@lt5.10 \
        $(LINUX_DIR)/drivers/net/mdio/of_mdio.ko@ge5.10
   AUTOLOAD:=$(call AutoLoad,41,of_mdio)