kernel: add kmod-phy-microchip
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 30 Dec 2021 19:03:48 +0000 (20:03 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 8 Jan 2022 22:17:18 +0000 (23:17 +0100)
phy drivers for Microchip's LAN88xx PHYs.
This is needed for the "LAN7801" variant
of the upstream lan78xx usb ethernet driver.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/kernel/linux/modules/netdevices.mk

index 6bbaf21e4aa944ec6eaf2069ee16164f98cea8c5..91f51f5be647b9c1faa18dc6483aa1b132cb236b 100644 (file)
@@ -196,6 +196,21 @@ endef
 
 $(eval $(call KernelPackage,et131x))
 
+define KernelPackage/phy-microchip
+   SUBMENU:=$(NETWORK_DEVICES_MENU)
+   TITLE:=Microchip Ethernet PHY driver
+   KCONFIG:=CONFIG_MICROCHIP_PHY
+   DEPENDS:=+kmod-libphy
+   FILES:=$(LINUX_DIR)/drivers/net/phy/microchip.ko
+   AUTOLOAD:=$(call AutoLoad,18,microchip,1)
+endef
+
+define KernelPackage/phy-microchip/description
+   Supports the LAN88XX PHYs.
+endef
+
+$(eval $(call KernelPackage,phy-microchip))
+
 
 define KernelPackage/phylib-broadcom
    SUBMENU:=$(NETWORK_DEVICES_MENU)