kernel: bump 4.9 to 4.9.166
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 29 Mar 2019 13:04:00 +0000 (14:04 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 29 Mar 2019 17:04:39 +0000 (18:04 +0100)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch

index ad240735a56138f1cdaef73f8b0bc3d54e6252a3..fac959f67626ba5a2892370e073dcdcc26c07f59 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .165
+LINUX_VERSION-4.9 = .166
 LINUX_VERSION-4.14 = .108
 
-LINUX_KERNEL_HASH-4.9.165 = 47a0916af54b37028417f365c8938477af00235f4f36c514e9375155772f043c
+LINUX_KERNEL_HASH-4.9.166 = b8f87c087cbc35d35d55cae1c0c7e47c8d20226d241697bf5d4c0c524439baeb
 LINUX_KERNEL_HASH-4.14.108 = b6e33c687f26cd13934f961f48985c17ab3fd0e09aae007a175e3bbf3a8ed454
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 2fc47b614ee55f066cb2eecf4cd874822be482f0..4c228b333aef39c9542b1a5e9254062bde052d71 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        return entry->group;
  }
-@@ -3180,9 +3182,10 @@ static bool amd_iommu_capable(enum iommu
+@@ -3185,9 +3187,10 @@ static bool amd_iommu_capable(enum iommu
        return false;
  }
  
@@ -47,7 +47,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        struct unity_map_entry *entry;
        int devid;
  
-@@ -3191,41 +3194,56 @@ static void amd_iommu_get_dm_regions(str
+@@ -3196,41 +3199,56 @@ static void amd_iommu_get_dm_regions(str
                return;
  
        list_for_each_entry(entry, &amd_iommu_unity_map, list) {
@@ -118,7 +118,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        struct dma_ops_domain *dma_dom = to_dma_ops_domain(to_pdomain(domain));
        unsigned long start, end;
-@@ -3249,9 +3267,9 @@ static const struct iommu_ops amd_iommu_
+@@ -3254,9 +3272,9 @@ static const struct iommu_ops amd_iommu_
        .add_device = amd_iommu_add_device,
        .remove_device = amd_iommu_remove_device,
        .device_group = amd_iommu_device_group,