kernel: bump 4.14 to 4.14.108
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 25 Mar 2019 10:57:36 +0000 (11:57 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 29 Mar 2019 17:04:39 +0000 (18:04 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ipq806x/patches-4.14/0067-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/kirkwood/patches-4.14/200-disable-tso.patch
target/linux/mvebu/patches-4.14/006-mvebu-Mangle-bootloader-s-kernel-arguments.patch
target/linux/oxnas/patches-4.14/996-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/ramips/patches-4.14/0031-uvc-add-iPassion-iP2970-support.patch

index e473179507da15495be28854911373e12e3d8fdf..ad240735a56138f1cdaef73f8b0bc3d54e6252a3 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .165
-LINUX_VERSION-4.14 = .107
+LINUX_VERSION-4.14 = .108
 
 LINUX_KERNEL_HASH-4.9.165 = 47a0916af54b37028417f365c8938477af00235f4f36c514e9375155772f043c
-LINUX_KERNEL_HASH-4.14.107 = e48d0f01468e399d03e443527fe7fa277d0bc46df4a66fad97df47ee1f9b4ef4
+LINUX_KERNEL_HASH-4.14.108 = b6e33c687f26cd13934f961f48985c17ab3fd0e09aae007a175e3bbf3a8ed454
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index c7123eac52c8fa87e5d24f48e6ccb4e51402ec5b..803edfe6f73180bb658f588c32360a124132b8a1 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1938,6 +1938,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1939,6 +1939,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 4b0cbeaba2dc55573cb54c6acedf9efb95dc3272..cdd7fc803e2b5861adeaa3b8bd6635acc1a36a4b 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Ezequiel Garcia <ezequiel.garcia <at> free-electrons.com>
 ---
 --- a/drivers/net/ethernet/marvell/mv643xx_eth.c
 +++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
-@@ -3200,11 +3200,11 @@ static int mv643xx_eth_probe(struct plat
+@@ -3205,11 +3205,11 @@ static int mv643xx_eth_probe(struct plat
        dev->watchdog_timeo = 2 * HZ;
        dev->base_addr = 0;
  
index c4ffd0efea986b3c42a0adae9006c00a9e109d7c..d36125ddb5b3621b160b8d1deb4637106cc6e028 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1938,6 +1938,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1939,6 +1939,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 85947b1974ea464cef780b827efb069b79531de8..2374818dbb9bb2e212e8a47bc46b7fd108c39a6e 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1938,6 +1938,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1939,6 +1939,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 3ef607f14b501d8a3d04cb58285029a34ebaa2f4..ff4c5b17fa07a67d849896f9e2ce6955fe4a6ce0 100644 (file)
@@ -64,7 +64,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include <media/v4l2-common.h>
  
-@@ -1093,9 +1098,149 @@ static void uvc_video_decode_data(struct
+@@ -1101,9 +1106,149 @@ static void uvc_video_decode_data(struct
        }
  }
  
@@ -214,7 +214,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        /* Mark the buffer as done if the EOF marker is set. */
        if (data[1] & UVC_STREAM_EOF && buf->bytesused != 0) {
                uvc_trace(UVC_TRACE_FRAME, "Frame complete (EOF found).\n");
-@@ -1510,6 +1655,8 @@ static int uvc_init_video_isoc(struct uv
+@@ -1518,6 +1663,8 @@ static int uvc_init_video_isoc(struct uv
        if (npackets == 0)
                return -ENOMEM;