mvebu: cortexa9: set DTS dir for 6.6
authorStijn Segers <foss@volatilesystems.org>
Tue, 19 Mar 2024 21:55:11 +0000 (22:55 +0100)
committerRobert Marko <robimarko@gmail.com>
Wed, 3 Apr 2024 15:49:53 +0000 (17:49 +0200)
With 6.6, all DTSes were moved to their vendor subdirectories. ARM64
DTSes already used this scheme, but 32 bit Cortex A9 did not, prior
to 6.6. Introduce a kernel version check to keep backward compatibility
with 6.1.

Suggested-by: Robert Marko <robimarko@gmail.com>
Signed-off-by: Stijn Segers <foss@volatilesystems.org>
target/linux/mvebu/image/cortexa9.mk

index d97509f4d63021d96160465f0c178896694cf34b..270c6314743981205faa7b8ebc407ee8c1ad4a01 100644 (file)
@@ -3,6 +3,10 @@
 # Copyright (C) 2012-2016 OpenWrt.org
 # Copyright (C) 2016 LEDE-project.org
 
+ifneq ($(KERNEL),6.1)
+DTS_DIR := $(DTS_DIR)/marvell
+endif
+
 define Build/fortigate-header
   ( \
     dd if=/dev/zero bs=384 count=1 2>/dev/null; \