mvebu: 6.6: refresh patches
authorStijn Segers <foss@volatilesystems.org>
Thu, 28 Mar 2024 18:05:32 +0000 (19:05 +0100)
committerRobert Marko <robimarko@gmail.com>
Wed, 3 Apr 2024 15:49:53 +0000 (17:49 +0200)
Manually refreshed:
 * 309-linksys-status-led.patch
 * 310-linksys-use-eth0-as-cpu-port.patch
 * 320-arm-dts-armada-370-synology-ds213j-mtd-parts.patch
 * 701-mvpp2-read-mac-address-from-nvmem.patch
 * 902-drivers-mfd-Add-a-driver-for-IEI-WT61P803-PUZZLE-MCU.patch

All other patches automatically refreshed.

Signed-off-by: Stijn Segers <foss@volatilesystems.org>
14 files changed:
target/linux/mvebu/patches-6.6/300-mvebu-Mangle-bootloader-s-kernel-arguments.patch
target/linux/mvebu/patches-6.6/309-linksys-status-led.patch
target/linux/mvebu/patches-6.6/310-linksys-use-eth0-as-cpu-port.patch
target/linux/mvebu/patches-6.6/320-arm-dts-armada-370-synology-ds213j-mtd-parts.patch
target/linux/mvebu/patches-6.6/700-mvneta-tx-queue-workaround.patch
target/linux/mvebu/patches-6.6/701-mvpp2-read-mac-address-from-nvmem.patch
target/linux/mvebu/patches-6.6/800-cpuidle-mvebu-indicate-failure-to-enter-deeper-sleep.patch
target/linux/mvebu/patches-6.6/801-pci-mvebu-time-out-reset-on-link-up.patch
target/linux/mvebu/patches-6.6/901-dt-bindings-Add-IEI-vendor-prefix-and-IEI-WT61P803-P.patch
target/linux/mvebu/patches-6.6/902-drivers-mfd-Add-a-driver-for-IEI-WT61P803-PUZZLE-MCU.patch
target/linux/mvebu/patches-6.6/903-drivers-hwmon-Add-the-IEI-WT61P803-PUZZLE-HWMON-driv.patch
target/linux/mvebu/patches-6.6/904-drivers-leds-Add-the-IEI-WT61P803-PUZZLE-LED-driver.patch
target/linux/mvebu/patches-6.6/906-Documentation-hwmon-Add-iei-wt61p803-puzzle-hwmon-dr.patch
target/linux/mvebu/patches-6.6/907-MAINTAINERS-Add-an-entry-for-the-IEI-WT61P803-PUZZLE.patch

index f3881a0d25e4b27d1c10e883d349675f6d78e1ce..625f51a95df8252db5b37c48eb7d227541006d22 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1587,6 +1587,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1566,6 +1566,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
@@ -48,7 +48,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  config CMDLINE
 --- a/arch/arm/boot/compressed/atags_to_fdt.c
 +++ b/arch/arm/boot/compressed/atags_to_fdt.c
-@@ -5,6 +5,8 @@
+@@ -6,6 +6,8 @@
  
  #if defined(CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND)
  #define do_extend_cmdline 1
@@ -57,7 +57,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  #else
  #define do_extend_cmdline 0
  #endif
-@@ -20,6 +22,7 @@ static int node_offset(void *fdt, const
+@@ -21,6 +23,7 @@ static int node_offset(void *fdt, const
        return offset;
  }
  
@@ -65,7 +65,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  static int setprop(void *fdt, const char *node_path, const char *property,
                   void *val_array, int size)
  {
-@@ -28,6 +31,7 @@ static int setprop(void *fdt, const char
+@@ -29,6 +32,7 @@ static int setprop(void *fdt, const char
                return offset;
        return fdt_setprop(fdt, offset, property, val_array, size);
  }
@@ -73,7 +73,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  
  static int setprop_string(void *fdt, const char *node_path,
                          const char *property, const char *string)
-@@ -38,6 +42,7 @@ static int setprop_string(void *fdt, con
+@@ -39,6 +43,7 @@ static int setprop_string(void *fdt, con
        return fdt_setprop_string(fdt, offset, property, string);
  }
  
@@ -81,7 +81,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  static int setprop_cell(void *fdt, const char *node_path,
                        const char *property, uint32_t val)
  {
-@@ -46,6 +51,7 @@ static int setprop_cell(void *fdt, const
+@@ -47,6 +52,7 @@ static int setprop_cell(void *fdt, const
                return offset;
        return fdt_setprop_cell(fdt, offset, property, val);
  }
@@ -89,7 +89,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  
  static const void *getprop(const void *fdt, const char *node_path,
                           const char *property, int *len)
-@@ -58,6 +64,7 @@ static const void *getprop(const void *f
+@@ -59,6 +65,7 @@ static const void *getprop(const void *f
        return fdt_getprop(fdt, offset, property, len);
  }
  
@@ -97,7 +97,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  static uint32_t get_cell_size(const void *fdt)
  {
        int len;
-@@ -69,6 +76,74 @@ static uint32_t get_cell_size(const void
+@@ -70,6 +77,74 @@ static uint32_t get_cell_size(const void
        return cell_size;
  }
  
@@ -172,7 +172,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  static void merge_fdt_bootargs(void *fdt, const char *fdt_cmdline)
  {
        char cmdline[COMMAND_LINE_SIZE];
-@@ -88,18 +163,28 @@ static void merge_fdt_bootargs(void *fdt
+@@ -89,18 +164,28 @@ static void merge_fdt_bootargs(void *fdt
  
        /* and append the ATAG_CMDLINE */
        if (fdt_cmdline) {
@@ -201,7 +201,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  static void hex_str(char *out, uint32_t value)
  {
        uint32_t digit;
-@@ -117,6 +202,7 @@ static void hex_str(char *out, uint32_t
+@@ -118,6 +203,7 @@ static void hex_str(char *out, uint32_t
        }
        *out = '\0';
  }
@@ -209,7 +209,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  
  /*
   * Convert and fold provided ATAGs into the provided FDT.
-@@ -131,9 +217,11 @@ int atags_to_fdt(void *atag_list, void *
+@@ -132,9 +218,11 @@ int atags_to_fdt(void *atag_list, void *
        struct tag *atag = atag_list;
        /* In the case of 64 bits memory size, need to reserve 2 cells for
         * address and size for each bank */
@@ -223,7 +223,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  
        /* make sure we've got an aligned pointer */
        if ((u32)atag_list & 0x3)
-@@ -168,7 +256,9 @@ int atags_to_fdt(void *atag_list, void *
+@@ -169,7 +257,9 @@ int atags_to_fdt(void *atag_list, void *
                        else
                                setprop_string(fdt, "/chosen", "bootargs",
                                               atag->u.cmdline.cmdline);
@@ -234,7 +234,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
                        if (memcount >= sizeof(mem_reg_property)/4)
                                continue;
                        if (!atag->u.mem.size)
-@@ -212,6 +302,10 @@ int atags_to_fdt(void *atag_list, void *
+@@ -213,6 +303,10 @@ int atags_to_fdt(void *atag_list, void *
                setprop(fdt, "/memory", "reg", mem_reg_property,
                        4 * memcount * memsize);
        }
@@ -247,7 +247,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  }
 --- a/init/main.c
 +++ b/init/main.c
-@@ -112,6 +112,10 @@
+@@ -111,6 +111,10 @@
  
  #include <kunit/test.h>
  
@@ -257,9 +257,9 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
 +
  static int kernel_init(void *);
  
- extern void init_IRQ(void);
-@@ -993,6 +997,18 @@ asmlinkage __visible void __init __no_sa
-       page_alloc_init();
+ /*
+@@ -927,6 +931,18 @@ void start_kernel(void)
+       boot_cpu_hotplug_init();
  
        pr_notice("Kernel command line: %s\n", saved_command_line);
 +
index 4cbc2787b2109ac4d274cebc27db1fc7635931d5..4ad9abc3a1988f538239b5dae4ed23dbaf2314ea 100644 (file)
@@ -18,7 +18,7 @@
                pinctrl-0 = <&gpio_leds_pins>;
                pinctrl-names = "default";
  
--              power {
+-              led-power {
 +              led_power: power {
                        gpios = <&gpio1 23 GPIO_ACTIVE_HIGH>;
                        default-state = "on";
@@ -43,7 +43,7 @@
                pinctrl-0 = <&power_led_pin>;
                pinctrl-names = "default";
  
--              power {
+-              led-power {
 +              led_power: power {
                        label = "mamba:white:power";
                        gpios = <&gpio1 8 GPIO_ACTIVE_HIGH>;
index 8136646671a2bc2754c737fe9e8769bf6b9c2941..683a5ebe51ae13a3c296ed7720d4d873cde963c8 100644 (file)
@@ -17,7 +17,7 @@
 -                              reg = <5>;
 +                      port@6 {
 +                              reg = <6>;
-                               label = "cpu";
+                               phy-mode = "sgmii";
 -                              ethernet = <&eth2>;
 +                              ethernet = <&eth0>;
  
index 0699a47765b110b0bcb002335ed79ae275719631..1f02ff74b07d17ae0276201dfbcb8d0dc05f85c6 100644 (file)
@@ -9,17 +9,17 @@
  
        memory@0 {
 @@ -94,6 +95,8 @@
-                              status = "okay";
-                              phy = <&phy1>;
-                              phy-mode = "sgmii";
-+                             nvmem-cells = <&macaddr_vendor_0>;
-+                             nvmem-cell-names = "mac-address";
+                               status = "okay";
+                               phy = <&phy1>;
+                               phy-mode = "sgmii";
++                              nvmem-cells = <&macaddr_vendor_0>;
++                              nvmem-cell-names = "mac-address";
                        };
  
                        sata@a0000 {
 @@ -175,6 +178,24 @@
-                       gpio = <&gpio1 30 GPIO_ACTIVE_HIGH>;
-               };
+       phy1: ethernet-phy@1 { /* Marvell 88E1512 */
+               reg = <1>;
        };
 +
 +      virtual_flash {
@@ -41,8 +41,8 @@
 +      };
  };
  
- &mdio {
-@@ -265,48 +286,52 @@
+ &pinctrl {
+@@ -259,48 +280,52 @@
                reg = <0>; /* Chip select 0 */
                spi-max-frequency = <20000000>;
  
index 14f93592fe3a7528f3890c63262e02287df58f14..099281e048aabaa3fae7263eea80f6d5faf5faae 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 ---
 --- a/drivers/net/ethernet/marvell/mvneta.c
 +++ b/drivers/net/ethernet/marvell/mvneta.c
-@@ -5233,6 +5233,16 @@ static int mvneta_setup_tc(struct net_de
+@@ -5294,6 +5294,16 @@ static int mvneta_setup_tc(struct net_de
        }
  }
  
@@ -31,7 +31,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static const struct net_device_ops mvneta_netdev_ops = {
        .ndo_open            = mvneta_open,
        .ndo_stop            = mvneta_stop,
-@@ -5243,6 +5253,9 @@ static const struct net_device_ops mvnet
+@@ -5304,6 +5314,9 @@ static const struct net_device_ops mvnet
        .ndo_fix_features    = mvneta_fix_features,
        .ndo_get_stats64     = mvneta_get_stats64,
        .ndo_eth_ioctl        = mvneta_ioctl,
index 1c4194776aac3ccd8d67898078548476af1eab2e..c5bad1772f75e320af96d698c005ab7f1498f195 100644 (file)
@@ -12,16 +12,16 @@ Signed-off-by: Tobias Schramm <tobias@t-sys.eu>
 ---
 --- a/drivers/net/ethernet/marvell/mvpp2/mvpp2_main.c
 +++ b/drivers/net/ethernet/marvell/mvpp2/mvpp2_main.c
-@@ -6134,6 +6134,12 @@ static void mvpp2_port_copy_mac_addr(str
-               }
+@@ -6153,6 +6153,12 @@ static int mvpp2_port_copy_mac_addr(stru
+               return 0;
        }
  
 +      if (!of_get_mac_address(to_of_node(fwnode), hw_mac_addr)) {
 +              *mac_from = "nvmem cell";
 +              eth_hw_addr_set(dev, hw_mac_addr);
-+              return;
++              return 0;
 +      }
 +
        *mac_from = "random";
        eth_hw_addr_random(dev);
- }
index 29f36be460d22a03b72b9af822b0b7266250eeb8..5df5aca5dc9e4cdbf766325045c989c4bcbaa842 100644 (file)
@@ -24,8 +24,8 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
 
 --- a/drivers/cpuidle/cpuidle-mvebu-v7.c
 +++ b/drivers/cpuidle/cpuidle-mvebu-v7.c
-@@ -39,8 +39,12 @@ static int mvebu_v7_enter_idle(struct cp
-       ret = mvebu_v7_cpu_suspend(deepidle);
+@@ -42,8 +42,12 @@ static __cpuidle int mvebu_v7_enter_idle
        cpu_pm_exit();
  
 +      /*
index d2995b375c4f0c0314a51c9ec92c0f0e9491f69b..f1832c8940dfe164e81ff016ae444ef9af5a644d 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 
 --- a/drivers/pci/controller/pci-mvebu.c
 +++ b/drivers/pci/controller/pci-mvebu.c
-@@ -1414,6 +1414,7 @@ static int mvebu_pcie_powerup(struct mve
+@@ -1397,6 +1397,7 @@ static int mvebu_pcie_powerup(struct mve
  
        if (port->reset_gpio) {
                u32 reset_udelay = PCI_PM_D3COLD_WAIT * 1000;
@@ -21,7 +21,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
  
                of_property_read_u32(port->dn, "reset-delay-us",
                                     &reset_udelay);
-@@ -1421,7 +1422,13 @@ static int mvebu_pcie_powerup(struct mve
+@@ -1404,7 +1405,13 @@ static int mvebu_pcie_powerup(struct mve
                udelay(100);
  
                gpiod_set_value_cansleep(port->reset_gpio, 0);
@@ -36,7 +36,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
        }
  
        return 0;
-@@ -1538,15 +1545,16 @@ static int mvebu_pcie_probe(struct platf
+@@ -1521,15 +1528,16 @@ static int mvebu_pcie_probe(struct platf
                if (!child)
                        continue;
  
index fc5c80458243435d7bbb31321ede38792e2d926e..e9c1d57d244e12361ade99f2089297431ec2db61 100644 (file)
@@ -207,7 +207,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 +    };
 --- a/Documentation/devicetree/bindings/vendor-prefixes.yaml
 +++ b/Documentation/devicetree/bindings/vendor-prefixes.yaml
-@@ -579,6 +579,8 @@ patternProperties:
+@@ -609,6 +609,8 @@ patternProperties:
      description: IC Plus Corp.
    "^idt,.*":
      description: Integrated Device Technologies, Inc.
index 47d9e3a263761b02676579e40a0bfebf931c5d69..1046b15e4b79dc215b83b2a836942bd6e5287b56 100644 (file)
@@ -26,7 +26,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/mfd/Kconfig
 +++ b/drivers/mfd/Kconfig
-@@ -2222,6 +2222,15 @@ config SGI_MFD_IOC3
+@@ -2274,6 +2274,15 @@ config SGI_MFD_IOC3
          If you have an SGI Origin, Octane, or a PCI IOC3 card,
          then say Y. Otherwise say N.
  
@@ -39,9 +39,9 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 +        used for fan control, temperature sensor reading, LED control
 +        and system identification.
 +
- config MFD_INTEL_M10_BMC
-       tristate "Intel MAX 10 Board Management Controller"
-       depends on SPI_MASTER
+ config MFD_INTEL_M10_BMC_CORE
+         tristate
+         select MFD_CORE
 --- a/drivers/mfd/Makefile
 +++ b/drivers/mfd/Makefile
 @@ -244,6 +244,7 @@ obj-$(CONFIG_MFD_RT4831)   += rt4831.o
index a11b387d929207d982018aa5d9aa2bda1410170e..d4a533917b5dd76f38f716f203a6235e9412f0b7 100644 (file)
@@ -26,7 +26,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/hwmon/Kconfig
 +++ b/drivers/hwmon/Kconfig
-@@ -755,6 +755,14 @@ config SENSORS_IBMPOWERNV
+@@ -783,6 +783,14 @@ config SENSORS_IBMPOWERNV
          This driver can also be built as a module. If so, the module
          will be called ibmpowernv.
  
@@ -43,7 +43,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
        depends on IIO
 --- a/drivers/hwmon/Makefile
 +++ b/drivers/hwmon/Makefile
-@@ -87,6 +87,7 @@ obj-$(CONFIG_SENSORS_HIH6130)        += hih6130
+@@ -90,6 +90,7 @@ obj-$(CONFIG_SENSORS_HS3001) += hs3001.o
  obj-$(CONFIG_SENSORS_ULTRA45) += ultra45_env.o
  obj-$(CONFIG_SENSORS_I5500)   += i5500_temp.o
  obj-$(CONFIG_SENSORS_I5K_AMB) += i5k_amb.o
index 1abb1b94166be11073664d434ffe9305faa1d75f..a9cb46bbd848c8ecd524fe900ab5bdd4228f91a8 100644 (file)
@@ -30,7 +30,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -300,6 +300,14 @@ config LEDS_IPAQ_MICRO
+@@ -316,6 +316,14 @@ config LEDS_IPAQ_MICRO
          Choose this option if you want to use the notification LED on
          Compaq/HP iPAQ h3100 and h3600.
  
@@ -47,7 +47,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
        depends on LEDS_CLASS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -32,6 +32,7 @@ obj-$(CONFIG_LEDS_HP6XX)             += leds-hp6xx.
+@@ -34,6 +34,7 @@ obj-$(CONFIG_LEDS_HP6XX)             += leds-hp6xx.
  obj-$(CONFIG_LEDS_INTEL_SS4200)               += leds-ss4200.o
  obj-$(CONFIG_LEDS_IP30)                       += leds-ip30.o
  obj-$(CONFIG_LEDS_IPAQ_MICRO)         += leds-ipaq-micro.o
index 0f1a6f306bbe303071484834c32f4145f825cae9..77e9fa298e70f983a695cad88163481dcb0f7608 100644 (file)
@@ -64,7 +64,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 +================= == =====================================================
 --- a/Documentation/hwmon/index.rst
 +++ b/Documentation/hwmon/index.rst
-@@ -77,6 +77,7 @@ Hardware Monitoring Kernel Drivers
+@@ -82,6 +82,7 @@ Hardware Monitoring Kernel Drivers
     ibmaem
     ibm-cffps
     ibmpowernv
index e72df378efec2020ba1d91fc37a5adcd2e35d21b..2a8397d0b55f4fba7f48fc1e54eb517fcf13ddd6 100644 (file)
@@ -16,9 +16,9 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -9900,6 +9900,22 @@ F:      include/net/nl802154.h
- F:    net/ieee802154/
- F:    net/mac802154/
+@@ -10138,6 +10138,22 @@ IFCVF VIRTIO DATA PATH ACCELERATOR
+ R:    Zhu Lingshan <lingshan.zhu@intel.com>
+ F:    drivers/vdpa/ifcvf/
  
 +IEI WT61P803 M801 MFD DRIVER
 +M:    Luka Kovacic <luka.kovacic@sartura.hr>