malta: fix overlay support by updating to f2fs/ext4 based overlays
authorPetr Štetiar <ynezz@true.cz>
Thu, 28 Mar 2019 14:34:26 +0000 (14:34 +0000)
committerPetr Štetiar <ynezz@true.cz>
Tue, 25 Jun 2019 14:12:22 +0000 (14:12 +0000)
Current snapshot images doesn't provide images with usable overlay
filesystems:

 mount_root: no usable overlay filesystem found, using tmpfs overlay

So this patch fixes this by updating support to current f2fs/ext4 based
overlays and providing squashfs with proper rootfs
TARGET_ROOTFS_PARTSIZE size.

While at it, I've also added support for optional gzipping of the
images, and renamed the output rootfs image filenames to match the more
common naming pattern $(IMG_PREFIX)-rootfs-$(FS-TYPE).img.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/malta/Makefile
target/linux/malta/image/Makefile

index 435c1b656861cf1683e01e1bd61789b46f267a5d..6d520e4a52e105de4abed5bc86dc2dbe865e50fb 100644 (file)
@@ -12,12 +12,12 @@ CPU_TYPE:=24kc
 SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-FEATURES:=ramdisk
+FEATURES:=cpiogz ext4 ramdisk squashfs targz
 
 KERNEL_PATCHVER:=4.19
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-basic kmod-mac80211-hwsim kmod-pcnet32
+DEFAULT_PACKAGES += wpad-basic kmod-mac80211-hwsim kmod-pcnet32 mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))
index d49d4a762d610079207ed5bade138d20697afb82..72e7eab8073aec08cef1ee2b086f44ad47ce644c 100644 (file)
@@ -34,18 +34,21 @@ define Image/BuildKernel
        cp $(KDIR)/uImage.gz $(BIN_DIR)/$(IMG_PREFIX)-uImage-gzip
 endef
 
-define Image/Build/squashfs
-    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-endef
-
 define Image/Build/Initramfs
        cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
        cp $(KDIR)/vmlinux-initramfs $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.bin
 endef
 
+define Image/Build/gzip
+       gzip -f9n $(BIN_DIR)/$(IMG_ROOTFS)-$(1).img
+endef
+
+$(eval $(call Image/gzip-ext4-padded-squashfs))
+
 define Image/Build
        $(call Image/Build/$(1))
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_ROOTFS)-$(1).img
+       $(call Image/Build/gzip/$(1))
 endef
 
 $(eval $(call BuildImage))