applications: add missing dependency to luci-base
authorSergey Ponomarev <stokito@gmail.com>
Sun, 24 Sep 2023 08:11:42 +0000 (11:11 +0300)
committerSergey Ponomarev <stokito@gmail.com>
Sun, 24 Sep 2023 08:11:42 +0000 (11:11 +0300)
It's better to explicitly define it

Signed-off-by: Sergey Ponomarev <stokito@gmail.com>
74 files changed:
applications/luci-app-adblock/Makefile
applications/luci-app-ahcp/Makefile
applications/luci-app-apinger/Makefile
applications/luci-app-aria2/Makefile
applications/luci-app-babeld/Makefile
applications/luci-app-banip/Makefile
applications/luci-app-commands/Makefile
applications/luci-app-coovachilli/Makefile
applications/luci-app-cshark/Makefile
applications/luci-app-dawn/Makefile
applications/luci-app-dcwapd/Makefile
applications/luci-app-diag-core/Makefile
applications/luci-app-dnscrypt-proxy/Makefile
applications/luci-app-dockerman/Makefile
applications/luci-app-dump1090/Makefile
applications/luci-app-dynapoint/Makefile
applications/luci-app-firewall/Makefile
applications/luci-app-frpc/Makefile
applications/luci-app-frps/Makefile
applications/luci-app-fwknopd/Makefile
applications/luci-app-hd-idle/Makefile
applications/luci-app-ksmbd/Makefile
applications/luci-app-ledtrig-rssi/Makefile
applications/luci-app-ledtrig-switch/Makefile
applications/luci-app-ledtrig-usbport/Makefile
applications/luci-app-lorawan-basicstation/Makefile
applications/luci-app-ltqtapi/Makefile
applications/luci-app-minidlna/Makefile
applications/luci-app-mjpg-streamer/Makefile
applications/luci-app-mwan3/Makefile
applications/luci-app-natmap/Makefile
applications/luci-app-nextdns/Makefile
applications/luci-app-nft-qos/Makefile
applications/luci-app-nlbwmon/Makefile
applications/luci-app-ntpc/Makefile
applications/luci-app-nut/Makefile
applications/luci-app-ocserv/Makefile
applications/luci-app-olsr-services/Makefile
applications/luci-app-olsr-viz/Makefile
applications/luci-app-olsr/Makefile
applications/luci-app-omcproxy/Makefile
applications/luci-app-openvpn/Makefile
applications/luci-app-openwisp/Makefile
applications/luci-app-opkg/Makefile
applications/luci-app-p910nd/Makefile
applications/luci-app-pagekitec/Makefile
applications/luci-app-polipo/Makefile
applications/luci-app-qos/Makefile
applications/luci-app-radicale2/Makefile
applications/luci-app-rp-pppoe-server/Makefile
applications/luci-app-samba4/Makefile
applications/luci-app-ser2net/Makefile
applications/luci-app-shairplay/Makefile
applications/luci-app-siitwizard/Makefile
applications/luci-app-smartdns/Makefile
applications/luci-app-softether/Makefile
applications/luci-app-splash/Makefile
applications/luci-app-sqm/Makefile
applications/luci-app-tinyproxy/Makefile
applications/luci-app-transmission/Makefile
applications/luci-app-travelmate/Makefile
applications/luci-app-ttyd/Makefile
applications/luci-app-udpxy/Makefile
applications/luci-app-uhttpd/Makefile
applications/luci-app-unbound/Makefile
applications/luci-app-upnp/Makefile
applications/luci-app-vnstat/Makefile
applications/luci-app-vnstat2/Makefile
applications/luci-app-watchcat/Makefile
applications/luci-app-wifischedule/Makefile
applications/luci-app-wol/Makefile
applications/luci-app-xfrpc/Makefile
applications/luci-app-xinetd/Makefile
applications/luci-app-yggdrasil/Makefile

index 0d4bc939495875a0c4182519a24061b231523dcd..3548c5232310203297c24540da40153bf605c5c2 100644 (file)
@@ -4,7 +4,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for Adblock
-LUCI_DEPENDS:=+adblock
+LUCI_DEPENDS:=+luci-base +adblock
 LUCI_PKGARCH:=all
 
 PKG_LICENSE:=Apache-2.0
index 10859345e658acfed81cf2990cd711b8a160e350..f66be24766c3b91d1de9714b976709d26a0fb110 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for AHCPd
-LUCI_DEPENDS:=+luci-compat +ahcpd
+LUCI_DEPENDS:=+luci-base +luci-compat +ahcpd
 
 include ../../luci.mk
 
index 78de53a7e8afa10f78a4663bde076b28cac114b8..77b18bf08db9252cb66b5f66c3965997efdba5db 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for the Apinger
-LUCI_DEPENDS:=+apinger +apinger-rrd
+LUCI_DEPENDS:=+luci-base +apinger +apinger-rrd
 LUCI_PKGARCH:=all
 PKG_LICENSE:=GPL-2.0
 
index ad6bd1d1849f1eeb840706858677b6a84ce646ec..f6f10dc8be7391c3157aadebc74f25dfe8961c64 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for Aria2
-LUCI_DEPENDS:=+aria2
+LUCI_DEPENDS:=+luci-base +aria2
 LUCI_PKGARCH:=all
 
 PKG_MAINTAINER:=Xingwang Liao <kuoruan@gmail.com>
index 6af9280261b657df4b6914f3a47b7878d84e0ef3..50ce9ce068e141bf8e6f43bb3402f7829c4ce869 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for babeld
-LUCI_DEPENDS:=+babeld +luci-compat
+LUCI_DEPENDS:=+luci-base +babeld +luci-compat
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index 60e4ecb52961d0d523ae3f145bf65c7f9f73d7d1..0da87b9e922eb587cd883a6e84e9618741409a07 100644 (file)
@@ -4,7 +4,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for banIP
-LUCI_DEPENDS:=+banip
+LUCI_DEPENDS:=+luci-base +banip
 LUCI_PKGARCH:=all
 
 PKG_LICENSE:=Apache-2.0
index e581a003b8196481db1d872981f409b772c96628..6378f572ff1c2b247f95fc286c0b4d01f102497a 100644 (file)
@@ -7,6 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Shell Command Module
+LUCI_DEPENDS:=+luci-base
 
 PKG_LICENSE:=Apache-2.0
 
index 4bcafdc8f891810784551eb8d8a0e203c59df483..1f3a0fc0ea67c3af5e90f1706577319e42c784fa 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for Coova Chilli
-LUCI_DEPENDS:=+luci-compat @BROKEN
+LUCI_DEPENDS:=+luci-base +luci-compat @BROKEN
 
 include ../../luci.mk
 
index c8a283bea4e17861e71cfbdae750c0998ae7ba0b..1273b50a3ba6768128ada1dbf9329e900f2356b5 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Cloudshark capture tool Web UI
-LUCI_DEPENDS:=+luci-compat +cshark
+LUCI_DEPENDS:=+luci-base +luci-compat +cshark
 LUCI_PKGARCH:=all
 
 PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
index 1b2b598cc89c9b90601384d1cb5f6e070b00c34b..3e1ce3cc0ac7dc6b2575eb15215ffc5d78c35e45 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for DAWN
-LUCI_DEPENDS:=+dawn +luci-compat +luci-lib-json
+LUCI_DEPENDS:=+luci-base +dawn +luci-compat +luci-lib-json
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index 3def090a76215eb0323cb100266fa0ed21472014..6b85d0c864ca5be7321f7a888ec51fc6e5d53e13 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Dual Channel Wi-Fi AP Daemon configuration module
-LUCI_DEPENDS:=+luci-compat +dcwapd
+LUCI_DEPENDS:=+luci-base +luci-compat +dcwapd
 
 include ../../luci.mk
 
index ac9f499b121cedf1dbe9c835b7b5d8bd8dbb4a1c..1fcd9c6fc47d4f55f17934948ab9d5ff8b0853de 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Diagnostics Tools (Core)
-LUCI_DEPENDS:=
+LUCI_DEPENDS:=+luci-base
 
 include ../../luci.mk
 
index c67b83000f1aa5ea1c4d54d7405854fc996e3616..e79b06de88c92f705a5aba1c965b154897c8e36c 100644 (file)
@@ -5,7 +5,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for DNSCrypt-Proxy
-LUCI_DEPENDS:=+luci-compat +uclient-fetch +dnscrypt-proxy +luci-lib-httpprotoutils
+LUCI_DEPENDS:=+luci-base +luci-compat +uclient-fetch +dnscrypt-proxy +luci-lib-httpprotoutils
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index f4d103086026c6a84471a40ebf67732a4c6b2fc0..06c7180b0ad45bec60c215638eaf4f3b892737d1 100644 (file)
@@ -2,6 +2,7 @@ include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for docker
 LUCI_DEPENDS:=@(aarch64||arm||x86_64) \
+       +luci-base \
        +luci-compat \
        +luci-lib-docker \
        +docker \
index 81cf9f0ed43cf6dafab7cab0a7e45a01ce4a4a0b..8cc7ef306d869beea01009ca7f76d2e84b5e464a 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for dump1090
-LUCI_DEPENDS:=+luci-compat +dump1090
+LUCI_DEPENDS:=+luci-base +luci-compat +dump1090
 
 include ../../luci.mk
 
index a763dc6146baac6aab1e62efd8dddb8a530e39fb..1f4486ef4b1a07123a88d46bd13ad445bd5d3bad 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for DynaPoint
-LUCI_DEPENDS:=+luci-compat +luci-lib-ipkg +dynapoint
+LUCI_DEPENDS:=+luci-base +luci-compat +luci-lib-ipkg +dynapoint
 
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Tobias Ilte <tobias.ilte@campus.tu-berlin.de>
index 2e219d0096546ad44f0e6471d1905522e2a078ed..fc3312888689e43c303a48a184d4b58d96780c6e 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Firewall and Portforwarding application
-LUCI_DEPENDS:=+uci-firewall
+LUCI_DEPENDS:=+luci-base +uci-firewall
 
 PKG_LICENSE:=Apache-2.0
 
index 90a20c4bfc088ba714c778b8797326b1eb9162ff..16e10e54a6aea336d3b1e20ca7d6d6da193f5c82 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for frp client
-LUCI_DEPENDS:=+frpc
+LUCI_DEPENDS:=+luci-base +frpc
 
 PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Richard Yu <yurichard3839@gmail.com>
index 4d77b03c074ec113092bbf0ae4e03f3ec4aa0818..f835b9aa398d7a7f6eaaee660e4e597a2866f87d 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for frp server
-LUCI_DEPENDS:=+frps
+LUCI_DEPENDS:=+luci-base +frps
 
 PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Richard Yu <yurichard3839@gmail.com>
index ba7a8568e7caff0218746a74ed03b80d885b261b..7aabd3c2af6172cb13a9c0d97e90a73135cf2d58 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Fwknopd config - web config for the firewall knock daemon
-LUCI_DEPENDS:=+fwknopd +qrencode
+LUCI_DEPENDS:=+luci-base +fwknopd +qrencode
 PKG_LICENSE:=GPLv2
 PKG_MAINTAINER:=Jonathan Bennett <JBennett@incomsystems.biz>
 include ../../luci.mk
index 28e1cef14b331b59c459b3c404125a017b8d252b..e5c16c9fc25967fdf1bfa30d7937463f0a5ce8c4 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Hard Disk Idle Spin-Down module
-LUCI_DEPENDS:=+hd-idle +lsblk
+LUCI_DEPENDS:=+luci-base +hd-idle +lsblk
 
 include ../../luci.mk
 
index 08f476a2774c98e59a4879eed2628d37206d4a87..c360614e2d49189e08a5909d02d8d150b0e5ed40 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Network Shares - Ksmbd the SMB kernel fileserver
-LUCI_DEPENDS:=+ksmbd-server
+LUCI_DEPENDS:=+luci-base +ksmbd-server
 
 include ../../luci.mk
 
index b3be2065c88a21032d4656c85e542917e0c1432e..e08acad4e2e32c7d96d8264e401048bc51103a51 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:= LuCI Support for ledtrigger rssi
-LUCI_DEPENDS:=+rssileds
+LUCI_DEPENDS:=+luci-base +rssileds
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index 7cefc50294bf821e650e4570dd05aadc719649ac..cecacfa80f9eaff4e22d8ba288174aca012eaf77 100644 (file)
@@ -8,6 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:= LuCI Support for ledtrigger switch
+LUCI_DEPENDS:=+luci-base
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index 1a176676facd48a002f8a7a0857bbd438b8e576e..5e2cee96f2a9a9e019bb648400a484526ae5b449 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:= LuCI Support for ledtrigger usbport
-LUCI_DEPENDS:=+kmod-usb-ledtrig-usbport
+LUCI_DEPENDS:=+luci-base +kmod-usb-ledtrig-usbport
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index 392587767b0aa0e4fb274f305226a4f528f47700..1eb2afe5f93691599933a98b77889159315e4647 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for LoRaWAN basicstation
-LUCI_DEPENDS:=+basicstation
+LUCI_DEPENDS:=+luci-base +basicstation
 LUCI_PKGARCH:=all
 
 PKG_MAINTAINER:=Marcus Schref <mschref@tdt.de>
index c9692481263bed2e73dc46bd0be7ec3aa742f6b5..0b377ba4b87d4d55e170aa88f90711df713d3756 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for Lantiq Devices
-LUCI_DEPENDS:=+luci-compat @BROKEN
+LUCI_DEPENDS:=+luci-base +luci-compat @BROKEN
 
 include ../../luci.mk
 
index 4790aa32ced30fa14cbd216bc09879e9554006e7..29d1870f110849efff0b098f348be66ff9d48da2 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for miniDLNA
-LUCI_DEPENDS:=+minidlna
+LUCI_DEPENDS:=+luci-base +minidlna
 
 include ../../luci.mk
 
index b4f1f1412741f462eec9beb39669f1015d8e93c5..11048862f06465016908e9f19be661f532d72de1 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=MJPG-Streamer service configuration module
-LUCI_DEPENDS:= +mjpg-streamer
+LUCI_DEPENDS:=+luci-base +mjpg-streamer
 
 include ../../luci.mk
 
index 8edba3ccd52a534c6c0c232b1e9ec3f523a6f63d..31d15afd47c651e37c9113d6ffad44d21a393810 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for the MWAN3 MultiWAN Manager
-LUCI_DEPENDS:=+mwan3
+LUCI_DEPENDS:=+luci-base +mwan3
 LUCI_PKGARCH:=all
 PKG_LICENSE:=GPLv2
 
index 0d02dcac51d4f8d25a0e52ec02045c217f8aeca8..7238f0da38e4fe2bf35962b734d3fa671880ed92 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for natmap
-LUCI_DEPENDS:=+natmap
+LUCI_DEPENDS:=+luci-base +natmap
 
 PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Richard Yu <yurichard3839@gmail.com>
index 51d60561b17e1233a27ac27b37cc0d695a6e3461..cd4980ccb9245e440f7e7f33e53acf315d77c589 100644 (file)
@@ -4,7 +4,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for NextDNS
-LUCI_DEPENDS:=+nextdns
+LUCI_DEPENDS:=+luci-base +nextdns
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index a8227de9fd92b7f437076fc4e4f8fd38d49b6a0f..1690854fc4eac715cf174f47d1df1b50160aef6e 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=QoS over Nftables
-LUCI_DEPENDS:=+luci-compat +nft-qos
+LUCI_DEPENDS:=+luci-base +luci-compat +nft-qos
 
 include ../../luci.mk
 
index a00177f2ca3b682d0d917867073832c4b49c8d5a..d53452c3f0f7bf74117efe2f1c38289a93f17e7f 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Netlink based bandwidth accounting
-LUCI_DEPENDS:=+nlbwmon
+LUCI_DEPENDS:=+luci-base +nlbwmon
 
 include ../../luci.mk
 
index b144b7ba939ac55bf328677132c03c75aa073271..108ed9027e2a41f5644aa452639f16ee42766602 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=NTP time synchronisation configuration module
-LUCI_DEPENDS:=+luci-compat +ntpclient
+LUCI_DEPENDS:=+luci-base +luci-compat +ntpclient
 
 include ../../luci.mk
 
index cce56e0c9f003ef94745eae12f4f548b2768dc8e..1190a50eb684ba81e46ec32f91a1ff809ae9c687 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Network UPS Tools Configuration
-LUCI_DEPENDS:=+luci-compat
+LUCI_DEPENDS:=+luci-base +luci-compat
 LUCI_PKGARCH:=all
 PKG_RELEASE:=1
 
index 2f2ea788ebbe942adb5df702f569c7d4152b0e56..918e85815b18fb4b56cb33e802143dcdcdce4f51 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for OpenConnect VPN
-LUCI_DEPENDS:=+luci-compat +ocserv +certtool
+LUCI_DEPENDS:=+luci-base +luci-compat +ocserv +certtool
 
 include ../../luci.mk
 
index b1daf6daad71c7b6402c72fc7b7b95781f056daa..245ea602d5f51f64f6e6cf1b4f280b66798f9000 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Show services announced with the nameservice plugin
-LUCI_DEPENDS:=+luci-app-olsr +olsrd +olsrd-mod-nameservice
+LUCI_DEPENDS:=+luci-base +luci-app-olsr +olsrd +olsrd-mod-nameservice
 
 include ../../luci.mk
 
index e1a1185092345cb67e64c4b062d6d9f4e6a2e315..34ac041f4d1ac617a526c2e09b2a31386fa72844 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=OLSR Visualisation
-LUCI_DEPENDS:=+luci-app-olsr +olsrd +olsrd-mod-txtinfo
+LUCI_DEPENDS:=+luci-base +luci-app-olsr +olsrd +olsrd-mod-txtinfo
 
 include ../../luci.mk
 
index 168bfab9f3abfcef5206b28090620d9ed36d2db8..b503809a78b04f715eda69cadbea6f38d0fdcbc0 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=OLSR configuration and status module
-LUCI_DEPENDS:=+olsrd
+LUCI_DEPENDS:=+luci-base +olsrd
 
 include ../../luci.mk
 
index 622ce069504dba3e91f6ca7ab97b0c5e0788149b..77bf565015767ce6ca9ce9910a23f07b2afa74a9 100644 (file)
@@ -14,7 +14,7 @@ PKG_MAINTAINER:=Shun Li <riverscn@gmail.com>
 PKG_LICENSE:=Apache-2.0
 
 LUCI_TITLE:=LuCI support for omcproxy
-LUCI_DEPENDS:=+omcproxy
+LUCI_DEPENDS:=+luci-base +omcproxy
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index 4dfcc682ce64382e9905f04816a07f1cceacbe9a..74df261b0d72e904b6180479e055f3f5429dc5e3 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for OpenVPN
-LUCI_DEPENDS:=+luci-compat
+LUCI_DEPENDS:=+luci-base +luci-compat
 
 PKG_LICENSE:=Apache-2.0
 
index 03fbd83c1136295b4e909deac198d8d250f26570..b8b147998dbd811a40d868a8d61825b8ca4fc63c 100644 (file)
@@ -8,7 +8,7 @@ PKG_MAINTAINER:=Nicholas Smith <nicholas@nbembedded.com>
 
 LUCI_TITLE:=LuCI support for OpenWISP
 LUCI_DESCRIPTION:=Allows configuration of OpenWISP agent settings
-LUCI_DEPENDS:=+openwisp-config
+LUCI_DEPENDS:=+luci-base +openwisp-config
 
 include ../../luci.mk
 
index 5763e9115ebd3e28013eb632a4697e98cf05414c..0f3d8a7027ccf524a28c1277c7262c76c651e4c4 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=OPKG package management application
-LUCI_DEPENDS:=+opkg
+LUCI_DEPENDS:=+luci-base +opkg
 
 include ../../luci.mk
 
index 8c73f372f472b7a4e39cfaa04c764fbe352659e8..4b33020cbd552322345ad448f1c189ec23ac1aa8 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=p910nd - Printer server module
-LUCI_DEPENDS:=+luci-compat +p910nd
+LUCI_DEPENDS:=+luci-base +luci-compat +p910nd
 
 include ../../luci.mk
 
index d875009772d0526e5ebe94b34ad6d07b17e381c3..9ed223a7ca668e6fa3be8ae51388928ce3f3771c 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for PageKite
-LUCI_DEPENDS:=+pagekitec
+LUCI_DEPENDS:=+luci-base +pagekitec
 
 PKG_MAINTAINER:=Karl Palsson <karlp@tweak.net.au>
 
index 0bd18433220ed49c8878ed5a8738ad356c47381a..cd157e48e96cc5fd4b159c94d30bde62e7f21785 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for the Polipo Proxy
-LUCI_DEPENDS:=+luci-compat +polipo
+LUCI_DEPENDS:=+luci-base +luci-compat +polipo
 
 include ../../luci.mk
 
index 8361b6e2e6deb1a6fcc135917509bab2562c3e20..846858d0436cae1c67534e1c5975c9b92e6409d4 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Quality of Service configuration module
-LUCI_DEPENDS:=+luci-compat +qos-scripts
+LUCI_DEPENDS:=+luci-base +luci-compat +qos-scripts
 
 PKG_LICENSE:=Apache-2.0
 
index aa964d4f5112dad30e0fe45cf7bdf882baa0efe2..fe7e9e98c662a3256f33ce7c48cafa5ebbde6939 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Radicale v2.x CalDAV/CardDAV Server
-LUCI_DEPENDS:=+luci-compat +radicale2 +rpcd-mod-rad2-enc
+LUCI_DEPENDS:=+luci-base +luci-compat +radicale2 +rpcd-mod-rad2-enc
 LUCI_PKGARCH:=all
 
 PKG_LICENSE:=Apache-2.0
index b4edfc9499a5d978046090b0651646e08caa4cbd..4454242d48607574b9d949239fd301f3fe91ed3c 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Roaring Penguin PPPoE Server
-LUCI_DEPENDS:=+luci-compat +rp-pppoe-server
+LUCI_DEPENDS:=+luci-base +luci-compat +rp-pppoe-server
 
 include ../../luci.mk
 
index b0dedc5413de6e8907d8119c47af8b4dfa3a418b..0073e6a7e3d7a77af7c2ea5fc7ecde9cbdbb9eda 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Network Shares - Samba 4 SMB/CIFS fileserver
-LUCI_DEPENDS:=+samba4-server
+LUCI_DEPENDS:=+luci-base +samba4-server
 
 include ../../luci.mk
 
index a77bd4009e33be8129c8a447be5b52bf681ad65c..72ca1f698aee3c75df8f7f8af8948ace84421022 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for ser2net
-LUCI_DEPENDS:=+ser2net
+LUCI_DEPENDS:=+luci-base +ser2net
 
 PKG_LICENSE:=Apache-2.0
 
index 59ca53d1b1fe138d362b2787679949bc10d0d99e..1e9ca6bef1d7690fecfba90d53c7cdbd4c8e6140 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for Shairplay
-LUCI_DEPENDS:=+luci-compat +shairplay
+LUCI_DEPENDS:=+luci-base +luci-compat +shairplay
 
 include ../../luci.mk
 
index a411f6aa3dc0a02a713b6a93a3dbccbc80a600b6..7677db0cf2386227ef5c0b7c1e4b5ec289978780 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=SIIT IPv4-over-IPv6 configuration wizard
-LUCI_DEPENDS:=+luci-compat +kmod-siit
+LUCI_DEPENDS:=+luci-base +luci-compat +kmod-siit
 
 include ../../luci.mk
 
index 407e98f7c89361842beb0804236999b58e7a0669..217288cfa4179dc16cd252d84e07940c2c65697b 100644 (file)
@@ -11,7 +11,7 @@ PKG_RELEASE:=1
 
 LUCI_TITLE:=LuCI for smartdns
 LUCI_DESCRIPTION:=Provides Luci for smartdns
-LUCI_DEPENDS:=+smartdns
+LUCI_DEPENDS:=+luci-base +smartdns
 LUCI_PKGARCH:=all
 
 define Package/$(PKG_NAME)/config
index 06a310c7e1f33299cbb0adc521ff61474df15ac0..03215084012a2573cd03e010cff3974f255e39bd 100644 (file)
@@ -5,7 +5,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Softether management application
-LUCI_DEPENDS:=+softethervpn5-client
+LUCI_DEPENDS:=+luci-base +softethervpn5-client
 
 include ../../luci.mk
 
index 8950a497ea2276f8498a4eef100b620431e29eb4..5d9503c62270bac62a7cc783e9dc97de21d277de 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Freifunk DHCP-Splash application
-LUCI_DEPENDS:=+luci-compat +luci-lib-nixio +luci-lib-iptparser +luci-lua-runtime +tc +kmod-sched +iptables-mod-nat-extra +iptables-mod-ipopt
+LUCI_DEPENDS:=+luci-base +luci-compat +luci-lib-nixio +luci-lib-iptparser +luci-lua-runtime +tc +kmod-sched +iptables-mod-nat-extra +iptables-mod-ipopt
 
 define Package/luci-app-splash/conffiles
 /etc/config/luci_splash
index 4ab842b2414d246a7e8510fe3e8953c15fa8125c..f83b99ee2d745cee0999b54d5ba7f3bf4d47823c 100644 (file)
@@ -8,7 +8,7 @@ LUCI_DESCRIPTION:=Luci interface for the SQM scripts queue management package
 
 PKG_MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
 
-LUCI_DEPENDS:=+sqm-scripts
+LUCI_DEPENDS:=+luci-base +sqm-scripts
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index f4c7475b8bed3196b189d637e213b0414b598dcb..8a90ce7f16d5a8f7c1783116df7b4cfaf3b5f2aa 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Tinyproxy - HTTP(S)-Proxy configuration
-LUCI_DEPENDS:=+luci-compat +tinyproxy
+LUCI_DEPENDS:=+luci-base +luci-compat +tinyproxy
 
 include ../../luci.mk
 
index d0fddbefef06213583243ecce621c90dca6456b3..ff0b105a14c837840b2d34597c9ef27a249b2c5a 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for Transmission
-LUCI_DEPENDS:=+transmission-daemon
+LUCI_DEPENDS:=+luci-base +transmission-daemon
 
 include ../../luci.mk
 
index 5444d2bbe0406acc048326869382b0b79cecabe8..ec16edaddd64871af169292191dcb9e87327bc0e 100644 (file)
@@ -4,7 +4,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for Travelmate
-LUCI_DEPENDS:=+travelmate
+LUCI_DEPENDS:=+luci-base +travelmate
 LUCI_PKGARCH:=all
 
 PKG_LICENSE:=Apache-2.0
index 65ec02710f620deeb7837911a2158984e9f3d4b9..148464411aa97d26f7ce3f7835c36f2e190ca2c0 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=ttyd - Command-line tool for sharing terminal over the web
-LUCI_DEPENDS:=+ttyd
+LUCI_DEPENDS:=+luci-base +ttyd
 
 include ../../luci.mk
 
index cb8f1792322266842c969c4804ed47c367267690..ee2350ba933c0541f00fc497efd6adaabab682e7 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for udpxy
-LUCI_DEPENDS:=+udpxy
+LUCI_DEPENDS:=+luci-base +udpxy
 
 include ../../luci.mk
 
index 95429650a1628cea7e2dddd49e7adc5dee3cc324..da7e8697fd0cf67991646bde200e8488a394a5ee 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=uHTTPd Webserver Configuration
-LUCI_DEPENDS:= +uhttpd
+LUCI_DEPENDS:=+luci-base +uhttpd
 
 PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Daniel Dickinson <openwrt@daniel.thecshore.com>
index 9dd01ffed6b70357eeacd68679e7640be3fc76bd..4376a9aa8e1b6069e9aee70b9f65f0b082900ca2 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Unbound Recursive DNS Resolver Configuration
-LUCI_DEPENDS:=+luci-compat +unbound-daemon
+LUCI_DEPENDS:=+luci-base +luci-compat +unbound-daemon
 
 include ../../luci.mk
 
index 84a4d485765865c11769ddedf3b4b38e1d13d65d..15da0fd1873be190b8077eef565a2c2e0e26ef64 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Universal Plug & Play configuration module
-LUCI_DEPENDS:=+miniupnpd +rpcd-mod-ucode
+LUCI_DEPENDS:=+luci-base +miniupnpd +rpcd-mod-ucode
 
 include ../../luci.mk
 
index c2e930632e1d0822a660332c612e5b5b33aa99a3..606a0853c8904314b9ed3525b2bdf1f9ac2f2f34 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for VnStat
-LUCI_DEPENDS:=+luci-compat +vnstat +vnstati
+LUCI_DEPENDS:=+luci-base +luci-compat +vnstat +vnstati
 
 include ../../luci.mk
 
index 420bf548a407eeda23334cf4bb04ec0134335998..e611a98a27f77ffded1f73359638d327ab4cf8b4 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for vnStat 2
-LUCI_DEPENDS:=+luci-lib-jsonc +vnstat2 +vnstati2
+LUCI_DEPENDS:=+luci-base +luci-lib-jsonc +vnstat2 +vnstati2
 
 PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Jan Hoffmann <jan@3e8.eu>
index c3c7aada9d9d6e7d8cac4a23e3c4d64bf594cc06..7d45ec1436ce9fecfd350ade2ecb03198881ed8d 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for Watchcat
-LUCI_DEPENDS:=+watchcat
+LUCI_DEPENDS:=+luci-base +watchcat
 
 include ../../luci.mk
 
index 891b41bf5a5068d68b9a25f7979e765da5f2d9c0..e6d5c5fbe239651bf2b2fdfecf95227fe977e608 100644 (file)
@@ -15,7 +15,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Turns WiFi on and off according to a schedule
-LUCI_DEPENDS:=+luci-compat +wifischedule
+LUCI_DEPENDS:=+luci-base +luci-compat +wifischedule
 
 include ../../luci.mk
 
index d935ee90303b30a049d58dd279be1a636e293a08..f7466c0175325f92c98609883dd92e12337e7f8e 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for Wake-on-LAN
-LUCI_DEPENDS:=+etherwake
+LUCI_DEPENDS:=+luci-base +etherwake
 
 include ../../luci.mk
 
index 1a8959838827f5df1eff51f666ef2702fe825d47..f7237eb064de3ba60c49012eb5e349a9335610dc 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for xfrpc
-LUCI_DEPENDS:=+xfrpc
+LUCI_DEPENDS:=+luci-base +xfrpc
 
 PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Dengfeng Liu <liu_df@qq.com>
index beed1bccbfab3d6b894c5a94f5021b4056fb36b7..db518755a1750a7e757a3f1dfb37cf7346dc6956 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI Support for xinetd
-LUCI_DEPENDS:=+xinetd
+LUCI_DEPENDS:=+luci-base +xinetd
 LUCI_PKGARCH:=all
 
 PKG_MAINTAINER:=Helge Mader <ma@dev.tdt.de>
index 747d8c3d67f75e5f5e9d578b72f6e0a6a69af531..4ce191921b95b6ad90ca38af80715bbe3a42a486 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for Yggdrasil
-LUCI_DEPENDS:=+yggdrasil
+LUCI_DEPENDS:=+luci-base +yggdrasil
 
 include ../../luci.mk