applications: replace +luci-mod-admin-full with +luci-base
authorSergey Ponomarev <stokito@gmail.com>
Sun, 24 Sep 2023 07:55:27 +0000 (10:55 +0300)
committerSergey Ponomarev <stokito@gmail.com>
Sun, 24 Sep 2023 08:10:06 +0000 (11:10 +0300)
The apps don't need for the admin full.

Signed-off-by: Sergey Ponomarev <stokito@gmail.com>
applications/luci-app-acme/Makefile
applications/luci-app-advanced-reboot/Makefile
applications/luci-app-bmx7/Makefile
applications/luci-app-clamav/Makefile
applications/luci-app-ddns/Makefile
applications/luci-app-lxc/Makefile
applications/luci-app-mosquitto/Makefile
applications/luci-app-privoxy/Makefile
applications/luci-app-radicale/Makefile
applications/luci-app-squid/Makefile

index 8f9bf8ec79b83a6077ae0a228787456081cb2efe..3853b4d7aceef7bc073d521017d852ee7a5f7575 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=ACME package - LuCI interface
-LUCI_DEPENDS:=+luci-mod-admin-full +acme
+LUCI_DEPENDS:=+luci-base +acme
 
 PKG_MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
 PKG_LICENSE:=GPL-3.0-or-later
index adee08a63ab456c681ff65dc176191d0e6445a1b..09190dfbf92cec00c1cda72f6659dfb5e34c5d04 100644 (file)
@@ -12,7 +12,7 @@ LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
 LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot supported Linksys and ZyXEL routers to\
        an alternative partition. Also provides Web UI to shut down (power off) your device.    Supported dual-partition\
        routers are listed at https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
-LUCI_DEPENDS:=+luci-mod-admin-full +jshn
+LUCI_DEPENDS:=+luci-base +jshn
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index 546aeb9159146565fbcfee51cf09cadc028ae9b5..48e6fc023ac6c266dcd88ab89d64e63990d22240 100644 (file)
@@ -4,7 +4,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for BMX7
-LUCI_DEPENDS:=+luci-compat +luci-lib-json +luci-mod-admin-full +bmx7 +bmx7-json
+LUCI_DEPENDS:=+luci-compat +luci-lib-json +luci-base +bmx7 +bmx7-json
 PKG_MAINTAINER:= Roger Pueyo <roger.pueyo@guifi.net> \
        Pau Escrich <p4u@dabax.net>
 PKG_LICENSE:=GPL-2.0-or-later
index 93df9edc90717f37b7e6a9ded2fca587471fd959..e8c72ce8fa1e18568fe1812184f4b992d92fce96 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=ClamAV LuCI interface
-LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full +clamav
+LUCI_DEPENDS:=+luci-compat +luci-base +clamav
 
 PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
 PKG_LICENSE:=Apache-2.0
index 2ebb0c8b82b8e053e0cd91cbcafebb42fa1c53b8..579843665c7521bc22805c234d484c7f31365a6a 100644 (file)
@@ -12,7 +12,7 @@ PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Ansuel Smith <ansuelsmth@gmail.com>
 
 LUCI_TITLE:=LuCI Support for Dynamic DNS Client (ddns-scripts)
-LUCI_DEPENDS:=+luci-mod-admin-full +luci-lua-runtime +ddns-scripts
+LUCI_DEPENDS:=+luci-base +luci-lua-runtime +ddns-scripts
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index 52f3f42df534c635ef46a8c3fb32216e4ef0945a..c976a1ee465ade9ae13bca4eb31a082672547d4e 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LXC management Web UI
-LUCI_DEPENDS:=@!arc +luci-compat +luci-mod-admin-full +lxc +lxc-attach +lxc-console +lxc-create +liblxc +rpcd-mod-lxc +getopt +!LXC_BUSYBOX_OPTIONS:tar
+LUCI_DEPENDS:=@!arc +luci-compat +luci-base +lxc +lxc-attach +lxc-console +lxc-create +liblxc +rpcd-mod-lxc +getopt +!LXC_BUSYBOX_OPTIONS:tar
 LUCI_PKGARCH:=all
 
 define Package/luci-app-lxc/conffiles
index 7713bcf8ecdb5465a8a4b2720c3340f15ec4cb40..1a659caeeecfddd63351a3ee850fd89bec7896c2 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Mosquitto LuCI interface
-LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full mosquitto
+LUCI_DEPENDS:=+luci-compat +luci-base mosquitto
 LUCI_PKGARCH:=all
 LUCI_DESCRIPTION:=Provides a webadmin for most basic mosquitto parameters.
 
index f558603795cc38473b60708fe724c1cdf93268a3..3a9aa489630c2cafa68417a91a8520646be70b4e 100644 (file)
@@ -21,7 +21,7 @@ PKG_MAINTAINER:=
 
 # LuCI specific settings
 LUCI_TITLE:=LuCI Support for Privoxy WEB proxy
-LUCI_DEPENDS:=+luci-compat +luci-lib-ipkg +luci-mod-admin-full +privoxy
+LUCI_DEPENDS:=+luci-compat +luci-lib-ipkg +luci-base +privoxy
 LUCI_PKGARCH:=all
 
 define Package/$(PKG_NAME)/config
index b70683674e54711076be4fe9c6f5b7de6e8f9c04..7002cdb8fd3347af00d4fddea21a0be0fc26dd06 100644 (file)
@@ -21,7 +21,7 @@ PKG_MAINTAINER:=
 
 # LuCI specific settings
 LUCI_TITLE:=LuCI Support for Radicale CardDAV/CalDAV
-LUCI_DEPENDS:=+luci-compat +luci-lib-ipkg +luci-mod-admin-full
+LUCI_DEPENDS:=+luci-compat +luci-lib-ipkg +luci-base
 LUCI_PKGARCH:=all
 
 define Package/$(PKG_NAME)/config
index b16bd5d752e96a438033b762ccdb2b1bb6bc7806..4c89c4a610a76f6627d382d1a9fc24da31b2b759 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Squid LuCI Interface
-LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full +squid
+LUCI_DEPENDS:=+luci-compat +luci-base +squid
 
 PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
 PKG_LICENSE:=Apache-2.0