packages: move gconf2 away to /feeds/xorg/lib/
authorNicolas Thill <nico@openwrt.org>
Thu, 17 Nov 2011 08:59:55 +0000 (08:59 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 17 Nov 2011 08:59:55 +0000 (08:59 +0000)
SVN-Revision: 29205

xorg/lib/gconf2/Makefile [new file with mode: 0644]
xorg/lib/gconf2/patches/010-do-not-use-GTK_DOC-macro.patch [new file with mode: 0644]
xorg/lib/gconf2/patches/020-do-not-build-examples_docs_pos_tests.patch [new file with mode: 0644]

diff --git a/xorg/lib/gconf2/Makefile b/xorg/lib/gconf2/Makefile
new file mode 100644 (file)
index 0000000..86b764d
--- /dev/null
@@ -0,0 +1,109 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gconf2
+PKG_VERSION:=2.24.0
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/GConf-$(PKG_VERSION)
+PKG_SOURCE:=GConf-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNOME/GConf/2.24
+PKG_MD5SUM:=4971d96f5ba94fe4a69396267bd5afe8
+
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+PKG_BUILD_DEPENDS:=orbit2/host intltool/host
+
+PKG_INSTALL=1
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/libgconf2
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=GConf2 library
+  URL:=http://www.gnome.org/projects/gconf/
+  DEPENDS:=+orbit2 +glib2 +dbus +libdbus-glib +libxml2
+endef
+
+define Package/libgconf2/description
+GConf is a configuration database system for storing application preferences.
+endef
+
+define Package/gconf2
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=GConf2 command line utils
+  URL:=http://www.gnome.org/projects/gconf/
+  DEPENDS:=+libgconf2
+endef
+
+define Package/gconf2/description
+GConf is a configuration database system for storing application preferences.
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+           --disable-gtk \
+       )
+       find $(PKG_BUILD_DIR) -name Makefile -exec sed -i 's,ORBIT_IDL.*orbit-idl-2,ORBIT_IDL = $(STAGING_DIR_HOST)/bin/orbit-idl-2,g' {} \; # tell gconf2 to use the host-built idl-compiler
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{include/gconf/2/gconf,lib/pkgconfig,share/aclocal}
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/gconf/2/gconf/* \
+               $(1)/usr/include/gconf/2/gconf/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libgconf-2.{so*,la,a} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/aclocal/* \
+               $(1)/usr/share/aclocal/
+endef
+
+define Package/libgconf2/install
+       $(INSTALL_DIR) $(1)/etc/gconf
+       $(CP) \
+               $(PKG_INSTALL_DIR)/etc/gconf/* \
+               $(1)/etc/gconf/
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libgconf-2.so* \
+               $(1)/usr/lib/
+
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/lib/gconfd-2 \
+               $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/usr/lib/GConf/2
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/GConf/2/libgconfbackend-xml.so \
+               $(1)/usr/lib/GConf/2/
+
+       $(INSTALL_DIR) $(1)/usr/share/dbus-1/services
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/dbus-1/services/* \
+               $(1)/usr/share/dbus-1/services/
+endef
+
+define Package/gconf2/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/* \
+               $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,libgconf2))
+$(eval $(call BuildPackage,gconf2))
diff --git a/xorg/lib/gconf2/patches/010-do-not-use-GTK_DOC-macro.patch b/xorg/lib/gconf2/patches/010-do-not-use-GTK_DOC-macro.patch
new file mode 100644 (file)
index 0000000..170524c
--- /dev/null
@@ -0,0 +1,11 @@
+--- GConf-2.24.0.orig/configure.in     2008-09-22 19:51:00.000000000 +0200
++++ GConf-2.24.0/configure.in  2010-12-10 15:50:41.515380606 +0100
+@@ -127,7 +127,7 @@
+   fi
+ fi
+-GTK_DOC_CHECK([1.0])
++#GTK_DOC_CHECK([1.0])
+ AC_ARG_ENABLE(gtk, [  --enable-gtk          Enable GTK+ support (for gconf-sanity-check) [default=auto]], enable_gtk="$enableval", enable_gtk=auto)
diff --git a/xorg/lib/gconf2/patches/020-do-not-build-examples_docs_pos_tests.patch b/xorg/lib/gconf2/patches/020-do-not-build-examples_docs_pos_tests.patch
new file mode 100644 (file)
index 0000000..70cc993
--- /dev/null
@@ -0,0 +1,23 @@
+--- GConf-2.24.0.orig/Makefile.in      2008-09-22 20:03:56.000000000 +0200
++++ GConf-2.24.0/Makefile.in   2010-12-10 13:52:16.027379891 +0100
+@@ -267,8 +267,8 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = gconf backends po doc examples $(am__append_1)
+-DIST_SUBDIRS = tests $(SUBDIRS) 
++SUBDIRS = gconf backends $(am__append_1)
++DIST_SUBDIRS = $(SUBDIRS) 
+ EXTRA_DIST = \
+       TODO                \
+       gtk-doc.make        \
+diff -ruN GConf-2.24.0.orig//Makefile.am GConf-2.24.0//Makefile.am
+--- GConf-2.24.0.orig//Makefile.am     2008-08-19 11:41:58.000000000 +0200
++++ GConf-2.24.0//Makefile.am  2010-12-10 18:49:14.591378059 +0100
+@@ -1,5 +1,5 @@
+-SUBDIRS = gconf backends po doc examples 
++SUBDIRS = gconf backends
+ if ENABLE_DEFAULTS_SERVICE
+ SUBDIRS += defaults