prereq-build: g++ formatting and consistency fixes
authorKarl Palsson <karlp@tweak.net.au>
Mon, 17 May 2021 00:38:03 +0000 (00:38 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 May 2021 13:11:38 +0000 (15:11 +0200)
Remove \n that mangles output, and fix inconsistent version name check.

Example before:

Build dependency: Please install the GNU C++ Compiler (g++) 6 or later
Build dependency: \nPlease reinstall the GNU C++ Compiler (4.8 or later) - it appears to be broken
Build dependency: Please install ncurses. (Missing libncurses.so or ncurses.h)

Signed-off-by: Karl Palsson <karlp@tweak.net.au>
include/prereq-build.mk

index 8adf0d03dd4f4637ceaa9d299c487908063b69d0..639d1ad0face54f6075475f441858bd10cff6d82 100644 (file)
@@ -31,7 +31,7 @@ $(eval $(call SetupHostCommand,gcc, \
        gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
-       \nPlease reinstall the GNU C Compiler (6 or later) - \
+       Please reinstall the GNU C Compiler (6 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -))
@@ -43,7 +43,7 @@ $(eval $(call SetupHostCommand,g++, \
        g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \
-       \nPlease reinstall the GNU C++ Compiler (4.8 or later) - \
+       Please reinstall the GNU C++ Compiler (6 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \