dropbear: Make utmp and putuline support configurable via seperate config options
authorLuka Perkov <luka@openwrt.org>
Tue, 10 May 2016 22:36:38 +0000 (22:36 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 10 May 2016 22:36:38 +0000 (22:36 +0000)
Utmp support tracks who is currenlty logged in by logging info to the file /var/run/utmp (supported by busybox)
Putuline support will use the utmp structure to write to the utmp file

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
SVN-Revision: 49333

package/network/services/dropbear/Config.in
package/network/services/dropbear/Makefile

index 3316c84e9e5f8d70a5aae11da22bac975e30b2c8..7c2edd79f23708f9ef01c6a62a54073b0c7a33ed 100644 (file)
@@ -32,4 +32,19 @@ config DROPBEAR_ECC
 
                Increases binary size by about 23 kB (MIPS).
 
+config DROPBEAR_UTMP
+       bool "Utmp support"
+       default n
+       depends on BUSYBOX_CONFIG_FEATURE_UTMP
+       help
+               This enables dropbear utmp support, the file /var/run/utmp is used to
+               track who is currently logged in.
+
+config DROPBEAR_PUTUTLINE
+       bool "Pututline support"
+       default n
+       depends on DROPBEAR_UTMP
+       help
+               Dropbear will use pututline() to write the utmp structure into the utmp file.
+
 endmenu
index f48c2b5b2cef65a7ff3eeac5fcbaeed2d8278f6a..8d4e7bc7fa45715b8c64977edb24148c4e198e55 100644 (file)
@@ -68,12 +68,11 @@ CONFIGURE_ARGS += \
        --enable-syslog \
        $(if $(CONFIG_SHADOW_PASSWORDS),,--disable-shadow) \
        --disable-lastlog \
-       --disable-utmp \
-       --disable-utmpx \
+       $(if $(CONFIG_DROPBEAR_UTMP),,--disable-utmp) \
        --disable-wtmp \
        --disable-wtmpx \
        --disable-loginfunc \
-       --disable-pututline \
+       $(if $(CONFIG_DROPBEAR_PUTUTLINE),,--disable-pututline) \
        --disable-pututxline \
        --disable-zlib \
        --enable-bundled-libtom