libxfce4util: fix compilation, use official download source
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 9 Mar 2011 14:59:36 +0000 (14:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 9 Mar 2011 14:59:36 +0000 (14:59 +0000)
SVN-Revision: 25976

xfce/libs/libxfce4util/Makefile

index d5e90c9d17337f7e6777bb2b110c21e382aaa4e1..ae8a925eb5d1186b8d4991b6f03c3e492c2e1149 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,10 +12,10 @@ PKG_VERSION:=4.6.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.tx-us.xfce.org/archive/xfce-$(PKG_VERSION)/src/
+PKG_SOURCE_URL:=http://archive.xfce.org/src/xfce/libxfce4util/4.6
 PKG_MD5SUM:=eac51d58179cbcadc3f802450a8ec9cd
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -29,11 +29,8 @@ define Package/libxfce4util
   DEPENDS:=+glib2
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-broken-putenv=no \
-       )
-endef
+CONFIGURE_ARGS += --with-broken-putenv=no
+MAKE_FLAGS += GTKDOC_REBASE=true
 
 define Build/InstallDev
        $(INSTALL_DIR)  $(1)/usr/{lib/pkgconfig,include/xfce4/libxfce4util}