kernel: crypto: drop kmod-crypto-pcompress
authorAleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>
Sun, 2 May 2021 09:27:23 +0000 (11:27 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 May 2021 13:11:38 +0000 (15:11 +0200)
CONFIG_CRYPTO_PCOMP and CONFIG_CRYPTO_PCOMP2 have been removed in upstream commit[1].
This symbol doesn't exist since kernel 4.6 and this package is empty.

1. [ crypto: compress - remove unused pcomp interface ]
(https://github.com/torvalds/linux/commit/110492183c4b8f572b16fce096b9d78e2da30baf)

Signed-off-by: Aleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>
package/kernel/linux/modules/crypto.mk

index edce712c565ef32006a8957da6ef5633064a6bb3..f07676d6b77b222ee532779bcdc98250c25a2278 100644 (file)
@@ -600,7 +600,7 @@ $(eval $(call KernelPackage,crypto-lib-poly1305))
 
 define KernelPackage/crypto-manager
   TITLE:=CryptoAPI algorithm manager
-  DEPENDS:=+kmod-crypto-aead +kmod-crypto-hash +kmod-crypto-pcompress
+  DEPENDS:=+kmod-crypto-aead +kmod-crypto-hash
   KCONFIG:= \
        CONFIG_CRYPTO_MANAGER \
        CONFIG_CRYPTO_MANAGER2
@@ -770,19 +770,6 @@ endef
 $(eval $(call KernelPackage,crypto-pcbc))
 
 
-define KernelPackage/crypto-pcompress
-  TITLE:=CryptoAPI Partial (de)compression operations
-  KCONFIG:= \
-       CONFIG_CRYPTO_PCOMP=y \
-       CONFIG_CRYPTO_PCOMP2
-  FILES:=$(LINUX_DIR)/crypto/pcompress.ko
-  AUTOLOAD:=$(call AutoLoad,09,pcompress)
-  $(call AddDepends/crypto)
-endef
-
-$(eval $(call KernelPackage,crypto-pcompress))
-
-
 define KernelPackage/crypto-rsa
   TITLE:=RSA algorithm
   DEPENDS:=+kmod-crypto-manager +kmod-asn1-decoder