armsr: remove redundant phy-marvell-10g module
authorDaniel Golle <daniel@makrotopia.org>
Fri, 11 Aug 2023 13:16:08 +0000 (14:16 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 13 Aug 2023 14:01:36 +0000 (15:01 +0100)
the Marvell 10G PHY driver is no way specific to ARM SystemReady
systems, it frequently occurs on SFP+ copper modules and is useful on
many targets.

Hence it been added to package/kernel/linux/modules/netdevices and we
can remove the now redundant target-specific module.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/armsr/modules.mk

index 7a349337d8aef6c4a69889a3453e922eca0a8996..2bd5748e90e82f4b3f875334037591d12025b0e8 100644 (file)
@@ -151,17 +151,6 @@ endef
 
 $(eval $(call KernelPackage,marvell-mdio))
 
-define KernelPackage/phy-marvell-10g
-  SUBMENU:=$(NETWORK_DEVICES_MENU)
-  TITLE:=Marvell Alaska 10G PHY driver
-  DEPENDS:=@(TARGET_armsr_armv8) +kmod-libphy
-  KCONFIG:=CONFIG_MARVELL_10G_PHY
-  FILES=$(LINUX_DIR)/drivers/net/phy/marvell10g.ko
-  AUTOLOAD=$(call AutoLoad,35,marvell10g)
-endef
-
-$(eval $(call KernelPackage,phy-marvell-10g))
-
 define KernelPackage/mvneta
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Marvell Armada 370/38x/XP/37xx network driver