mpc85xx: p1010: change wrapper address of simple image devices
authorPawel Dembicki <paweldembicki@gmail.com>
Mon, 19 Feb 2024 12:39:10 +0000 (13:39 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 8 Mar 2024 16:24:13 +0000 (17:24 +0100)
Kernel and initramfs size grows. Now uncompressed initramfs image and
regular kernel image overlaps configured area:

Initramfs:
  WRAP    arch/powerpc/boot/simpleImage.br200-wp
INFO: Uncompressed kernel (size 0x1428688) overlaps the address of the
wrapper(0x1000000)
INFO: Fixing the link_address of wrapper to (0x1500000)
  WRAP    arch/powerpc/boot/simpleImage.tl-wdr4900-v1
INFO: Uncompressed kernel (size 0x1428688) overlaps the address of the
wrapper(0x1000000)
INFO: Fixing the link_address of wrapper to (0x1500000)
  WRAP    arch/powerpc/boot/simpleImage.ws-ap3715i
INFO: Uncompressed kernel (size 0x1428688) overlaps the address of the
wrapper(0x1000000)
INFO: Fixing the link_address of wrapper to (0x1500000)

Regular image:
  WRAP    arch/powerpc/boot/simpleImage.br200-wp
INFO: Uncompressed kernel (size 0x10e0688) overlaps the address of the
wrapper(0x1000000)
INFO: Fixing the link_address of wrapper to (0x1100000)
  WRAP    arch/powerpc/boot/simpleImage.tl-wdr4900-v1
INFO: Uncompressed kernel (size 0x10e0688) overlaps the address of the
wrapper(0x1000000)
INFO: Fixing the link_address of wrapper to (0x1100000)
  WRAP    arch/powerpc/boot/simpleImage.ws-ap3715i
INFO: Uncompressed kernel (size 0x10e0688) overlaps the address of the
wrapper(0x1000000)
INFO: Fixing the link_address of wrapper to (0x1100000)

Let's change wrapper address to safe value.

Tested on: TL-WDR4900, BR200-WP

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
target/linux/mpc85xx/image/p1010.mk
target/linux/mpc85xx/patches-5.15/100-powerpc-85xx-tl-wdr4900-v1-support.patch
target/linux/mpc85xx/patches-5.15/107-powerpc-85xx-add-ws-ap3825i-support.patch
target/linux/mpc85xx/patches-6.1/100-powerpc-85xx-tl-wdr4900-v1-support.patch
target/linux/mpc85xx/patches-6.1/107-powerpc-85xx-add-ws-ap3825i-support.patch

index c0de19f6c6fd45220254a72fc0bde3b3e6b6d21c..a4f2d13dd4e9241703a19be8310aa5dbfa8b233c 100644 (file)
@@ -21,8 +21,8 @@ define Device/aerohive_br200-wp
   KERNEL_NAME := simpleImage.br200-wp
   KERNEL := kernel-bin | uImage none
   KERNEL_INITRAMFS := kernel-bin | uImage none
-  KERNEL_ENTRY := 0x1000000
-  KERNEL_LOADADDR := 0x1000000
+  KERNEL_ENTRY := 0x1500000
+  KERNEL_LOADADDR := 0x1500000
   KERNEL_SIZE := 8m
   IMAGES := fdt.bin sysupgrade.bin
   IMAGE/fdt.bin := append-dtb
@@ -39,8 +39,8 @@ define Device/enterasys_ws-ap3715i
   DEVICE_MODEL := WS-AP3715i
   BLOCKSIZE := 64k
   KERNEL_NAME := simpleImage.ws-ap3715i
-  KERNEL_ENTRY := 0x1000000
-  KERNEL_LOADADDR := 0x1000000
+  KERNEL_ENTRY := 0x1500000
+  KERNEL_LOADADDR := 0x1500000
   KERNEL = kernel-bin | lzma | uImage lzma
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
@@ -60,8 +60,8 @@ define Device/tplink_tl-wdr4900-v1
   KERNEL_NAME := simpleImage.tl-wdr4900-v1
   KERNEL_INITRAMFS :=
   KERNEL := kernel-bin | uImage none -M 0x4f4b4c49 | spi-loader-okli $(1)
-  KERNEL_ENTRY := 0x1000000
-  KERNEL_LOADADDR := 0x1000000
+  KERNEL_ENTRY := 0x1500000
+  KERNEL_LOADADDR := 0x1500000
   SUPPORTED_DEVICES += tl-wdr4900-v1
   COMPILE := loader-$(1)
   COMPILE/loader-$(1) := spi-loader-okli-compile
index 0ecbec3ca413c2face85849ad1397db54577f029..fa27e9665d7492198aea201c4b4e28b7585b745a 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
      ;;
 +simpleboot-tl-wdr4900-v1)
 +    platformo="$object/fixed-head.o $object/simpleboot.o"
-+    link_address='0x1000000'
++    link_address='0x1500000'
 +    binary=y
 +    ;;
  simpleboot-*)
index bd731a23445026031d04febcbafcb2b4f96437fe..51da0f4527f4c76ca144b1e7cf61653cfec5a71c 100644 (file)
@@ -62,4 +62,4 @@ WS-AP3825i AP.
 +simpleboot-ws-ap3825i|\
  simpleboot-tl-wdr4900-v1)
      platformo="$object/fixed-head.o $object/simpleboot.o"
-     link_address='0x1000000'
+     link_address='0x1500000'
index 7b9016d2fee26148f5dcd256ccea8ea2421ca034..a7253a97946e6e46299fa9cb78749fd4727dad55 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
      ;;
 +simpleboot-tl-wdr4900-v1)
 +    platformo="$object/fixed-head.o $object/simpleboot.o"
-+    link_address='0x1000000'
++    link_address='0x1500000'
 +    binary=y
 +    ;;
  simpleboot-*)
index 0fa1b4172b8fb2765eff50c4dc39df7d9d30a943..fb697e1d1fbc68ca81485972805cdc8f6459d251 100644 (file)
@@ -62,4 +62,4 @@ WS-AP3825i AP.
 +simpleboot-ws-ap3825i|\
  simpleboot-tl-wdr4900-v1)
      platformo="$object/fixed-head.o $object/simpleboot.o"
-     link_address='0x1000000'
+     link_address='0x1500000'