rpcd: update to latest openwrt-18.06 Git HEAD
authorJo-Philipp Wich <jo@mein.io>
Tue, 26 May 2020 14:23:10 +0000 (16:23 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 26 May 2020 14:26:28 +0000 (16:26 +0200)
7be1f17 file: exec: properly free memory on error
313964c file: avoid closing stdio descriptors in rpc_file_exec_run
cd09c5f file: patch process stdin to /dev/null
efbcedb file: remove unused members from struct rpc_file_exec_context
71b00ab file: rpc_file_exec_run: fix potential memory leak and integer overflow
c7bb956 plugin: fix double free in finish callback
16de3fa plugin: do not free method name separately
29c9c11 exec: properly free memory on rpc_exec() error
5cd4f4e plugin: exec: properly free memory on parse error
d80f70e plugin: fix leaking invoked method name for exec plugins
53a0952 session: deny access if password login is disabled
662d034 uci: reset uci_ptr flags when merging options during section add
dd46d6d uci: free configs list memory on return
abbc302 uci: reset uci_ptr flags when merging set operations

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/system/rpcd/Makefile

index 04155e6f2229407f7b5480f0217d4123ae8fc084..70c2fe8cc77a7137031d6175c47435cdb0e4ca7d 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rpcd
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/rpcd.git
-PKG_SOURCE_DATE:=2018-11-28
-PKG_SOURCE_VERSION:=3aa81d0dfae167eccc26203bd0c96f3e3450f253
+PKG_SOURCE_DATE:=2020-05-26
+PKG_SOURCE_VERSION:=7be1f17138f19d1d7a86e0c27b3662d3643ff296
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-PKG_MIRROR_HASH:=1befc5e1793a687e7a37b4f4d611e5f95aef4b79ad4b288c4dcb4c74d212509b
+PKG_MIRROR_HASH:=b427b2be8ebd486edbc88f6e789d1890cbdda1b4f04dcfcc8751f568c3a82674
 
 PKG_LICENSE:=ISC
 PKG_LICENSE_FILES:=