netifd: fix IPv4 route target masking
authorJo-Philipp Wich <jo@mein.io>
Tue, 14 Nov 2023 13:38:11 +0000 (14:38 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 14 Nov 2023 13:38:11 +0000 (14:38 +0100)
A previous commit supposed to mask out excess host bits in route targets
failed to correctly calculate the mask value, causing it to produce
improper results for certain mask lengths.

Fixes: https://github.com/openwrt/netifd/issues/17
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/config/netifd/Makefile
package/network/config/netifd/patches/0001-interface-ip-fix-IPv4-route-target-masking.patch [new file with mode: 0644]

index 826889aca6c2e3e56d81b0e514c3604cb2f7b346..d237ed181f4fff5da7b225e41411e8369108116e 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
diff --git a/package/network/config/netifd/patches/0001-interface-ip-fix-IPv4-route-target-masking.patch b/package/network/config/netifd/patches/0001-interface-ip-fix-IPv4-route-target-masking.patch
new file mode 100644 (file)
index 0000000..dd9374a
--- /dev/null
@@ -0,0 +1,32 @@
+From 8587c074f1eb2064c42adb0a6aa5073f695ab89d Mon Sep 17 00:00:00 2001
+From: Jo-Philipp Wich <jo@mein.io>
+Date: Tue, 14 Nov 2023 14:01:44 +0100
+Subject: [PATCH] interface-ip: fix IPv4 route target masking
+
+A previous commit supposed to mask out excess host bits in route targets
+failed to correctly calculate the mask value, causing it to produce
+improper results for certain mask lengths.
+
+Fixes: #17
+Fixes: 76eb342 ("interface-ip: mask out host bits in IPv4 route targets")
+Signed-off-by: Jo-Philipp Wich <jo@mein.io>
+---
+ interface-ip.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/interface-ip.c b/interface-ip.c
+index d2fe385..28e7106 100644
+--- a/interface-ip.c
++++ b/interface-ip.c
+@@ -448,7 +448,7 @@ interface_ip_add_route(struct interface *iface, struct blob_attr *attr, bool v6)
+               /* Mask out IPv4 host bits to avoid "Invalid prefix for given prefix length" */
+               if (af == AF_INET && route->mask < 32)
+-                      route->addr.in.s_addr &= ((1u << route->mask) - 1);
++                      clear_if_addr(&route->addr, route->mask);
+       }
+       if ((cur = tb[ROUTE_GATEWAY]) != NULL) {
+-- 
+2.39.1
+