kernel: bump 4.14 to 4.14.259
authorPetr Štetiar <ynezz@true.cz>
Thu, 23 Dec 2021 10:37:55 +0000 (11:37 +0100)
committerPetr Štetiar <ynezz@true.cz>
Wed, 29 Dec 2021 07:52:36 +0000 (08:52 +0100)
All patches refreshed automagically without conflicts, but upstream in
commit 48c2461f28fe ("ARM: 8800/1: use choice for kernel unwinders")
added new config options UNWINDER_ARM and UNWINDER_FRAME_POINTER so we
need to adjust default configs as well.

Run tested on ipq40xx/glinet-b1300 and mvebu/turris-omnia.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
47 files changed:
include/kernel-version.mk
target/linux/armvirt/config-4.14
target/linux/at91/config-4.14
target/linux/bcm53xx/config-4.14
target/linux/brcm2708/bcm2708/config-4.14
target/linux/brcm2708/bcm2709/config-4.14
target/linux/brcm2708/bcm2710/config-4.14
target/linux/brcm2708/patches-4.14/950-0170-lan78xx-Avoid-spurious-kevent-4-error.patch
target/linux/brcm2708/patches-4.14/950-0251-lan78xx-Read-initial-EEE-status-from-DT.patch
target/linux/brcm2708/patches-4.14/950-0252-lan78xx-Change-LEDs-to-include-10Mb-activity.patch
target/linux/brcm2708/patches-4.14/950-0257-lan78xx-Read-LED-states-from-Device-Tree.patch
target/linux/brcm2708/patches-4.14/950-0265-net-lan78xx-Allow-for-VLAN-headers-in-timeout.patch
target/linux/brcm2708/patches-4.14/950-0268-lan78xx-Move-enabling-of-EEE-into-PHY-init-code.patch
target/linux/brcm2708/patches-4.14/950-0269-net-lan78xx-Request-s-w-csum-check-on-VLAN-tagged-pa.patch
target/linux/brcm2708/patches-4.14/950-0270-net-lan78xx-Add-support-for-VLAN-filtering.patch
target/linux/brcm2708/patches-4.14/950-0271-net-lan78xx-Add-support-for-VLAN-tag-stripping.patch
target/linux/brcm2708/patches-4.14/950-0272-net-lan78xx-Reduce-s-w-csum-check-on-VLANs.patch
target/linux/brcm2708/patches-4.14/950-0314-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch
target/linux/brcm2708/patches-4.14/950-0359-net-lan78xx-fix-rx-handling-before-first-packet-is-s.patch
target/linux/brcm2708/patches-4.14/950-0360-lan78xx-Fix-link-status-notifications.patch
target/linux/brcm2708/patches-4.14/950-0443-net-lan78xx-Support-auto-downshift-to-100Mb-s.patch
target/linux/brcm2708/patches-4.14/950-0454-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
target/linux/brcm2708/patches-4.14/961-lan78xx-enable-LED.patch
target/linux/cns3xxx/config-4.14
target/linux/gemini/config-4.14
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/config-4.14
target/linux/imx6/config-4.14
target/linux/ipq40xx/config-4.14
target/linux/ipq806x/config-4.14
target/linux/kirkwood/config-4.14
target/linux/layerscape/armv7/config-4.14
target/linux/layerscape/armv8_64b/config-4.14
target/linux/mediatek/mt7622/config-4.14
target/linux/mediatek/mt7623/config-4.14
target/linux/mvebu/config-4.14
target/linux/mvebu/cortexa53/config-default
target/linux/mvebu/cortexa72/config-default
target/linux/mxs/config-4.14
target/linux/octeontx/config-4.14
target/linux/omap/config-4.14
target/linux/oxnas/config-4.14
target/linux/samsung/s5pv210/config-4.14
target/linux/sunxi/config-4.14
target/linux/sunxi/cortexa53/config-4.14
target/linux/tegra/config-4.14
target/linux/zynq/config-4.14

index 5a663742036eef3c133474dda927702bb2eb66a8..0151a7d14193c009525f147b430dd5c62753358e 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .258
+LINUX_VERSION-4.14 = .259
 
-LINUX_KERNEL_HASH-4.14.258 = 71af29d042e4ce6cf0f8cdb5ce2fc4790cca642ee4a80ae6bb71a2092afc4b98
+LINUX_KERNEL_HASH-4.14.259 = 26e284541ff77bd3af14e40aa690bcf229d0f9b9677704fd9fecb59e108e4368
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index b46e89b4ee3ce96dcf1cd29616779a5b23c61595..a1fda0f28d7c2f619ab5772c96ce8aa46c0088a9 100644 (file)
@@ -169,6 +169,7 @@ CONFIG_SRCU=y
 CONFIG_SWIOTLB=y
 CONFIG_TICK_CPU_ACCOUNTING=y
 CONFIG_TREE_RCU=y
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB_SUPPORT=y
 CONFIG_VIRTIO=y
 CONFIG_VIRTIO_BALLOON=y
index b1b49054ab7cacd2e4ce3b6cce31846673c4e9e7..d849491cca82f53f722d66296a167a07008e0386 100644 (file)
@@ -520,6 +520,7 @@ CONFIG_UBIFS_FS_ADVANCED_COMPR=y
 CONFIG_UBIFS_FS_LZO=y
 CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_ACM=y
 CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
index 12da0eec9f21281a837e0a4cd4c4359615bbb372..377eb8e72b2d29d853eaf9fdd2a49a1f0aaa6ef6 100644 (file)
@@ -349,6 +349,7 @@ CONFIG_UBIFS_FS=y
 CONFIG_UBIFS_FS_LZO=y
 CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB_SUPPORT=y
 CONFIG_USE_OF=y
 CONFIG_VECTORS_BASE=0xffff0000
index 284d7cfa4b26cc261bd19cc8c2ba895175a60611..671caa6dfc926082b0e70d5e5ce1ba58454731c0 100644 (file)
@@ -390,6 +390,7 @@ CONFIG_TMPFS_POSIX_ACL=y
 CONFIG_UEVENT_HELPER_PATH=""
 # CONFIG_UID16 is not set
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
 CONFIG_USB_COMMON=y
index 9817656a60e93a9378a090bb861ef2163ea36be3..73fd185ef30d97a3ef2eb0f96b775d2e2ce16a4d 100644 (file)
@@ -432,6 +432,7 @@ CONFIG_TREE_SRCU=y
 CONFIG_UEVENT_HELPER_PATH=""
 # CONFIG_UID16 is not set
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
 CONFIG_USB_COMMON=y
index d7170c7875e8a9e08541832ba93129db277d86ad..ab9e759d10bbe1f4b365ef8c54ca3f3152fa57e7 100644 (file)
@@ -454,6 +454,7 @@ CONFIG_TREE_RCU=y
 CONFIG_TREE_SRCU=y
 CONFIG_UEVENT_HELPER_PATH=""
 CONFIG_UNMAP_KERNEL_AT_EL0=y
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB=y
 CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
 CONFIG_USB_COMMON=y
index e9b4d3855d55260cdc9f5c446d1954bf8a1a8a56..8ad6c069dd602d473e09709877f7cca3157dc496 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2504,7 +2504,7 @@ static void lan78xx_init_stats(struct la
+@@ -2502,7 +2502,7 @@ static void lan78xx_init_stats(struct la
        dev->stats.rollover_max.eee_tx_lpi_transitions = 0xFFFFFFFF;
        dev->stats.rollover_max.eee_tx_lpi_time = 0xFFFFFFFF;
  
index 7b7c04f11c461f994bc875eed1564b9e36780d01..c10286401aa95f8ee53fc048c6e5e93b6e607660 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2520,6 +2520,22 @@ static int lan78xx_open(struct net_devic
+@@ -2518,6 +2518,22 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index 47c20a7f132e59e56f6d53e9aedf98f711ce47f4..ef87555112cca6d9b29ee78b6e9976a8345cdedb 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2004,6 +2004,7 @@ static int lan78xx_phy_init(struct lan78
+@@ -2002,6 +2002,7 @@ static int lan78xx_phy_init(struct lan78
  {
        int ret;
        u32 mii_adv;
@@ -22,7 +22,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        struct phy_device *phydev = dev->net->phydev;
  
        phydev = phy_find_first(dev->mdiobus);
-@@ -2076,6 +2077,19 @@ static int lan78xx_phy_init(struct lan78
+@@ -2074,6 +2075,19 @@ static int lan78xx_phy_init(struct lan78
        mii_adv = (u32)mii_advertise_flowctrl(dev->fc_request_control);
        phydev->advertising |= mii_adv_to_ethtool_adv_t(mii_adv);
  
index d9de18f40122de5ab0eb1df2ad6565e840b65404..8143e0efe99eb2a1c015f96c7efc7a02a209bbb6 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2004,7 +2004,9 @@ static int lan78xx_phy_init(struct lan78
+@@ -2002,7 +2002,9 @@ static int lan78xx_phy_init(struct lan78
  {
        int ret;
        u32 mii_adv;
@@ -30,7 +30,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        struct phy_device *phydev = dev->net->phydev;
  
        phydev = phy_find_first(dev->mdiobus);
-@@ -2077,18 +2079,27 @@ static int lan78xx_phy_init(struct lan78
+@@ -2075,18 +2077,27 @@ static int lan78xx_phy_init(struct lan78
        mii_adv = (u32)mii_advertise_flowctrl(dev->fc_request_control);
        phydev->advertising |= mii_adv_to_ethtool_adv_t(mii_adv);
  
index fa4dbcd35e6bb8d3806089357a778112dcd7e190..3e46e64385c4f701fedefa4c4643e28df7d0f0bf 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2200,7 +2200,7 @@ static int lan78xx_change_mtu(struct net
+@@ -2198,7 +2198,7 @@ static int lan78xx_change_mtu(struct net
        if ((ll_mtu % dev->maxpacket) == 0)
                return -EDOM;
  
@@ -26,7 +26,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  
        netdev->mtu = new_mtu;
  
-@@ -2493,7 +2493,8 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2491,7 +2491,8 @@ static int lan78xx_reset(struct lan78xx_
        buf |= FCT_TX_CTL_EN_;
        ret = lan78xx_write_reg(dev, FCT_TX_CTL, buf);
  
index 1d334d009142e8b79a4a25e12805ea6337c65cd3..a90f25326ca429a7f1a3718eaeeac425c92964ca 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2079,6 +2079,22 @@ static int lan78xx_phy_init(struct lan78
+@@ -2077,6 +2077,22 @@ static int lan78xx_phy_init(struct lan78
        mii_adv = (u32)mii_advertise_flowctrl(dev->fc_request_control);
        phydev->advertising |= mii_adv_to_ethtool_adv_t(mii_adv);
  
@@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        /* Set LED modes:
         * led: 0=link/activity          1=link1000/activity
         *      2=link100/activity       3=link10/activity
-@@ -2546,22 +2562,6 @@ static int lan78xx_open(struct net_devic
+@@ -2544,22 +2560,6 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index 206bd2588d4a200b57157ae42e872b372f93569f..ab9e09ed4e57b61c9a8662e04e31563a69abbf9e 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2898,8 +2898,12 @@ static void lan78xx_rx_csum_offload(stru
+@@ -2896,8 +2896,12 @@ static void lan78xx_rx_csum_offload(stru
                                    struct sk_buff *skb,
                                    u32 rx_cmd_a, u32 rx_cmd_b)
  {
index c66a6cde5e715a3d1d3d5331767516cf2a82c2aa..fc25c5f3d2750fe25f99d6f4e3116da741efb409 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2285,7 +2285,7 @@ static int lan78xx_set_features(struct n
+@@ -2283,7 +2283,7 @@ static int lan78xx_set_features(struct n
                pdata->rfe_ctl &= ~(RFE_CTL_ICMP_COE_ | RFE_CTL_IGMP_COE_);
        }
  
@@ -24,7 +24,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
                pdata->rfe_ctl |= RFE_CTL_VLAN_FILTER_;
        else
                pdata->rfe_ctl &= ~RFE_CTL_VLAN_FILTER_;
-@@ -2834,6 +2834,9 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2832,6 +2832,9 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_TSO_CSUM_ENABLE)
                dev->net->features |= NETIF_F_TSO | NETIF_F_TSO6 | NETIF_F_SG;
  
index ece8542c01ead99f5bae26d4db2fe4e1f7cd8b2c..518ff32d14607f921289fac7e44c04d10f2dd661 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  #define TX_OVERHEAD                   (8)
  #define RXW_PADDING                   2
  
-@@ -2285,6 +2286,11 @@ static int lan78xx_set_features(struct n
+@@ -2283,6 +2284,11 @@ static int lan78xx_set_features(struct n
                pdata->rfe_ctl &= ~(RFE_CTL_ICMP_COE_ | RFE_CTL_IGMP_COE_);
        }
  
@@ -36,7 +36,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
        if (features & NETIF_F_HW_VLAN_CTAG_FILTER)
                pdata->rfe_ctl |= RFE_CTL_VLAN_FILTER_;
        else
-@@ -2834,6 +2840,9 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2832,6 +2838,9 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_TSO_CSUM_ENABLE)
                dev->net->features |= NETIF_F_TSO | NETIF_F_TSO6 | NETIF_F_SG;
  
@@ -46,7 +46,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
        if (DEFAULT_VLAN_FILTER_ENABLE)
                dev->net->features |= NETIF_F_HW_VLAN_CTAG_FILTER;
  
-@@ -2914,6 +2923,16 @@ static void lan78xx_rx_csum_offload(stru
+@@ -2912,6 +2921,16 @@ static void lan78xx_rx_csum_offload(stru
        }
  }
  
@@ -63,7 +63,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static void lan78xx_skb_return(struct lan78xx_net *dev, struct sk_buff *skb)
  {
        int             status;
-@@ -2978,6 +2997,8 @@ static int lan78xx_rx(struct lan78xx_net
+@@ -2976,6 +2995,8 @@ static int lan78xx_rx(struct lan78xx_net
                        if (skb->len == size) {
                                lan78xx_rx_csum_offload(dev, skb,
                                                        rx_cmd_a, rx_cmd_b);
@@ -72,7 +72,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  
                                skb_trim(skb, skb->len - 4); /* remove fcs */
                                skb->truesize = size + sizeof(struct sk_buff);
-@@ -2996,6 +3017,7 @@ static int lan78xx_rx(struct lan78xx_net
+@@ -2994,6 +3015,7 @@ static int lan78xx_rx(struct lan78xx_net
                        skb_set_tail_pointer(skb2, size);
  
                        lan78xx_rx_csum_offload(dev, skb2, rx_cmd_a, rx_cmd_b);
index 7aa49a9b0389ddd52862d06795c4b6751133cd8e..0f68ebfda6468dd102070ff2514eb7e0d01ea59c 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2910,12 +2910,13 @@ static void lan78xx_rx_csum_offload(stru
+@@ -2908,12 +2908,13 @@ static void lan78xx_rx_csum_offload(stru
                                    struct sk_buff *skb,
                                    u32 rx_cmd_a, u32 rx_cmd_b)
  {
index c860f5bacb037c619a421e828df46d5722d8f1c6..bc2b6c2972b5f578cd434773adb877b6cf23b438 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -2837,8 +2846,14 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2835,8 +2844,14 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_RX_CSUM_ENABLE)
                dev->net->features |= NETIF_F_RXCSUM;
  
index d308f082148f37ae5fc392278da12fb3de8ebc96..4170ebabd7a729e21e4b65d53d450dc40a7321b0 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2595,6 +2595,8 @@ static int lan78xx_open(struct net_devic
+@@ -2593,6 +2593,8 @@ static int lan78xx_open(struct net_devic
  
        dev->link_on = false;
  
index 5a279cdebdd27516bbb97e3bc32b166b748c529c..d68873582be0bfe1b6097a95a500778fa6b80d02 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2595,8 +2595,6 @@ static int lan78xx_open(struct net_devic
+@@ -2593,8 +2593,6 @@ static int lan78xx_open(struct net_devic
  
        dev->link_on = false;
  
index 3bb25695738bd2f89c3187eba0421f15738768f7..b0e727f020ebfa2e2a2122fd574e9173d3fbb834 100644 (file)
@@ -85,7 +85,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  #include <linux/of_net.h>
  #include "lan78xx.h"
  
-@@ -1768,6 +1769,7 @@ done:
+@@ -1766,6 +1767,7 @@ done:
  
  static int lan78xx_mdio_init(struct lan78xx_net *dev)
  {
@@ -93,7 +93,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        int ret;
  
        dev->mdiobus = mdiobus_alloc();
-@@ -1797,7 +1799,9 @@ static int lan78xx_mdio_init(struct lan7
+@@ -1795,7 +1797,9 @@ static int lan78xx_mdio_init(struct lan7
                break;
        }
  
index c323ced943cbf64f51607f7bb34c9da8f9137ebd..6e03e4dedf46a91371505dd789f85072fdca4616 100644 (file)
@@ -28,7 +28,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3687,7 +3692,12 @@ static int lan78xx_probe(struct usb_inte
+@@ -3685,7 +3690,12 @@ static int lan78xx_probe(struct usb_inte
        netdev->max_mtu = MAX_SINGLE_PACKET_SIZE;
        netif_set_gso_max_size(netdev, MAX_SINGLE_PACKET_SIZE - MAX_HEADER);
  
index 2b9f91137bc71667eb410662e2b70eb295b35b36..1281c81c38080cc826de2e3292a6deb395a90de1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2468,6 +2468,15 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2466,6 +2466,15 @@ static int lan78xx_reset(struct lan78xx_
  
        ret = lan78xx_read_reg(dev, HW_CFG, &buf);
        buf |= HW_CFG_MEF_;
index 54f7576ea5c51cae41f4bcb69b0841c1df7b1ef1..76faf97bc11434e4a2e4369fd28284ca48e479b9 100644 (file)
@@ -354,6 +354,7 @@ CONFIG_TIMER_PROBE=y
 CONFIG_TREE_RCU=y
 CONFIG_TREE_SRCU=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB=y
 CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
 CONFIG_USB_CNS3XXX_EHCI=y
index fb96aa78c73afd8a77782a162a72e6ccc1be09d1..d92b947c00370a49b024580264b0dc11b488f540 100644 (file)
@@ -409,6 +409,7 @@ CONFIG_TMPFS_POSIX_ACL=y
 CONFIG_TREE_SRCU=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
 CONFIG_UNINLINE_SPIN_UNLOCK=y
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB_SUPPORT=y
 # CONFIG_USERIO is not set
 CONFIG_USER_NS=y
index 5a0fe0ad1b828f32fe162d75ffba29ab9af06fe4..d813aa42c99e12e6d62fe861846c43d6f7db14ce 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -2050,7 +2050,8 @@ static const struct usb_device_id option
+@@ -2058,7 +2058,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index de8dd8bb8ad05ec1992800b2c8abb2dec2492649..cbe2c09af91dcbb036bb71d42b6b1075d7f31012 100644 (file)
@@ -5173,6 +5173,8 @@ CONFIG_UNIX98_PTYS=y
 # CONFIG_UNIXWARE_DISKLABEL is not set
 # CONFIG_UNIX_DIAG is not set
 # CONFIG_UNUSED_SYMBOLS is not set
+# CONFIG_UNWINDER_ARM is not set
+# CONFIG_UNWINDER_FRAME_POINTER is not set
 # CONFIG_UPROBES is not set
 # CONFIG_UPROBE_EVENTS is not set
 # CONFIG_US5182D is not set
index 313f657a80f0c7a803a5768804acb6fc3028c571..ddbf21737637b57b53f44f7106b71b96e38ef132 100644 (file)
@@ -49,6 +49,7 @@ CONFIG_ARM_PATCH_IDIV=y
 CONFIG_ARM_PATCH_PHYS_VIRT=y
 CONFIG_ARM_THUMB=y
 # CONFIG_ARM_THUMBEE is not set
+CONFIG_ARM_UNWIND=y
 CONFIG_ARM_VIRT_EXT=y
 CONFIG_ASN1=y
 CONFIG_ASSOCIATIVE_ARRAY=y
@@ -193,7 +194,6 @@ CONFIG_F2FS_STAT_FS=y
 CONFIG_FEC=y
 CONFIG_FIXED_PHY=y
 CONFIG_FIX_EARLYCON_MEM=y
-CONFIG_FRAME_POINTER=y
 CONFIG_FSL_GUTS=y
 CONFIG_FS_ENCRYPTION=y
 CONFIG_FS_MBCACHE=y
@@ -494,6 +494,7 @@ CONFIG_UBIFS_FS_ADVANCED_COMPR=y
 CONFIG_UBIFS_FS_LZO=y
 CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_CHIPIDEA=y
 CONFIG_USB_CHIPIDEA_HOST=y
index c72e69320622fa1196b25777b2ac6e409e954fca..720b7bf431a40bc798e80400e52dd87706a7ee05 100644 (file)
@@ -465,6 +465,7 @@ CONFIG_UBIFS_FS_LZO=y
 CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UEVENT_HELPER_PATH=""
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
 # CONFIG_USB_EHCI_HCD is not set
index 38f5c94507c71a09809683fadd9f3df89b5318fb..40fa5dd2b14acb3ad17c797e08e7d1091dc62be3 100644 (file)
@@ -468,6 +468,7 @@ CONFIG_UBIFS_FS_LZO=y
 CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UEVENT_HELPER_PATH=""
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
 # CONFIG_USB_EHCI_HCD is not set
index 9481d0a3cf934282268391382cfb28c8f80aaef5..eb821ff706d5e66e37340baa2d7f5089c651700c 100644 (file)
@@ -325,6 +325,7 @@ CONFIG_UBIFS_FS_ADVANCED_COMPR=y
 CONFIG_UBIFS_FS_LZO=y
 CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
 CONFIG_USB_EHCI_HCD=y
index 2128e27b8f19be24347676c0cfcb683af14f0048..bbb2101390391cda2706c0b2cc2b772a7524bd67 100644 (file)
@@ -735,6 +735,7 @@ CONFIG_UCS2_STRING=y
 CONFIG_UEVENT_HELPER_PATH=""
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
 CONFIG_UNIX_DIAG=y
+CONFIG_UNWINDER_ARM=y
 CONFIG_UPROBES=y
 CONFIG_UPROBE_EVENTS=y
 CONFIG_USB_SUPPORT=y
index 54e6d4cd9d29eab7fe7f580632ae53f8dbd8acfc..82ed5b91bacd747272d5fdc2fa621d61389cc45a 100644 (file)
@@ -898,6 +898,7 @@ CONFIG_UIO_SERCOS3=y
 CONFIG_UNINLINE_SPIN_UNLOCK=y
 CONFIG_UNIX_DIAG=y
 CONFIG_UNMAP_KERNEL_AT_EL0=y
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB_SUPPORT=y
 # CONFIG_USERIO is not set
 CONFIG_USER_NS=y
index eab9aa247f22ca201ef36851ccc448fe99f0f6e8..14ca8ac86e8c14e33a08d9737695bdc52e200cd3 100644 (file)
@@ -428,6 +428,7 @@ CONFIG_TIMER_PROBE=y
 CONFIG_TREE_RCU=y
 CONFIG_TREE_SRCU=y
 # CONFIG_UNMAP_KERNEL_AT_EL0 is not set
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
 # CONFIG_USB_EHCI_HCD is not set
index c2133d026f89f85f92ec520f9b5e93ba13c97c74..7dd87b68c499f06b2106fe3bb0e5f40825a1ea60 100644 (file)
@@ -481,6 +481,7 @@ CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UEVENT_HELPER_PATH=""
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
 CONFIG_UNINLINE_SPIN_UNLOCK=y
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
 # CONFIG_USB_EHCI_HCD is not set
index 7a0caeeb61205a32522331bcf9f9c817253d82a6..ab2e9dfa9950ae6cd3d1b5893ba523af6b9b148a 100644 (file)
@@ -471,6 +471,7 @@ CONFIG_UBIFS_FS=y
 CONFIG_UBIFS_FS_LZO=y
 CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
 CONFIG_USB_EHCI_HCD=y
index df5f6f341bf0a5ecbbd51c8f51534cdb6c9c18ec..46daf41ed29a584b9e385c7e9dfe14426e3c67d8 100644 (file)
@@ -110,4 +110,5 @@ CONFIG_SYSCTL_EXCEPTION_TRACE=y
 CONFIG_SYS_SUPPORTS_HUGETLBFS=y
 CONFIG_THREAD_INFO_IN_TASK=y
 CONFIG_UNMAP_KERNEL_AT_EL0=y
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_VMAP_STACK=y
index f9bcefc4c511964935103923ed88ed350e7c4cd3..3dd8bafdbf142c6ed0e37be5199ce7c094c2ec24 100644 (file)
@@ -118,4 +118,5 @@ CONFIG_SYSCTL_EXCEPTION_TRACE=y
 CONFIG_SYS_SUPPORTS_HUGETLBFS=y
 CONFIG_THREAD_INFO_IN_TASK=y
 CONFIG_UNMAP_KERNEL_AT_EL0=y
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_VMAP_STACK=y
index abad1807cd8afe258e809add3e5f31b93fa7964d..842750040baa760e78a6b0d2cbde9efaa8ca1303 100644 (file)
@@ -288,6 +288,7 @@ CONFIG_TIMER_OF=y
 CONFIG_TIMER_PROBE=y
 CONFIG_TINY_SRCU=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB=y
 CONFIG_USB_CHIPIDEA=y
 CONFIG_USB_CHIPIDEA_HOST=y
index beb8ee647cec8e28725b53f8eb28d969a15e8406..203656bb32230078a1263fb3fbd0169dfc2e6a9d 100644 (file)
@@ -496,6 +496,7 @@ CONFIG_TASK_XACCT=y
 CONFIG_TEE=y
 CONFIG_THREAD_INFO_IN_TASK=y
 CONFIG_UNMAP_KERNEL_AT_EL0=y
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_THUNDER_NIC_BGX=y
 CONFIG_THUNDER_NIC_PF=y
 CONFIG_THUNDER_NIC_RGX=y
index 67a33d2b2364aee6c2470e5a92b4d65f3e2e3846..4466b8871bd44776cb57e1ade29d57977663401e 100644 (file)
@@ -697,6 +697,7 @@ CONFIG_UBIFS_FS_LZO=y
 CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
 CONFIG_UNINLINE_SPIN_UNLOCK=y
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
 CONFIG_USB_DWC3=y
index b0933405eaa434788a9ba8e8fc31c7fd9825c7e5..bd623e074351db54930b36f93c20cf77a7ad1af4 100644 (file)
@@ -340,6 +340,7 @@ CONFIG_TINY_SRCU=y
 CONFIG_TRACE_CLOCK=y
 CONFIG_UEVENT_HELPER_PATH=""
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB_SUPPORT=y
 # CONFIG_USERIO is not set
 CONFIG_USE_OF=y
index 548b1987150a8c9bf72b9d8bc7ed39ec7c0fe75b..7296cfdb554d87f6f65fe44f50c4018c931c12fc 100644 (file)
@@ -366,6 +366,7 @@ CONFIG_UBIFS_FS_LZO=y
 CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
 CONFIG_UNINLINE_SPIN_UNLOCK=y
+CONFIG_UNWINDER_ARM=y
 # CONFIG_USERIO is not set
 # CONFIG_USER_NS is not set
 CONFIG_USE_OF=y
index 6e19f1599b998648af2ecc9d375de19b59b9557e..b7575023417e25b0dc767bed6be4dc521a5432e2 100644 (file)
@@ -563,6 +563,7 @@ CONFIG_TOUCHSCREEN_SUN4I=y
 CONFIG_TREE_SRCU=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
 CONFIG_UNINLINE_SPIN_UNLOCK=y
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
 CONFIG_USB_COMMON=y
index 1ba379ea650976a3d30ea09824a2264242a4ed52..b47e7f2bafb1260833cd9765aad169eb3b02ca81 100644 (file)
@@ -99,4 +99,5 @@ CONFIG_SUN50I_ERRATUM_UNKNOWN1=y
 CONFIG_SYSCTL_EXCEPTION_TRACE=y
 CONFIG_THREAD_INFO_IN_TASK=y
 CONFIG_UNMAP_KERNEL_AT_EL0=y
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_VMAP_STACK=y
index 42547da301ea89cdc0ca9eea0ca6391ebf821ef7..e5603f62b5b9e47a1dc6504dbe6f59b5125bcb17 100644 (file)
@@ -529,6 +529,7 @@ CONFIG_TREE_RCU=y
 CONFIG_TREE_SRCU=y
 CONFIG_TRUSTED_FOUNDATIONS=y
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
+CONFIG_UNWINDER_FRAME_POINTER=y
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
 CONFIG_USB_EHCI_HCD=y
index fc33ca1b511ad717534bc1d35a4b43a6fa70071b..82f65da6c57a5e8f8105401ecd69e210791813f3 100644 (file)
@@ -604,6 +604,7 @@ CONFIG_UIO_PDRV_GENIRQ=y
 # CONFIG_UIO_SERCOS3 is not set
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
 CONFIG_UNINLINE_SPIN_UNLOCK=y
+CONFIG_UNWINDER_ARM=y
 CONFIG_USB=y
 CONFIG_USB_CHIPIDEA=y
 CONFIG_USB_CHIPIDEA_HOST=y