tools: b43-tools: fix compilation with GCC14
authorRobert Marko <robimarko@gmail.com>
Fri, 29 Mar 2024 17:57:03 +0000 (18:57 +0100)
committerRobert Marko <robimarko@gmail.com>
Sun, 28 Apr 2024 09:31:02 +0000 (11:31 +0200)
GCC14 no longer treats integer types and pointer types as equivalent in
assignments (including implied assignments of function arguments and return
values), and instead fails the compilation with a type error.

So, as a workaround lets disable the newly introduced error
-Werror=int-conversion and just make it print a warning to enable compiling
with GCC14 as Fedora 40 now defaults to it.

(cherry picked from commit 0c96d20bf9fba6d814efa88c6fb08a5df094103a)
Link: https://github.com/openwrt/openwrt/pull/15309
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/b43-tools/Makefile

index a99b0c9e53d2e6926844e4dac818b191784da99a..cf1f118c157f70f29c52feeea89997bbb1c2e05c 100644 (file)
@@ -26,7 +26,7 @@ define Host/Compile
                $(HOST_MAKE_FLAGS) \
                $(1) QUIET_SPARSE=:
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/assembler \
-               CFLAGS="$(HOST_CFLAGS) -include endian.h" \
+               CFLAGS="$(HOST_CFLAGS) -include endian.h -Wno-error=int-conversion" \
                $(HOST_MAKE_FLAGS) \
                LDFLAGS= \
                $(1) QUIET_SPARSE=: