ucode: update to latest Git HEAD
authorJo-Philipp Wich <jo@mein.io>
Mon, 5 Sep 2022 08:50:39 +0000 (10:50 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 14 Oct 2022 22:43:22 +0000 (00:43 +0200)
4ae7072 fs: use `getline()` for line wise read operations
21ace5e lexer: fixes for regex literal parsing
00965fa lib: implement slice() function
76d396d main: implement print mode
7bbba78 compiler: optimize function return opcode generation
a45f2a3 lexer: improve regex literal handling
d64d5d6 vm: maintain export symbol tables per program
f4b4ded uloop: task: gracefully handle absent output callback
a58fe47 ubus: hold reference to underlying connection until deferred is concluded
e23b58a lib: uc_system(): retry waitpid() on EINTR
cc4eb79 ubus: support obtaining numeric error code
01c412c ubus: add toplevel constants for ubus status codes
8e240fa ubus: allow object method call handlers to return a numeric status code
5cdddd3 lib: add limit support to split() and replace()
0ba9c3e fs: add optional third permission argument to fs.open()
c1f7b3b lib: remove fixed capture group limit in match() and regex replace()

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(backported from commits 639754e36d849553e288f8e34f51f793761c07db
 and 5110dcb1fa44fc1aac737c63b31474daa471de89)

package/utils/ucode/Makefile

index 025f99738702698f6622396f898b644e6a3247f4..54127582bd6a79bd1b6f0f4b17153e7d5dc2e896 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2022-08-29
-PKG_SOURCE_VERSION:=344fa9e69da43ecdc4d8f7768d85d42639352405
-PKG_MIRROR_HASH:=94e1ae6779536b2bd8957db8c2922ec32dcef75258401707505b1d34b6f16d0b
+PKG_SOURCE_DATE:=2022-10-07
+PKG_SOURCE_VERSION:=4ae70721aae5f974538928cadc71fa3269e5ad20
+PKG_MIRROR_HASH:=97339d563e988d57ed02f5fd27722c908d616c2cec8b1f0479f42bc53dfd0aa1
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC