tools/mkimage: build uboot with NO_SDL=1
authorChristian Marangi <ansuelsmth@gmail.com>
Sun, 22 Jan 2023 00:35:16 +0000 (01:35 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 22 Jan 2023 00:35:16 +0000 (01:35 +0100)
From uboot Documentation for uboot-2022.01 for tools-only we can build
with NO_SDL=1 to skip installing the sdl2 package.

Follow this to fix compilation error on macos

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
tools/mkimage/Makefile

index fd5dad0cd8378938d010d071ab270f720a8e4636..5473be7a91d32b5f65265ce46399588d2fb0bf35 100644 (file)
@@ -26,6 +26,7 @@ define Host/Compile
                HOSTLDFLAGS="$(HOST_LDFLAGS)" \
                PKG_CONFIG_EXTRAARGS="--static" \
                V=$(if $(findstring c,$(OPENWRT_VERBOSE)),1) \
+               NO_SDL=1 \
                tools-only_config \
                tools-only
 endef