make init script executable on target, fix category name
authorMirko Vogt <mirko@openwrt.org>
Mon, 22 Jun 2009 13:38:41 +0000 (13:38 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 22 Jun 2009 13:38:41 +0000 (13:38 +0000)
SVN-Revision: 16540

phone/fso-gpsd/Makefile

index 226f723ab02783b6410bc447ad0cfac0728ebfe6..0fea28343b0f76e824e94620a900d2543a5de915 100644 (file)
@@ -33,7 +33,7 @@ TARGET_LDFLAGS += \
 
 define Package/fso-gpsd
   SECTION:=phone
-  CATEGORY:=phone
+  CATEGORY:=Phone
   TITLE:=FSO gps daemon
   URL:=http://freesmartphone.org
   DEPENDS:=fso-frameworkd
@@ -50,8 +50,8 @@ endef
 
 define Package/fso-gpsd/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/fso-gpsd $(1)/usr/sbin/
-       $(CP) ./files/fso-gpsd.init $(1)/etc/init.d/fso-gpsd
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fso-gpsd $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/fso-gpsd.init $(1)/etc/init.d/fso-gpsd
 endef
 
 $(eval $(call BuildPackage,fso-gpsd))