xdp-tools: fix wrong matching for OPENWRT_VERBOSE
authorChristian Marangi <ansuelsmth@gmail.com>
Fri, 3 May 2024 12:46:33 +0000 (14:46 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 3 May 2024 12:53:11 +0000 (14:53 +0200)
To enable verbose log for xdp-tools compilation, we check for "c" in
the OPENWRT_VERBOSE, but verbose.mk supports only "w" and "s" for V=1
and V=99.

Fix the wrong matching and correctly enable verbose output matching for
"s".

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/network/utils/xdp-tools/Makefile

index 8484ca758b0b4d577c05378a674819ecfc313648..8a839954e9b73c6ec36c89430c472276232cb30a 100644 (file)
@@ -89,7 +89,7 @@ CONFIGURE_VARS += \
        LLC="$(LLVM_LLC)" \
        BPF_LDFLAGS="-march=$(BPF_TARGET) -mcpu=v3"
 
-ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+ifneq ($(findstring s,$(OPENWRT_VERBOSE)),)
        MAKE_FLAGS+=V=1
 endif