remove now redundant +USE_EGLIBC:librt dependencies
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 19 Sep 2012 15:35:00 +0000 (15:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 19 Sep 2012 15:35:00 +0000 (15:35 +0000)
SVN-Revision: 33481

libs/curl/Makefile
libs/glib2/Makefile
net/bird/Makefile
net/ntpd/Makefile
net/samba36/Makefile
net/uhub/Makefile

index c84363f25c5a55695892f27e5cc92384bdddbf54..6152eeea17f99e21a18baed524a238491a6de504 100644 (file)
@@ -43,7 +43,7 @@ define Package/libcurl
   $(call Package/curl/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libopenssl +zlib +USE_EGLIBC:librt
+  DEPENDS:=+libopenssl +zlib
   TITLE:=A client-side URL transfer library
 endef
 
index f17ad0e3f77997cc959e8c05340f8c9338305cdd..21a74260cb56f857c818b414899925a5ab3f882d 100644 (file)
@@ -30,7 +30,7 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/glib2
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread +USE_EGLIBC:librt
+  DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread
   TITLE:=glib 2.0
   URL:=http://www.gtk.org/
 endef
index b5fcf959be9b2a484278b4dea6039c25deabfc53..9658b62ce92690520390042c7b57702c42b6b240 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/bird/Default
   TITLE:=The BIRD Internet Routing Daemon
   URL:=http://bird.network.cz/
-  DEPENDS:= +USE_EGLIBC:librt
+  DEPENDS:=
 endef
 
 define Package/birdc/Default
index a1f17d77c5ad3adaaf5f50e27dbf20e7c57b218c..514b6744dc53b1aea1374a78de1b64f10043b5a1 100644 (file)
@@ -30,7 +30,7 @@ define Package/ntpd/Default
   TITLE:=ISC ntp
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
   URL:=http://www.ntp.org/
-  DEPENDS:=+libcap +USE_EGLIBC:librt
+  DEPENDS:=+libcap
 endef
 
 define Package/ntpd/Default/description
index edeccc845fd02b27dc06f2dbc40f1ce93cf40b73..2a6b6b69719a325b9d714e2de069a779b4f8d7fc 100644 (file)
@@ -36,7 +36,7 @@ define Package/samba36-client
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS client
   URL:=http://www.samba.org/
-  DEPENDS:=+libreadline +libncurses +USE_EGLIBC:librt
+  DEPENDS:=+libreadline +libncurses
 endef
 
 define Package/samba36-server/config
index 1e00579462432c4601860e941c7a15ee1a3227b8..9b5bcb04e326d866bab437781a8b4295d682cc75 100644 (file)
@@ -21,7 +21,7 @@ define Package/uhub
   SUBMENU:=P2P
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent +USE_EGLIBC:librt
+  DEPENDS:=+libevent
   TITLE:=High performance ADC hub
   URL:=http://www.extatic.org/uhub/
 endef