gst-ffmpeg: merge [28440]
authorNicolas Thill <nico@openwrt.org>
Thu, 13 Oct 2011 13:18:53 +0000 (13:18 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 13 Oct 2011 13:18:53 +0000 (13:18 +0000)
SVN-Revision: 28441

multimedia/gst-ffmpeg/Makefile

index 663244f0a9b40bf14a332dc4a483f37f8ee90fb8..3d6841afddeec70a9bd1a997cee56c9bd9495fb5 100644 (file)
@@ -134,7 +134,7 @@ GST_VERSION:=0.10
 
 CONFIGURE_ARGS += \
        --with-ffmpeg-extra-configure="--target-os=linux \
-                --disable-bsfs \
+               --disable-bsfs \
                --disable-devices \
                --disable-encoders \
                $(FFMPEG_CONFIGURE_ENCODERS) \
@@ -149,6 +149,10 @@ CONFIGURE_ARGS += \
                --disable-protocols \
                $(FFMPEG_CONFIGURE_PROTOCOLS)"
 
+# XXX: trick to force use of embedded FFmpeg headers
+TARGET_CFLAGS += $(TARGET_CPPFLAGS)
+TARGET_CPPFLAGS :=
+
 TARGET_LDFLAGS += $(FPIC)
 
 define Build/Prepare