rename <fso> to <fso-frameworkd> because there are more fso-projects going on and...
authorMirko Vogt <mirko@openwrt.org>
Sat, 13 Jun 2009 13:48:26 +0000 (13:48 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 13 Jun 2009 13:48:26 +0000 (13:48 +0000)
SVN-Revision: 16430

12 files changed:
phone/fso-frameworkd/Makefile [new file with mode: 0644]
phone/fso-frameworkd/files/frameworkd.conf [new file with mode: 0644]
phone/fso-frameworkd/files/frameworkd.conf.om_gta02 [new file with mode: 0644]
phone/fso-frameworkd/files/frameworkd.init [new file with mode: 0644]
phone/fso-frameworkd/patches/001-multilibc.patch [new file with mode: 0644]
phone/fso-frameworkd/patches/010-disable-display-brightness-control.patch [new file with mode: 0644]
phone/fso/Makefile [deleted file]
phone/fso/files/frameworkd.conf [deleted file]
phone/fso/files/frameworkd.conf.om_gta02 [deleted file]
phone/fso/files/frameworkd.init [deleted file]
phone/fso/patches/001-multilibc.patch [deleted file]
phone/fso/patches/010-disable-display-brightness-control.patch [deleted file]

diff --git a/phone/fso-frameworkd/Makefile b/phone/fso-frameworkd/Makefile
new file mode 100644 (file)
index 0000000..cf55d13
--- /dev/null
@@ -0,0 +1,62 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fso-frameworkd
+PKG_VERSION:=20090609
+PKG_REV:=74fc21962e9bbc7f2a89c74f12c15ce1b5861bfb
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=git://git.freesmartphone.org/framework.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+
+PKG_BUILD_DEPENDS:=cython python
+
+include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+
+ifeq ($(CONFIG_TARGET_s3c24xx),y)
+  CONFIG=om_gta02
+endif
+
+define Package/fso-frameworkd
+  SECTION:=phone
+  CATEGORY:=Phone
+  TITLE:=framework for the freesmartphone.org DBus API reference implementation
+  DEPENDS:=+python +dbus-python +python-gobject +pyserial +pyyaml \
+           +gst-python +alsa-utils +freerunner-alsa-scenarios
+  URL:=http://www.freesmartphone.org
+endef
+
+define Package/fso-frameworkd/description
+  freesmartphone.org is a collaboration platform for open source and open discussion software projects working on interoperability and shared technology for Linux-based SmartPhones
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/fso-frameworkd/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR) $(1)/usr/bin $(1)/etc/init.d
+       $(CP) \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+               $(1)$(PYTHON_PKG_DIR)
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/* \
+               $(1)/usr/bin/
+       $(INSTALL_BIN) ./files/frameworkd.init $(1)/etc/init.d/frameworkd
+       $(CP) \
+               $(PKG_INSTALL_DIR)/../etc/* \
+               $(1)/etc/
+       $(if $(CONFIG),$(INSTALL_CONF) ./files/frameworkd.conf.$(CONFIG) $(1)/etc/frameworkd.conf,$(CP) ./files/frameworkd.conf $(1)/etc/frameworkd.conf)
+endef
+
+$(eval $(call BuildPackage,fso-frameworkd))
diff --git a/phone/fso-frameworkd/files/frameworkd.conf b/phone/fso-frameworkd/files/frameworkd.conf
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/phone/fso-frameworkd/files/frameworkd.conf.om_gta02 b/phone/fso-frameworkd/files/frameworkd.conf.om_gta02
new file mode 100644 (file)
index 0000000..ca223c3
--- /dev/null
@@ -0,0 +1,55 @@
+[frameworkd]
+version = 1
+log_level = INFO
+log_to = file
+log_destination = /var/log/frameworkd.log 
+
+[odeviced.audio]
+# set default alsa scenario
+default_scenario = stereoout
+# set path to alsa scenario files
+scenario_dir = /usr/share/openmoko/scenarios
+
+[odeviced.idlenotifier]
+# don't read from accellerometers for GTA02
+ignoreinput=2,3
+
+[odeviced.input]
+# don't read from accellerometers for GTA02
+ignoreinput=2,3
+# keys
+report1 = AUX,key,169,1
+report2 = POWER,key,116,1
+report3 = USB,key,356,0
+report4 = HEADSET,switch,2,0
+
+# disable accelerometer since it uses LOADS of CPU resources
+[odeviced.accelerometer]
+disable = 1
+accelerometer_type = gta02
+
+[ogsmd]
+# GTA02 has TI Calypso
+modemtype = ti_calypso
+ti_calypso_deep_sleep = never
+
+[ogpsd]
+device = GTA02Device
+channel = SerialChannel
+path = /dev/ttySAC1
+
+[opreferencesd]
+rootdir = ../etc/freesmartphone/opreferences:/etc/freesmartphone/opreferences:/usr/etc/freesmartphone/opreferences
+
+[oeventsd]
+rules_file = ../etc/freesmartphone/oevents/rules.yaml:/etc/freesmartphone/oevents/rules.yaml:/usr/etc/freesmartphone/oevents/rules.yaml
+
+[opimd]
+disable = 1
+
+#[otimed]
+## a list of time/zone sources to use or NONE
+#timesources = GPS,NTP
+#zonesources = GSM
+## use an ip address here, otherwise DNS resolution will block
+#ntpserver = 134.169.172.1
diff --git a/phone/fso-frameworkd/files/frameworkd.init b/phone/fso-frameworkd/files/frameworkd.init
new file mode 100644 (file)
index 0000000..28fb4d2
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2008 OpenWrt.org
+START=80
+
+start() {
+    /usr/bin/frameworkd &
+}
+    
+stop() {
+    killall frameworkd
+}
diff --git a/phone/fso-frameworkd/patches/001-multilibc.patch b/phone/fso-frameworkd/patches/001-multilibc.patch
new file mode 100644 (file)
index 0000000..03548d6
--- /dev/null
@@ -0,0 +1,56 @@
+diff -ruN fso-20090103.orig/framework/cxnet/common.py fso-20090103/framework/cxnet/common.py
+--- fso-20090103.orig/framework/cxnet/common.py        2009-01-05 10:09:43.000000000 +0100
++++ fso-20090103/framework/cxnet/common.py     2009-01-07 11:10:52.000000000 +0100
+@@ -38,7 +38,14 @@
+ else:
+       cx_int = c_uint64
+-libc = CDLL("libc.so.6")
++from os import listdir
++from re import compile
++re = compile('^libc.so.[0-9]$')
++libs = listdir('/lib')
++for lib in libs:
++      if re.match(lib):
++              libc = CDLL(lib)
++              break
+ def hdump(name,msg,size=0):
+       """
+diff -ruN fso-20090103.orig/framework/patterns/kobject.py fso-20090103/framework/patterns/kobject.py
+--- fso-20090103.orig/framework/patterns/kobject.py    2009-01-05 10:09:43.000000000 +0100
++++ fso-20090103/framework/patterns/kobject.py 2009-01-07 13:37:58.000000000 +0100
+@@ -88,7 +88,13 @@
+             self._watchR = gobject.io_add_watch( self._socketR.fileno(), gobject.IO_IN, self._onActivityR )
+         # for rtnetlink assistance
+-        self._libc = ctypes.CDLL( "libc.so.6" )
++        from re import compile
++        re = compile('^libc.so.[0-9]$')
++        libs = os.listdir('/lib')
++        for lib in libs:
++            if re.match(lib):
++                self._libc = ctypes.CDLL(lib)
++                break
+         self._parser = RtNetlinkParser()
+     def __del__( self ):
+Binary files fso-20090103.orig/framework/patterns/.kobject.py.swp and fso-20090103/framework/patterns/.kobject.py.swp differ
+diff -ruN fso-20090103.orig/framework/subsystems/odeviced/pyglet/linux.py fso-20090103/framework/subsystems/odeviced/pyglet/linux.py
+--- fso-20090103.orig/framework/subsystems/odeviced/pyglet/linux.py    2009-01-05 10:09:43.000000000 +0100
++++ fso-20090103/framework/subsystems/odeviced/pyglet/linux.py 2009-01-07 12:15:13.000000000 +0100
+@@ -15,7 +15,13 @@
+ import struct
+ import sys
+-c = ctypes.cdll.LoadLibrary('libc.so.6')
++from re import compile
++re = compile('^libc.so.[0-9]$')
++libs = os.listdir('/lib')
++for lib in libs:
++    if re.match(lib):
++        c = ctypes.cdll.LoadLibrary(lib)
++        break
+ _IOC_NRBITS = 8
+ _IOC_TYPEBITS = 8
diff --git a/phone/fso-frameworkd/patches/010-disable-display-brightness-control.patch b/phone/fso-frameworkd/patches/010-disable-display-brightness-control.patch
new file mode 100644 (file)
index 0000000..03d155d
--- /dev/null
@@ -0,0 +1,18 @@
+diff -ruN fso-20090609.orig/etc/freesmartphone/oevents/rules.yaml fso-20090609/etc/freesmartphone/oevents/rules.yaml
+--- fso-20090609.orig/etc/freesmartphone/oevents/rules.yaml    2009-06-10 15:55:56.000000000 +0200
++++ fso-20090609/etc/freesmartphone/oevents/rules.yaml 2009-06-10 15:57:00.000000000 +0200
+@@ -133,14 +133,3 @@
+     #
+     # Idleness Brightness Handling
+     #
+-    trigger: IdleState()
+-    filters: HasAttr(status, "busy")
+-    actions: SetDisplayBrightness("0", 90)
+--
+-    trigger: IdleState()
+-    filters: HasAttr(status, "idle_dim")
+-    actions: SetDisplayBrightness("0", 20)
+--
+-    trigger: IdleState()
+-    filters: HasAttr(status, "idle_prelock")
+-    actions: SetDisplayBrightness("0", 0)
diff --git a/phone/fso/Makefile b/phone/fso/Makefile
deleted file mode 100644 (file)
index d875d73..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=fso
-PKG_VERSION:=20090609
-PKG_REV:=74fc21962e9bbc7f2a89c74f12c15ce1b5861bfb
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=git://git.freesmartphone.org/framework.git
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=$(PKG_REV)
-
-PKG_BUILD_DEPENDS:=cython python
-
-include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-
-ifeq ($(CONFIG_TARGET_s3c24xx),y)
-  CONFIG=om_gta02
-endif
-
-define Package/fso
-  SECTION:=phone
-  CATEGORY:=Phone
-  TITLE:=freesmartphone.org DBus API reference implementation
-  DEPENDS:=+python +dbus-python +python-gobject +pyserial +pyyaml \
-           +gst-python +alsa-utils +freerunner-alsa-scenarios
-  URL:=http://www.freesmartphone.org
-endef
-
-define Package/fso/description
-  freesmartphone.org is a collaboration platform for open source and open discussion software projects working on interoperability and shared technology for Linux-based SmartPhones
-endef
-
-define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
-endef
-
-define Package/fso/install
-       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR) $(1)/usr/bin $(1)/etc/init.d
-       $(CP) \
-               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-               $(1)$(PYTHON_PKG_DIR)
-       $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/usr/bin/* \
-               $(1)/usr/bin/
-       $(INSTALL_BIN) ./files/frameworkd.init $(1)/etc/init.d/frameworkd
-       $(CP) \
-               $(PKG_INSTALL_DIR)/../etc/* \
-               $(1)/etc/
-       $(if $(CONFIG),$(INSTALL_CONF) ./files/frameworkd.conf.$(CONFIG) $(1)/etc/frameworkd.conf,$(CP) ./files/frameworkd.conf $(1)/etc/frameworkd.conf)
-endef
-
-$(eval $(call BuildPackage,fso))
diff --git a/phone/fso/files/frameworkd.conf b/phone/fso/files/frameworkd.conf
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/phone/fso/files/frameworkd.conf.om_gta02 b/phone/fso/files/frameworkd.conf.om_gta02
deleted file mode 100644 (file)
index ca223c3..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-[frameworkd]
-version = 1
-log_level = INFO
-log_to = file
-log_destination = /var/log/frameworkd.log 
-
-[odeviced.audio]
-# set default alsa scenario
-default_scenario = stereoout
-# set path to alsa scenario files
-scenario_dir = /usr/share/openmoko/scenarios
-
-[odeviced.idlenotifier]
-# don't read from accellerometers for GTA02
-ignoreinput=2,3
-
-[odeviced.input]
-# don't read from accellerometers for GTA02
-ignoreinput=2,3
-# keys
-report1 = AUX,key,169,1
-report2 = POWER,key,116,1
-report3 = USB,key,356,0
-report4 = HEADSET,switch,2,0
-
-# disable accelerometer since it uses LOADS of CPU resources
-[odeviced.accelerometer]
-disable = 1
-accelerometer_type = gta02
-
-[ogsmd]
-# GTA02 has TI Calypso
-modemtype = ti_calypso
-ti_calypso_deep_sleep = never
-
-[ogpsd]
-device = GTA02Device
-channel = SerialChannel
-path = /dev/ttySAC1
-
-[opreferencesd]
-rootdir = ../etc/freesmartphone/opreferences:/etc/freesmartphone/opreferences:/usr/etc/freesmartphone/opreferences
-
-[oeventsd]
-rules_file = ../etc/freesmartphone/oevents/rules.yaml:/etc/freesmartphone/oevents/rules.yaml:/usr/etc/freesmartphone/oevents/rules.yaml
-
-[opimd]
-disable = 1
-
-#[otimed]
-## a list of time/zone sources to use or NONE
-#timesources = GPS,NTP
-#zonesources = GSM
-## use an ip address here, otherwise DNS resolution will block
-#ntpserver = 134.169.172.1
diff --git a/phone/fso/files/frameworkd.init b/phone/fso/files/frameworkd.init
deleted file mode 100644 (file)
index 28fb4d2..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
-START=80
-
-start() {
-    /usr/bin/frameworkd &
-}
-    
-stop() {
-    killall frameworkd
-}
diff --git a/phone/fso/patches/001-multilibc.patch b/phone/fso/patches/001-multilibc.patch
deleted file mode 100644 (file)
index 03548d6..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-diff -ruN fso-20090103.orig/framework/cxnet/common.py fso-20090103/framework/cxnet/common.py
---- fso-20090103.orig/framework/cxnet/common.py        2009-01-05 10:09:43.000000000 +0100
-+++ fso-20090103/framework/cxnet/common.py     2009-01-07 11:10:52.000000000 +0100
-@@ -38,7 +38,14 @@
- else:
-       cx_int = c_uint64
--libc = CDLL("libc.so.6")
-+from os import listdir
-+from re import compile
-+re = compile('^libc.so.[0-9]$')
-+libs = listdir('/lib')
-+for lib in libs:
-+      if re.match(lib):
-+              libc = CDLL(lib)
-+              break
- def hdump(name,msg,size=0):
-       """
-diff -ruN fso-20090103.orig/framework/patterns/kobject.py fso-20090103/framework/patterns/kobject.py
---- fso-20090103.orig/framework/patterns/kobject.py    2009-01-05 10:09:43.000000000 +0100
-+++ fso-20090103/framework/patterns/kobject.py 2009-01-07 13:37:58.000000000 +0100
-@@ -88,7 +88,13 @@
-             self._watchR = gobject.io_add_watch( self._socketR.fileno(), gobject.IO_IN, self._onActivityR )
-         # for rtnetlink assistance
--        self._libc = ctypes.CDLL( "libc.so.6" )
-+        from re import compile
-+        re = compile('^libc.so.[0-9]$')
-+        libs = os.listdir('/lib')
-+        for lib in libs:
-+            if re.match(lib):
-+                self._libc = ctypes.CDLL(lib)
-+                break
-         self._parser = RtNetlinkParser()
-     def __del__( self ):
-Binary files fso-20090103.orig/framework/patterns/.kobject.py.swp and fso-20090103/framework/patterns/.kobject.py.swp differ
-diff -ruN fso-20090103.orig/framework/subsystems/odeviced/pyglet/linux.py fso-20090103/framework/subsystems/odeviced/pyglet/linux.py
---- fso-20090103.orig/framework/subsystems/odeviced/pyglet/linux.py    2009-01-05 10:09:43.000000000 +0100
-+++ fso-20090103/framework/subsystems/odeviced/pyglet/linux.py 2009-01-07 12:15:13.000000000 +0100
-@@ -15,7 +15,13 @@
- import struct
- import sys
--c = ctypes.cdll.LoadLibrary('libc.so.6')
-+from re import compile
-+re = compile('^libc.so.[0-9]$')
-+libs = os.listdir('/lib')
-+for lib in libs:
-+    if re.match(lib):
-+        c = ctypes.cdll.LoadLibrary(lib)
-+        break
- _IOC_NRBITS = 8
- _IOC_TYPEBITS = 8
diff --git a/phone/fso/patches/010-disable-display-brightness-control.patch b/phone/fso/patches/010-disable-display-brightness-control.patch
deleted file mode 100644 (file)
index 03d155d..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -ruN fso-20090609.orig/etc/freesmartphone/oevents/rules.yaml fso-20090609/etc/freesmartphone/oevents/rules.yaml
---- fso-20090609.orig/etc/freesmartphone/oevents/rules.yaml    2009-06-10 15:55:56.000000000 +0200
-+++ fso-20090609/etc/freesmartphone/oevents/rules.yaml 2009-06-10 15:57:00.000000000 +0200
-@@ -133,14 +133,3 @@
-     #
-     # Idleness Brightness Handling
-     #
--    trigger: IdleState()
--    filters: HasAttr(status, "busy")
--    actions: SetDisplayBrightness("0", 90)
---
--    trigger: IdleState()
--    filters: HasAttr(status, "idle_dim")
--    actions: SetDisplayBrightness("0", 20)
---
--    trigger: IdleState()
--    filters: HasAttr(status, "idle_prelock")
--    actions: SetDisplayBrightness("0", 0)