Makefile: clean image.map
authorJagan Teki <jagan@amarulasolutions.com>
Tue, 7 May 2019 18:52:10 +0000 (00:22 +0530)
committerKever Yang <kever.yang@rock-chips.com>
Wed, 26 Jun 2019 13:11:27 +0000 (21:11 +0800)
binman tools for creating single image build will create image.map
at the end, which has information about binman image node details.

current u-boot, is unable to clean this image.map so add a command
entry in clean target in Makefile.

Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
Reviewed-by: Kever Yang <kever.yang@rock-chips.com>
Makefile

index 6335834d12e1e36b9ef750b89e9f2aae50bce3d0..a90dd2a6052b2786e062106e1e60858f1665bb2b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1847,7 +1847,8 @@ clean: $(clean-dirs)
                -o -name modules.builtin -o -name '.tmp_*.o.*' \
                -o -name 'dsdt.aml' -o -name 'dsdt.asl.tmp' -o -name 'dsdt.c' \
                -o -name '*.efi' -o -name '*.gcno' -o -name '*.so' \) \
-               -type f -print | xargs rm -f
+               -type f -print | xargs rm -f \
+               image.map
 
 # mrproper - Delete all generated files, including .config
 #