snort3: fix bug with unset variable
authorEric Fahlgren <ericfahlgren@gmail.com>
Tue, 9 Apr 2024 14:23:46 +0000 (07:23 -0700)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Sat, 27 Apr 2024 10:28:14 +0000 (12:28 +0200)
  - Parameter not set in two places:
    /usr/bin/snort-mgr: eval: line 125: options: parameter not set

Reported-by: @klingon888
Signed-off-by: Eric Fahlgren <ericfahlgren@gmail.com>
net/snort3/Makefile
net/snort3/files/snort-mgr

index 48ce85b456df0feb86d277f8254a16b4cb086649..a8552428b7caf372041e06f72b5c7c666123bd10 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=snort3
 PKG_VERSION:=3.1.84.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
index 1fc54ca127d27703a2c8bb8e7dd972819a7bc5a8..3ea1b3e4d34131e92a30e277f2649a67a1d3d411 100644 (file)
@@ -54,7 +54,7 @@ nft_rm_table() {
 
 nft_add_table() {
        if [ "$(uci -q get snort.snort.method)" = "nfq" ]; then
-               local options
+               local options=''
                $VERBOSE && options='-e'
                print nftables | nft $options -f $STDIN
                $VERBOSE && nft list table inet snort
@@ -118,7 +118,7 @@ check() {
        fi
 
        if [ "$(uci -q get snort.snort.method)" = "nfq" ]; then
-               local options
+               local options=''
                local test_nft="${CONF_DIR}/test_conf.nft"
                print nftables > "${test_nft}" || die "Errors during generation of nftables config"
                $VERBOSE && options='-e'